summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD38
2 files changed, 32 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 732a5fa63d62..1c427ba650b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,31 @@
pkgbase = r-dose
pkgdesc = Disease Ontology Semantic and Enrichment analysis
- pkgver = 3.28.0
+ pkgver = 3.28.1
pkgrel = 1
url = https://bioconductor.org/packages/DOSE
arch = any
license = Artistic2.0
- depends = r
+ checkdepends = r-testthat
depends = r-annotationdbi
depends = r-biocparallel
depends = r-fgsea
depends = r-ggplot2
depends = r-gosemsim
depends = r-hdo.db
- depends = r-hpo.db
- depends = r-mpo.db
depends = r-qvalue
depends = r-reshape2
+ depends = r-yulab.utils
optdepends = r-clusterprofiler
optdepends = r-gson
+ optdepends = r-hpo.db
optdepends = r-knitr
+ optdepends = r-mpo.db
optdepends = r-org.hs.eg.db
optdepends = r-prettydoc
optdepends = r-rmarkdown
optdepends = r-testthat
- source = https://bioconductor.org/packages/release/bioc/src/contrib/DOSE_3.28.0.tar.gz
- sha256sums = 9e6b7edb00748f605aaa0175fb038dacaa64aadef208e72975a0093ef55739f6
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/DOSE_3.28.1.tar.gz
+ md5sums = 11096edb2862c8a442f53435082e40b6
+ sha256sums = 77e86745c3ce54f36a79c35a3c5a6fa1f86090a10b66b0a5647f2d2c842db10a
pkgname = r-dose
diff --git a/PKGBUILD b/PKGBUILD
index 311a0f381296..95801381781b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,55 @@
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=DOSE
-_pkgver=3.28.0
+_pkgver=3.28.1
pkgname=r-${_pkgname,,}
-pkgver=3.28.0
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='Disease Ontology Semantic and Enrichment analysis'
-arch=('any')
+pkgdesc="Disease Ontology Semantic and Enrichment analysis"
+arch=(any)
url="https://bioconductor.org/packages/${_pkgname}"
-license=('Artistic2.0')
+license=(Artistic2.0)
depends=(
- r
r-annotationdbi
r-biocparallel
r-fgsea
r-ggplot2
r-gosemsim
r-hdo.db
- r-hpo.db
- r-mpo.db
r-qvalue
r-reshape2
+ r-yulab.utils
+)
+checkdepends=(
+ r-testthat
)
optdepends=(
r-clusterprofiler
r-gson
+ r-hpo.db
r-knitr
+ r-mpo.db
r-org.hs.eg.db
r-prettydoc
r-rmarkdown
r-testthat
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('9e6b7edb00748f605aaa0175fb038dacaa64aadef208e72975a0093ef55739f6')
+md5sums=('11096edb2862c8a442f53435082e40b6')
+sha256sums=('77e86745c3ce54f36a79c35a3c5a6fa1f86090a10b66b0a5647f2d2c842db10a')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: