summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 20 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f547529cc457..88297bfc7b78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = r-fixest
pkgdesc = Fast Fixed-Effects Estimations
- pkgver = 0.11.2
+ pkgver = 0.12.0
pkgrel = 1
url = https://cran.r-project.org/package=fixest
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
checkdepends = r-data.table
depends = r-dreamerr
depends = r-numderiv
depends = r-rcpp
depends = r-sandwich
+ depends = r-stringmagic
+ optdepends = r-aer
optdepends = r-data.table
+ optdepends = r-emmeans
+ optdepends = r-estimability
optdepends = r-ggplot2
optdepends = r-knitr
optdepends = r-lfe
@@ -19,8 +23,8 @@ pkgbase = r-fixest
optdepends = r-plm
optdepends = r-rmarkdown
optdepends = r-tinytex
- source = https://cran.r-project.org/src/contrib/fixest_0.11.2.tar.gz
- md5sums = 9d2027d25c8a0081b878554544caf58b
- sha256sums = 2dee113a0689e5c4dd842c451d35c9a94a5b37536f9484611a877c1ea10e2b65
+ source = https://cran.r-project.org/src/contrib/fixest_0.12.0.tar.gz
+ md5sums = aa85a1ad448d0f41fc02100eee502059
+ b2sums = e1cad001e1ce16953f560bc0f1f95dd8b9d829ab5240cc01aaed4648a0d5762eb305d33f2eb7c453290b697c587bdd96d10e9d39388a31c887b86c780899e1da
pkgname = r-fixest
diff --git a/PKGBUILD b/PKGBUILD
index 2e5c286389cf..c8af9a7c8445 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,29 @@
# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
_pkgname=fixest
-_pkgver=0.11.2
+_pkgver=0.12.0
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
pkgrel=1
pkgdesc="Fast Fixed-Effects Estimations"
arch=(x86_64)
-url="https://cran.r-project.org/package=${_pkgname}"
-license=(GPL3)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-3.0-only')
depends=(
r-dreamerr
r-numderiv
r-rcpp
r-sandwich
+ r-stringmagic
)
checkdepends=(
r-data.table
)
optdepends=(
+ r-aer
r-data.table
+ r-emmeans
+ r-estimability
r-ggplot2
r-knitr
r-lfe
@@ -30,12 +34,12 @@ optdepends=(
r-tinytex
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-md5sums=('9d2027d25c8a0081b878554544caf58b')
-sha256sums=('2dee113a0689e5c4dd842c451d35c9a94a5b37536f9484611a877c1ea10e2b65')
+md5sums=('aa85a1ad448d0f41fc02100eee502059')
+b2sums=('e1cad001e1ce16953f560bc0f1f95dd8b9d829ab5240cc01aaed4648a0d5762eb305d33f2eb7c453290b697c587bdd96d10e9d39388a31c887b86c780899e1da')
build() {
- mkdir -p build
- R CMD INSTALL "$_pkgname" -l build
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
check() {