summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD52
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ee9472b5ebe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = r-ggraph
+ pkgdesc = An Implementation of Grammar of Graphics for Graphs and Networks
+ pkgver = 2.0.5
+ pkgrel = 4
+ url = https://cran.r-project.org/package=ggraph
+ arch = x86_64
+ license = MIT
+ depends = r
+ depends = r-digest
+ depends = r-dplyr
+ depends = r-ggforce
+ depends = r-ggplot2
+ depends = r-ggrepel
+ depends = r-graphlayouts
+ depends = r-gtable
+ depends = r-igraph
+ depends = r-rcpp
+ depends = r-rlang
+ depends = r-scales
+ depends = r-tidygraph
+ depends = r-viridis
+ depends = r-withr
+ optdepends = r-covr
+ optdepends = r-deldir
+ optdepends = r-gganimate
+ optdepends = r-knitr
+ optdepends = r-network
+ optdepends = r-purrr
+ optdepends = r-rmarkdown
+ optdepends = r-seriation
+ optdepends = r-tibble
+ source = https://cran.r-project.org/src/contrib/ggraph_2.0.5.tar.gz
+ sha256sums = e36ad49dba92ee8652e18b1fb197be0ceb9f0a2f8faee2194453a62578449654
+
+pkgname = r-ggraph
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8bb977087b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=ggraph
+_pkgver=2.0.5
+pkgname=r-${_pkgname,,}
+pkgver=2.0.5
+pkgrel=4
+pkgdesc='An Implementation of Grammar of Graphics for Graphs and Networks'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-digest
+ r-dplyr
+ r-ggforce
+ r-ggplot2
+ r-ggrepel
+ r-graphlayouts
+ r-gtable
+ r-igraph
+ r-rcpp
+ r-rlang
+ r-scales
+ r-tidygraph
+ r-viridis
+ r-withr
+)
+optdepends=(
+ r-covr
+ r-deldir
+ r-gganimate
+ r-knitr
+ r-network
+ r-purrr
+ r-rmarkdown
+ r-seriation
+ r-tibble
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('e36ad49dba92ee8652e18b1fb197be0ceb9f0a2f8faee2194453a62578449654')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: