summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d33db7a73db7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = r-httpuv
+ pkgdesc = HTTP and WebSocket Server Library
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = https://cran.r-project.org/package=httpuv
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = r
+ depends = r-rcpp
+ depends = r-r6
+ depends = r-promises
+ depends = r-later
+ depends = r-bh
+ optdepends = r-testthat
+ optdepends = r-callr
+ optdepends = r-curl
+ source = http://cran.r-project.org/src/contrib/httpuv_1.5.1.tar.gz
+ md5sums = 74de6d002c3d47e5f693bbeab22e2056
+
+pkgname = r-httpuv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cff4512d721
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+_cranname=httpuv
+_cranver=1.5.1
+pkgname=r-${_cranname}
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="HTTP and WebSocket Server Library"
+arch=('i686' 'x86_64')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('GPL3')
+depends=('r' 'r-rcpp' 'r-r6' 'r-promises' 'r-later' 'r-bh')
+optdepends=('r-testthat' 'r-callr' 'r-curl')
+source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('74de6d002c3d47e5f693bbeab22e2056')
+
+build(){
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l $srcdir
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -dm0755 "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "$_cranname" "$pkgdir/usr/lib/R/library"
+}