summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD76
2 files changed, 68 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 775f43351829..7d8a37ab183f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = r-lazyeval
- pkgdesc = An alternative approach to non-standard evaluation using formulas. Provides a full implementation of LISP style 'quasiquotation', making it easier to generate code with other code.
+ pkgdesc = Lightweight Well-Known Geometry Parsing
pkgver = 0.2.2
- pkgrel = 1
+ pkgrel = 4
url = https://cran.r-project.org/package=lazyeval
arch = i686
arch = x86_64
- license = GPL-3
+ license = GPL3
depends = r>=3.1.0
- optdepends = r-knitr
- optdepends = r-rmarkdown
- optdepends = r-testthat
+ depends = r-cpp11
optdepends = r-covr
- source = http://cran.r-project.org/src/contrib/lazyeval_0.2.2.tar.gz
- md5sums = 1de725fe0cd496a2535020867458641a
+ optdepends = r-knitr
+ optdepends = r-rmarkdown>=0.2.65
+ source = https://cran.r-project.org/src/contrib/lazyeval_0.2.2.tar.gz
+ b2sums = 94f69fe95a8ef8bf98421ae8570c6d381183f242e6f74334ed1886033b0ec3228e25b5412b89fe97fd4268f77b6be1c3fbe0113035b1afdee398898c732d67ff
pkgname = r-lazyeval
-
diff --git a/PKGBUILD b/PKGBUILD
index 019461816806..8161b9fd72a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,65 @@
-# Maintainer: Matt Frichtl <frichtlm@gmail.com>
-# Contributer: wagnerflo <florian@wagner-flo.net>
+# Maintainer: peippo <christoph+aur@christophfink.com>
+# Contributor: Grey Christoforo <first name at last name dot net>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Matt Frichtl <frichtlm@gmail.com>
+# Contributor: wagnerflo <florian@wagner-flo.net>
+
_cranname=lazyeval
_cranver=0.2.2
-pkgname=r-$_cranname
-pkgver=${_cranver}
-pkgrel=1
-pkgdesc="An alternative approach to non-standard evaluation using formulas. Provides a full implementation of LISP style 'quasiquotation', making it easier to generate code with other code."
-url="https://cran.r-project.org/package=lazyeval"
-arch=('i686' 'x86_64')
-license=('GPL-3')
-depends=('r>=3.1.0')
-optdepends=('r-knitr' 'r-rmarkdown' 'r-testthat' 'r-covr')
-source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-md5sums=('1de725fe0cd496a2535020867458641a')
+pkgname=r-${_cranname,,}
+pkgdesc="Lightweight Well-Known Geometry Parsing"
+url="https://cran.r-project.org/package=${_cranname}"
+license=("GPL3")
+pkgver=${_cranver//[:-]/.}
+pkgrel=4
+
+arch=("i686" "x86_64")
+depends=(
+ "r>=3.1.0"
+ "r-cpp11"
+)
+optdepends=(
+ "r-covr"
+ "r-knitr"
+ "r-rmarkdown>=0.2.65"
+)
+
+# The unittests for `r-lazyeval` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-lazyeval`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat"
+# )
+
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+b2sums=("94f69fe95a8ef8bf98421ae8570c6d381183f242e6f74334ed1886033b0ec3228e25b5412b89fe97fd4268f77b6be1c3fbe0113035b1afdee398898c732d67ff")
+
+build() {
+ mkdir -p "${srcdir}/build/"
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
+}
+
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
- mkdir -p ${pkgdir}/usr/lib/R/library
- cd ${srcdir}
- R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
+ if [[ -f "${_cranname}/LICENSE" ]]; then
+ install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ fi
}