summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD7
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f485312c15c..775f43351829 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = r-lazyeval
pkgdesc = An alternative approach to non-standard evaluation using formulas. Provides a full implementation of LISP style 'quasiquotation', making it easier to generate code with other code.
- pkgver = 0.2.1
+ pkgver = 0.2.2
pkgrel = 1
- url = http://cran.r-project.org/web/packages/lazyeval/index.html
+ url = https://cran.r-project.org/package=lazyeval
arch = i686
arch = x86_64
license = GPL-3
depends = r>=3.1.0
- source = http://cran.r-project.org/src/contrib/lazyeval_0.2.1.tar.gz
- md5sums = e7f4dcf399829e6cf1e49371cc773085
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ optdepends = r-covr
+ source = http://cran.r-project.org/src/contrib/lazyeval_0.2.2.tar.gz
+ md5sums = 1de725fe0cd496a2535020867458641a
pkgname = r-lazyeval
diff --git a/PKGBUILD b/PKGBUILD
index a405b9d5def4..019461816806 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Matt Frichtl <frichtlm@gmail.com>
# Contributer: wagnerflo <florian@wagner-flo.net>
_cranname=lazyeval
-_cranver=0.2.1
+_cranver=0.2.2
pkgname=r-$_cranname
pkgver=${_cranver}
pkgrel=1
pkgdesc="An alternative approach to non-standard evaluation using formulas. Provides a full implementation of LISP style 'quasiquotation', making it easier to generate code with other code."
-url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
+url="https://cran.r-project.org/package=lazyeval"
arch=('i686' 'x86_64')
license=('GPL-3')
depends=('r>=3.1.0')
+optdepends=('r-knitr' 'r-rmarkdown' 'r-testthat' 'r-covr')
source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-md5sums=('e7f4dcf399829e6cf1e49371cc773085')
+md5sums=('1de725fe0cd496a2535020867458641a')
package() {
mkdir -p ${pkgdir}/usr/lib/R/library