summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 27 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf327ae5f9af..e59bc6a333bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = r-lifecycle
- pkgdesc = Manage the lifecycle of your exported functions with shared conventions, documentation badges, and non-invasive deprecation warnings.
- pkgver = 0.1.0
+ pkgdesc = Manage the Life Cycle of your Package Functions
+ pkgver = 0.2.0
pkgrel = 1
url = https://cran.r-project.org/package=lifecycle
- arch = i686
- arch = x86_64
- license = GPL-3
+ arch = any
+ license = GPL3
depends = r>=3.2
depends = r-glue
depends = r-rlang>=0.4.0
optdepends = r-covr
optdepends = r-crayon
optdepends = r-knitr
- optdepends = r-markdown
+ optdepends = r-rmarkdown
optdepends = r-testthat
- source = http://cran.r-project.org/src/contrib/lifecycle_0.1.0.tar.gz
- md5sums = a039f080eb1dc67a40ce92ddced20cac
+ source = https://cran.r-project.org/src/contrib/lifecycle_0.2.0.tar.gz
+ md5sums = 42f1d553553ad8f092a20817a3077a6f
pkgname = r-lifecycle
diff --git a/PKGBUILD b/PKGBUILD
index 3dd2c01700c3..304ab658b249 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
-# Maintainer: frichtlm <frichtlm@gmail.com>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: frichtlm <frichtlm@gmail.com>
+
_cranname=lifecycle
-_cranver=0.1.0
-pkgname=r-$_cranname
-pkgver=${_cranver}
+_cranver=0.2.0
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="Manage the lifecycle of your exported functions with shared conventions, documentation badges, and non-invasive deprecation warnings."
-url="https://cran.r-project.org/package=lifecycle"
-arch=('i686' 'x86_64')
-license=('GPL-3')
-depends=('r>=3.2' 'r-glue' 'r-rlang>=0.4.0')
-optdepends=('r-covr' 'r-crayon' 'r-knitr' 'r-markdown' 'r-testthat')
-source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-md5sums=('a039f080eb1dc67a40ce92ddced20cac')
+pkgdesc="Manage the Life Cycle of your Package Functions"
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(GPL3)
+depends=('r>=3.2' r-glue 'r-rlang>=0.4.0')
+optdepends=(r-covr r-crayon r-knitr r-rmarkdown r-testthat)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('42f1d553553ad8f092a20817a3077a6f')
build() {
- cd ${srcdir}
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l $srcdir
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
package() {
- cd "${srcdir}"
+ cd "${srcdir}"
- install -dm0755 "$pkgdir/usr/lib/R/library"
- cp -a --no-preserve=ownership "$_cranname" "$pkgdir/usr/lib/R/library"
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}