summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD34
2 files changed, 25 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b7d6055e2a2..d7dc78ecc39b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,11 @@
pkgbase = r-magrittr
pkgdesc = A Forward-Pipe Operator for R
pkgver = 2.0.3
- pkgrel = 2
+ pkgrel = 3
url = https://cran.r-project.org/package=magrittr
arch = i686
arch = x86_64
license = MIT
- checkdepends = r-covr
- checkdepends = r-knitr
- checkdepends = r-rlang
- checkdepends = r-rmarkdown
- checkdepends = r-testthat
depends = r>=3.4.0
optdepends = r-covr
optdepends = r-knitr
diff --git a/PKGBUILD b/PKGBUILD
index ca4aa8936cbf..7c3841c7f4cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgdesc="A Forward-Pipe Operator for R"
url="https://cran.r-project.org/package=${_cranname}"
license=("MIT")
pkgver=${_cranver//[:-]/.}
-pkgrel=2
+pkgrel=3
arch=("i686" "x86_64")
depends=(
@@ -21,10 +21,25 @@ optdepends=(
"r-rlang"
"r-rmarkdown"
)
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat"
-)
+
+# The unittests for `r-magrittr` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-magrittr`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
b2sums=("f4ebee352cc6e3de831d7a596d7f44b94bc77a19ad110fe53d6cb7d872bd71c0c83da7b6fad8063823fef6e42a12827b01cd2c5ce77b4e274a3abbcf68a0e772")
@@ -34,15 +49,14 @@ build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- cd "${srcdir}/${_cranname}/tests"
- R_LIBS="${srcdir}/build/" Rscript --vanilla testthat.R
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi