summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD14
-rw-r--r--fix-test-snapshot.patch64
3 files changed, 79 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc883fc4e17b..11b35c0c76d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = r-mariner
pkgdesc = Explore the Hi-Cs
- pkgver = 1.2.0
- pkgrel = 2
+ pkgver = 1.4.0
+ pkgrel = 1
url = https://bioconductor.org/packages/mariner
arch = any
- license = GPL3
+ license = GPL-3.0-only
checkdepends = r-marinerdata
checkdepends = r-testthat
depends = r-abind
@@ -39,11 +39,11 @@ pkgbase = r-mariner
optdepends = r-marinerdata
optdepends = r-rmarkdown
optdepends = r-testthat
- source = https://bioconductor.org/packages/release/bioc/src/contrib/mariner_1.2.0.tar.gz
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/mariner_1.4.0.tar.gz
source = fix-test-snapshot.patch
- md5sums = 6ed30878d03b8a17e8e7c4ee17218893
- md5sums = d0928c3ea11234e2200f31c9b4ff4ade
- b2sums = dfaa195e26df395d9948668e342bcc5bc2c593d42b102a7140cb6778fc904f171b561c7fe1d6bce1dbefbd22832b745888549f06eff42c5596455d48e2693db3
- b2sums = aba583ffb72fea9e7ce5820b8160418b345b87e1d93fe9533efeb5732011373bd18dfea4c16b49f869e0d698529f48f738bec528c77d67c1cf095e7656a6ca30
+ md5sums = 59fce5faa48236d0a9cd9bdda6480d3d
+ md5sums = b055713d876d7ea3e97a92a152bb5f28
+ b2sums = e2c553258972c7d24b907feab042be3fce9547636a6fbb1c264148002928b48fec581504e8281c214d076bdca3933eda08f9df6ad6f7b0d74d1e3847e8bee75f
+ b2sums = 6111457fda4b526e70b08ac62ec1ffd68dd8fe81d6d57cd715ef4f10a5156756d788043a924d9b3103958775cc28d02e0313947187a571907a9f6adf879148a1
pkgname = r-mariner
diff --git a/PKGBUILD b/PKGBUILD
index 3e45bf89800b..5fdbdd85ddbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
_pkgname=mariner
-_pkgver=1.2.0
+_pkgver=1.4.0
pkgname=r-${_pkgname,,}
pkgver=${_pkgver//-/.}
-pkgrel=2
+pkgrel=1
pkgdesc="Explore the Hi-Cs"
arch=(any)
url="https://bioconductor.org/packages/$_pkgname"
-license=(GPL3)
+license=('GPL-3.0-only')
depends=(
r-abind
r-assertthat
@@ -51,10 +51,10 @@ optdepends=(
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
"fix-test-snapshot.patch")
-md5sums=('6ed30878d03b8a17e8e7c4ee17218893'
- 'd0928c3ea11234e2200f31c9b4ff4ade')
-b2sums=('dfaa195e26df395d9948668e342bcc5bc2c593d42b102a7140cb6778fc904f171b561c7fe1d6bce1dbefbd22832b745888549f06eff42c5596455d48e2693db3'
- 'aba583ffb72fea9e7ce5820b8160418b345b87e1d93fe9533efeb5732011373bd18dfea4c16b49f869e0d698529f48f738bec528c77d67c1cf095e7656a6ca30')
+md5sums=('59fce5faa48236d0a9cd9bdda6480d3d'
+ 'b055713d876d7ea3e97a92a152bb5f28')
+b2sums=('e2c553258972c7d24b907feab042be3fce9547636a6fbb1c264148002928b48fec581504e8281c214d076bdca3933eda08f9df6ad6f7b0d74d1e3847e8bee75f'
+ '6111457fda4b526e70b08ac62ec1ffd68dd8fe81d6d57cd715ef4f10a5156756d788043a924d9b3103958775cc28d02e0313947187a571907a9f6adf879148a1')
prepare() {
# fix snapshot test
diff --git a/fix-test-snapshot.patch b/fix-test-snapshot.patch
index 9359df6e98fe..98f0098be528 100644
--- a/fix-test-snapshot.patch
+++ b/fix-test-snapshot.patch
@@ -65,3 +65,67 @@ index 492df25..e6645e7 100644
,,1,FS
[,1] [,2] [,3] ... [,10] [,11]
[1,] 0 0 0 . 0 0
+diff --git a/mariner/tests/testthat/_snaps/MergedGInteractions.md b/mariner/tests/testthat/_snaps/MergedGInteractions.md
+index f27c0ed..999e149 100644
+--- a/mariner/tests/testthat/_snaps/MergedGInteractions.md
++++ b/mariner/tests/testthat/_snaps/MergedGInteractions.md
+@@ -4,6 +4,7 @@
+ .mapIds(x)
+ Output
+ seqnames1 start1 end1 width1 strand1 seqnames2 start2 end2
++ <fctr> <int> <int> <int> <fctr> <fctr> <int> <int>
+ 1: chr9 118645000 118650000 5001 * chr9 119330000 119335000
+ 2: chr9 118645000 118650000 5001 * chr9 119330000 119335000
+ 3: chr17 80635000 80640000 5001 * chr17 80920000 80925000
+@@ -12,16 +13,18 @@
+ 6: chr9 14460000 14465000 5001 * chr9 14765000 14770000
+ 7: chr17 47645000 47650000 5001 * chr17 48075000 48080000
+ 8: chr17 47645000 47650000 5001 * chr17 48075000 48080000
+- width2 strand2 color APScoreAvg ProbabilityofEnrichment RegAPScoreAvg
+- 1: 5001 * 0,0,0 2.611034 0.9860443 1.414376
+- 2: 5001 * 0,0,0 2.611034 0.9860443 1.414376
+- 3: 5001 * 0,0,0 2.889573 0.9713564 1.379367
+- 4: 5001 * 0,0,0 2.889573 0.9713564 1.379367
+- 5: 5001 * 0,0,0 3.272132 0.9868535 2.233533
+- 6: 5001 * 0,0,0 3.272132 0.9868535 2.233533
+- 7: 5001 * 0,0,0 3.520431 0.9801694 2.433166
+- 8: 5001 * 0,0,0 3.520431 0.9801694 2.433166
++ width2 strand2 color APScoreAvg ProbabilityofEnrichment RegAPScoreAvg
++ <int> <fctr> <char> <num> <num> <num>
++ 1: 5001 * 0,0,0 2.611034 0.9860443 1.414376
++ 2: 5001 * 0,0,0 2.611034 0.9860443 1.414376
++ 3: 5001 * 0,0,0 2.889573 0.9713564 1.379367
++ 4: 5001 * 0,0,0 2.889573 0.9713564 1.379367
++ 5: 5001 * 0,0,0 3.272132 0.9868535 2.233533
++ 6: 5001 * 0,0,0 3.272132 0.9868535 2.233533
++ 7: 5001 * 0,0,0 3.520431 0.9801694 2.433166
++ 8: 5001 * 0,0,0 3.520431 0.9801694 2.433166
+ Avg_diffMaxNeihgboor_1 Avg_diffMaxNeihgboor_2 avg std value
++ <num> <num> <num> <num> <num>
+ 1: 1.8755854 2.121637 2.605124 0.7942202 4.272311
+ 2: 1.8755854 2.121637 2.605124 0.7942202 4.272311
+ 3: 1.9105295 1.946362 1.854944 0.6729783 3.553193
+@@ -30,13 +33,14 @@
+ 6: 1.0059373 1.645508 3.437883 0.5164226 4.332049
+ 7: 0.8104557 1.486894 3.200528 0.6733462 3.920933
+ 8: 0.8104557 1.486894 3.200528 0.6733462 3.920933
+- src id grp clst i.id
+- 1: FS 1 1 1 1
+- 2: FS 5 1 1 1
+- 3: FS 2 2 1 2
+- 4: FS 6 2 1 2
+- 5: WT 3 1 2 3
+- 6: WT 7 1 2 3
+- 7: WT 4 2 2 4
+- 8: WT 8 2 2 4
++ src id grp clst i.id
++ <char> <int> <int> <int> <int>
++ 1: FS 1 1 1 1
++ 2: FS 5 1 1 1
++ 3: FS 2 2 1 2
++ 4: FS 6 2 1 2
++ 5: WT 3 1 2 3
++ 6: WT 7 1 2 3
++ 7: WT 4 2 2 4
++ 8: WT 8 2 2 4
+