summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56b39fa07101
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = r-mus.musculus
+ pkgdesc = Annotation package for the Mus.musculus object
+ pkgver = 1.3.1
+ pkgrel = 3
+ url = https://bioconductor.org/packages/Mus.musculus
+ arch = any
+ license = Artistic2.0
+ depends = r
+ depends = r-annotationdbi
+ depends = r-genomicfeatures
+ depends = r-go.db
+ depends = r-org.mm.eg.db
+ depends = r-organismdbi
+ depends = r-txdb.mmusculus.ucsc.mm10.knowngene
+ source = https://bioconductor.org/packages/release/data/annotation/src/contrib/Mus.musculus_1.3.1.tar.gz
+ sha256sums = de48a49134a77de0e4cf3dcb2c895103170eff3baea52a9187d8ad37906b7f90
+
+pkgname = r-mus.musculus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..684229cf83a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=Mus.musculus
+_pkgver=1.3.1
+pkgname=r-${_pkgname,,}
+pkgver=1.3.1
+pkgrel=3
+pkgdesc='Annotation package for the Mus.musculus object'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('Artistic2.0')
+depends=(
+ r
+ r-annotationdbi
+ r-genomicfeatures
+ r-go.db
+ r-org.mm.eg.db
+ r-organismdbi
+ r-txdb.mmusculus.ucsc.mm10.knowngene
+)
+source=("https://bioconductor.org/packages/release/data/annotation/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('de48a49134a77de0e4cf3dcb2c895103170eff3baea52a9187d8ad37906b7f90')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: