summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
2 files changed, 43 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e46f1d4879a..7cce2ada5f30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,24 @@
pkgbase = r-proxyc
pkgdesc = Computes Proximity in Large Sparse Matrices
- pkgver = 0.3.1
+ pkgver = 0.4.1
pkgrel = 1
url = https://cran.r-project.org/package=proxyC
arch = x86_64
- license = GPL
- depends = r
+ license = GPL-3.0-only
+ checkdepends = r-entropy
+ checkdepends = r-proxy
+ checkdepends = r-testthat
+ makedepends = r-rcpparmadillo
+ depends = blas
+ depends = onetbb
depends = r-rcpp
- depends = r-rcpparmadillo
- depends = r-rcppparallel
optdepends = r-entropy
+ optdepends = r-knitr
optdepends = r-proxy
+ optdepends = r-rmarkdown
optdepends = r-testthat
- source = https://cran.r-project.org/src/contrib/proxyC_0.3.1.tar.gz
- sha256sums = 325ef827c4425c2846a60d43ae4392d1ad2057ffea6378fa5ec7531b5d6bb49f
+ source = https://cran.r-project.org/src/contrib/proxyC_0.4.1.tar.gz
+ md5sums = 6c6e79971fc1d393c1894bf387688965
+ b2sums = 920699dbf8875611087064f6dedcbc7b2cbc870ec73d03e124fbf9a9ac210aa49b770df9b95db77229c3e1c5a05b29bf009d70f043753a9c6d911fc2b77ac413
pkgname = r-proxyc
diff --git a/PKGBUILD b/PKGBUILD
index 7c0531983373..dab7eef21874 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,50 @@
-# system requirements: C++11
-# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=proxyC
-_pkgver=0.3.1
+_pkgver=0.4.1
pkgname=r-${_pkgname,,}
-pkgver=0.3.1
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='Computes Proximity in Large Sparse Matrices'
-arch=('x86_64')
-url="https://cran.r-project.org/package=${_pkgname}"
-license=('GPL')
+pkgdesc="Computes Proximity in Large Sparse Matrices"
+arch=(x86_64)
+url="https://cran.r-project.org/package=$_pkgname"
+license=('GPL-3.0-only')
depends=(
- r
+ blas
+ onetbb
r-rcpp
+)
+makedepends=(
r-rcpparmadillo
- r-rcppparallel
+)
+checkdepends=(
+ r-entropy
+ r-proxy
+ r-testthat
)
optdepends=(
r-entropy
+ r-knitr
r-proxy
+ r-rmarkdown
r-testthat
)
source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('325ef827c4425c2846a60d43ae4392d1ad2057ffea6378fa5ec7531b5d6bb49f')
+md5sums=('6c6e79971fc1d393c1894bf387688965')
+b2sums=('920699dbf8875611087064f6dedcbc7b2cbc870ec73d03e124fbf9a9ac210aa49b770df9b95db77229c3e1c5a05b29bf009d70f043753a9c6d911fc2b77ac413')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
+}
+
+check() {
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" NOT_CRAN=true Rscript --vanilla testthat.R
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: