summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93c88f8f1ae0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = r-r.utils
+ pkgdesc = Various Programming Utilities
+ pkgver = 2.9.2
+ pkgrel = 1
+ url = http://cran.r-project.org/web/packages/R.utils/index.html
+ arch = x86_64
+ license = LGPL3
+ depends = r
+ depends = r-oo
+ source = http://cran.r-project.org/src/contrib/R.utils_2.9.2.tar.gz
+ md5sums = 8629f732956b4f040429f2dccc533168
+
+pkgname = r-r.utils
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed3a1239243f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Grey Christoforo <first name at last name dot net>
+pkgname=r-r.utils
+_cran_name=R.utils
+pkgver=2.9.2
+pkgrel=1
+pkgdesc="Various Programming Utilities"
+arch=('x86_64')
+url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
+license=('LGPL3')
+depends=('r' 'r-oo')
+source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
+md5sums=('8629f732956b4f040429f2dccc533168')
+
+package() {
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+}