summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 28 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93c88f8f1ae0..d86077ccef13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,12 +2,14 @@ pkgbase = r-r.utils
pkgdesc = Various Programming Utilities
pkgver = 2.9.2
pkgrel = 1
- url = http://cran.r-project.org/web/packages/R.utils/index.html
- arch = x86_64
+ url = https://cran.r-project.org/package=R.utils
+ arch = any
+ license = LGPL2.1
license = LGPL3
- depends = r
- depends = r-oo
- source = http://cran.r-project.org/src/contrib/R.utils_2.9.2.tar.gz
+ depends = r>=2.14.0
+ depends = r-r.oo>=1.23.0
+ optdepends = r-digest
+ source = https://cran.r-project.org/src/contrib/R.utils_2.9.2.tar.gz
md5sums = 8629f732956b4f040429f2dccc533168
pkgname = r-r.utils
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 6ae0b18a1f6c..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-/pkg
-/src
-*.tar.gz
-*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index ed3a1239243f..7d3afa64c119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,29 @@
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Grey Christoforo <first name at last name dot net>
-pkgname=r-r.utils
-_cran_name=R.utils
-pkgver=2.9.2
+
+_cranname=R.utils
+_cranver=2.9.2
+pkgname=r-${_cranname,,}
+pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Various Programming Utilities"
-arch=('x86_64')
-url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
-license=('LGPL3')
-depends=('r' 'r-oo')
-source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
+arch=(any)
+url="https://cran.r-project.org/package=${_cranname}"
+license=(LGPL2.1 LGPL3)
+depends=('r>=2.14.0' 'r-r.oo>=1.23.0')
+optdepends=(r-digest)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
md5sums=('8629f732956b4f040429f2dccc533168')
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+}
+
package() {
- mkdir -p $pkgdir/usr/lib/R/library
- cd $srcdir
+ cd "${srcdir}"
- R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}