summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD57
-rw-r--r--fix-version.patch13
4 files changed, 58 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 766b625caea9..bbd0b1bf4d7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = r-rcpp
pkgdesc = Seamless R and C++ Integration
- pkgver = 1.0.8.3
- pkgrel = 3
+ pkgver = 1.0.12
+ pkgrel = 1
url = https://cran.r-project.org/package=Rcpp
- arch = i686
arch = x86_64
license = GPL
checkdepends = r-tinytest
depends = r
- optdepends = r-tinytest
optdepends = r-inline
- optdepends = r-rbenchmark
optdepends = r-pkgkitten
- source = https://cran.r-project.org/src/contrib/Rcpp_1.0.8.3.tar.gz
- sha256sums = 9da5b84cdaf56e972b41e669d496b1ece2e91bcd435505c68b9f2bd98375f8bf
+ optdepends = r-rbenchmark
+ optdepends = r-tinytest
+ source = https://cran.r-project.org/src/contrib/Rcpp_1.0.12.tar.gz
+ source = fix-version.patch
+ md5sums = 85d8f0c330b934bc8f498be40185a315
+ md5sums = 50440aea988c07da6fbcfc6ad945679e
+ b2sums = 511f3071d81531cdbb6de9b633e1406bb865a462587ea1e0e36c9d760cd9ea80a4ae67b44f2e2b7b5861fde727c0324bf9c3ea2b3cb9085f829fb1cb8dcd88c5
+ b2sums = a11024a357cfda063cd3599290ba58f749b8107d888407ec333f1cd2558ba6cdd07a24e7d61aff74d176e31b9470b475e5e86c682b71637e2bea9776b714835d
pkgname = r-rcpp
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 018a3de08144..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-*
-!PKGBUILD
-!.SRCINFO
-!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index a896a9fd759c..688dea119846 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,52 @@
# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Matt Frichtl <frichtlm@gmail.com>
-_cranname=Rcpp
-_cranver=1.0.8.3
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=3
+_pkgname=Rcpp
+_pkgver=1.0.12
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=1
pkgdesc="Seamless R and C++ Integration"
-arch=(i686 x86_64)
-url="https://cran.r-project.org/package=${_cranname}"
+arch=(x86_64)
+url="https://cran.r-project.org/package=$_pkgname"
license=(GPL)
-depends=(r)
-checkdepends=(r-tinytest)
+depends=(
+ r
+)
+checkdepends=(
+ r-tinytest
+)
optdepends=(
- r-tinytest
- r-inline
- r-rbenchmark
- r-pkgkitten
+ r-inline
+ r-pkgkitten
+ r-rbenchmark
+ r-tinytest
)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=('9da5b84cdaf56e972b41e669d496b1ece2e91bcd435505c68b9f2bd98375f8bf')
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
+ "fix-version.patch")
+md5sums=('85d8f0c330b934bc8f498be40185a315'
+ '50440aea988c07da6fbcfc6ad945679e')
+b2sums=('511f3071d81531cdbb6de9b633e1406bb865a462587ea1e0e36c9d760cd9ea80a4ae67b44f2e2b7b5861fde727c0324bf9c3ea2b3cb9085f829fb1cb8dcd88c5'
+ 'a11024a357cfda063cd3599290ba58f749b8107d888407ec333f1cd2558ba6cdd07a24e7d61aff74d176e31b9470b475e5e86c682b71637e2bea9776b714835d')
+
+prepare() {
+ # fix version definition https://github.com/RcppCore/Rcpp/issues/1294
+ patch -Np1 -i fix-version.patch
+}
build() {
- mkdir -p build
- R CMD INSTALL "${_cranname}" -l "${srcdir}/build"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
check() {
- cd "${_cranname}/tests"
- R_LIBS="${srcdir}/build" LC_ALL=C.UTF-8 RunAllRcppTests=yes Rscript --vanilla tinytest.R
+ cd "$_pkgname/tests"
+ R_LIBS="$srcdir/build" LC_ALL=C.UTF-8 RunAllRcppTests=yes Rscript --vanilla tinytest.R
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "build/${_cranname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
diff --git a/fix-version.patch b/fix-version.patch
new file mode 100644
index 000000000000..b6f9002ac1d4
--- /dev/null
+++ b/fix-version.patch
@@ -0,0 +1,13 @@
+diff --git a/Rcpp/inst/include/Rcpp/config.h b/Rcpp/inst/include/Rcpp/config.h
+index fa75d9d..804089c 100644
+--- a/Rcpp/inst/include/Rcpp/config.h
++++ b/Rcpp/inst/include/Rcpp/config.h
+@@ -26,7 +26,7 @@
+ #define RcppDevVersion(maj, min, rev, dev) (((maj)*1000000) + ((min)*10000) + ((rev)*100) + (dev))
+
+ // the currently released version
+-#define RCPP_VERSION Rcpp_Version(1,0,11)
++#define RCPP_VERSION Rcpp_Version(1,0,12)
+ #define RCPP_VERSION_STRING "1.0.12"
+
+ // the current source snapshot (using four components, if a fifth is used in DESCRIPTION we ignore it)