summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD71
2 files changed, 54 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb810e4bf58d..f8bdde6b513e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = r-rlang
- pkgdesc = Functions for Base Types and Core R and 'Tidyverse' Features
- pkgver = 1.0.5
+ pkgdesc = Functions for Base Types and Core R and ‘Tidyverse’ Features
+ pkgver = 1.1.3
pkgrel = 1
url = https://cran.r-project.org/package=rlang
arch = i686
arch = x86_64
license = MIT
- depends = r>=3.4.0
+ depends = r>=3.5.0
optdepends = r-cli>=3.1.0
optdepends = r-covr
optdepends = r-crayon
@@ -16,12 +16,11 @@ pkgbase = r-rlang
optdepends = r-magrittr
optdepends = r-pillar
optdepends = r-rmarkdown
- optdepends = r-testthat>=3.0.0
optdepends = r-tibble
optdepends = r-usethis
optdepends = r-vctrs>=0.2.3
optdepends = r-withr
- source = https://cran.r-project.org/src/contrib/rlang_1.0.5.tar.gz
- sha256sums = 2da935e56697879ab128bec034564a6d11ea02cf479a3c92496121b72f922fab
+ source = https://cran.r-project.org/src/contrib/rlang_1.1.3.tar.gz
+ b2sums = c4641ee54942c6621f0b7b744da3197f582302222dad8f89eec4e7f4e4439deebd641a8292d6aad840690a7f24e43b9af316b353b72d5efbce712b8c9ea15648
pkgname = r-rlang
diff --git a/PKGBUILD b/PKGBUILD
index 74492626da5a..75caeb64e16a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,42 +3,69 @@
# Contributor: Grey Christoforo <first name at last name dot net>
_cranname=rlang
-_cranver=1.0.5
+_cranver=1.1.3
pkgname=r-${_cranname,,}
+pkgdesc="Functions for Base Types and Core R and ‘Tidyverse’ Features"
+url="https://cran.r-project.org/package=${_cranname}"
+license=("MIT")
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="Functions for Base Types and Core R and 'Tidyverse' Features"
-arch=(i686 x86_64)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(MIT)
-depends=("r>=3.4.0")
+
+arch=("i686" "x86_64")
+depends=(
+ "r>=3.5.0"
+)
optdepends=(
"r-cli>=3.1.0"
- r-covr
- r-crayon
- r-fs
- r-glue
- r-knitr
- r-magrittr
- r-pillar
- r-rmarkdown
- "r-testthat>=3.0.0"
- r-tibble
- r-usethis
+ "r-covr"
+ "r-crayon"
+ "r-fs"
+ "r-glue"
+ "r-knitr"
+ "r-magrittr"
+ "r-pillar"
+ "r-rmarkdown"
+ "r-tibble"
+ "r-usethis"
"r-vctrs>=0.2.3"
- r-withr
+ "r-withr"
)
+
+# The unittests for `r-rlang` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-rlang`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat>=3.0.0"
+# )
+
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-sha256sums=("2da935e56697879ab128bec034564a6d11ea02cf479a3c92496121b72f922fab")
+b2sums=("c4641ee54942c6621f0b7b744da3197f582302222dad8f89eec4e7f4e4439deebd641a8292d6aad840690a7f24e43b9af316b353b72d5efbce712b8c9ea15648")
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ mkdir -p "${srcdir}/build/"
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
+
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
-
+ cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi