summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 21 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4342375f8f82..bfdeaeccc232 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,13 @@
pkgbase = r-rlang
- pkgdesc = Functions for Base Types and Core R and Tidyverse Features
- pkgver = 0.2.2
+ pkgdesc = Functions for Base Types and Core R and 'Tidyverse' Features
+ pkgver = 0.3.1
pkgrel = 1
- url = https://cran.r-project.org/package=rlang
+ url = http://cran.r-project.org/web/packages/rlang/index.html
arch = x86_64
license = GPL3
depends = r
- optdepends = r-crayon
- optdepends = r-knitr
- optdepends = r-pillar
- optdepends = r-rmarkdown
- optdepends = r-testthat
- optdepends = r-covr
- replaces = r-cran-rlang
- source = https://cran.r-project.org/src/contrib/rlang_0.2.2.tar.gz
- md5sums = df2abf3a1936c503ed1edd4350ffb5f0
+ source = http://cran.r-project.org/src/contrib/rlang_0.3.1.tar.gz
+ md5sums = 58f35460425d475e6a2db267b5039f8f
pkgname = r-rlang
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 00a5786c4a01..dbad8ab2fbe7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,19 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
-_cranver=0.2.2
+# Contributor: Grey Christoforo <first name at last name dot net>
pkgname=r-rlang
-pkgver=${_cranver//[:-]/.}
+_cran_name=rlang
+pkgver=0.3.1
pkgrel=1
-pkgdesc='Functions for Base Types and Core R and Tidyverse Features'
+pkgdesc="Functions for Base Types and Core R and 'Tidyverse' Features"
arch=('x86_64')
-url='https://cran.r-project.org/package=rlang'
+url="http://cran.r-project.org/web/packages/${_cran_name}/index.html"
license=('GPL3')
-depends=('r' )
-optdepends=('r-crayon' 'r-knitr' 'r-pillar' 'r-rmarkdown' 'r-testthat' 'r-covr')
-replaces=('r-cran-rlang')
-source=("https://cran.r-project.org/src/contrib/rlang_"$_cranver".tar.gz")
-md5sums=('df2abf3a1936c503ed1edd4350ffb5f0')
+depends=('r')
+source=("http://cran.r-project.org/src/contrib/${_cran_name}_${pkgver}.tar.gz")
+md5sums=('58f35460425d475e6a2db267b5039f8f')
-build(){
- R CMD INSTALL rlang_"$_cranver".tar.gz -l "$srcdir"
-}
package() {
- install -dm0755 "$pkgdir"/usr/lib/R/library
- cp -a --no-preserve=ownership rlang "$pkgdir"/usr/lib/R/library
-}
+ mkdir -p $pkgdir/usr/lib/R/library
+ cd $srcdir
+ R CMD INSTALL -l $pkgdir/usr/lib/R/library ./${_cran_name}
+}