summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ba5ad030ef2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = r-rsubread
+ pkgdesc = Mapping, quantification and variant analysis of sequencing data
+ pkgver = 2.10.2
+ pkgrel = 1
+ url = https://bioconductor.org/packages/Rsubread
+ arch = x86_64
+ license = GPL
+ depends = r
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/Rsubread_2.10.2.tar.gz
+ sha256sums = 60836921adb5bf8eff956a60f99ac434a70b81e136f7074d401a84dd2dea7edf
+
+pkgname = r-rsubread
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b48fa138540
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=Rsubread
+_pkgver=2.10.2
+pkgname=r-${_pkgname,,}
+pkgver=2.10.2
+pkgrel=1
+pkgdesc='Mapping, quantification and variant analysis of sequencing data'
+arch=('x86_64')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('60836921adb5bf8eff956a60f99ac434a70b81e136f7074d401a84dd2dea7edf')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: