summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e00c3aebf402
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = r-rustinr-git
+ pkgdesc = Rust and R Integration
+ pkgver = r60.b7691f9
+ pkgrel = 1
+ url = https://github.com/rustr/rustinr
+ arch = any
+ license = Apache2.0
+ makedepends = git
+ depends = r
+ depends = rust
+ optdepends = r-testthat
+ source = rustinr_src::git+https://github.com/rustr/rustinr.git
+ md5sums = SKIP
+
+pkgname = r-rustinr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e81216efc8ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+
+_gitname=rustinr
+pkgname=r-${_gitname,,}-git
+pkgver=r60.b7691f9
+pkgrel=1
+pkgdesc="Rust and R Integration"
+arch=(any)
+url="https://github.com/rustr/${_gitname}"
+license=(Apache2.0)
+depends=(r rust)
+makedepends=(git)
+optdepends=(r-testthat)
+source=("${_gitname}_src::git+https://github.com/rustr/${_gitname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}_src"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}"
+
+ R CMD INSTALL "${_gitname}_src" -l ${srcdir}
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_gitname}" "${pkgdir}/usr/lib/R/library"
+}