summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
2 files changed, 26 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d642de4f762..426719805b77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = r-testit
- pkgdesc = Provides two convenience functions assert() and test_pkg() to facilitate testing R packages.
- pkgver = 0.9
+ pkgdesc = A Simple Package for Testing R Packages
+ pkgver = 0.11
pkgrel = 1
url = https://cran.r-project.org/package=testit
- arch = x86_64
- license = GPL-2
- license = GPL-3
+ arch = any
+ license = GPL3
depends = r
optdepends = r-rstudioapi
- source = https://cran.r-project.org/src/contrib/Archive/testit/testit_0.9.tar.gz
- md5sums = e19c52232a32060e86d8bef6f76b7d79
+ source = https://cran.r-project.org/src/contrib/testit_0.11.tar.gz
+ md5sums = 1b6fc5492bc69de5f7832c735d5132fd
pkgname = r-testit
diff --git a/PKGBUILD b/PKGBUILD
index c3e3500c0321..1c5665395235 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Kibouo <csonka.mihaly@hotmail.com>
# Contributor: Alex Branham <branham@utexas.edu>
+
_cranname=testit
-_cranver=0.9
-_pkgtar=${_cranname}_${_cranver}.tar.gz
-pkgname=r-testit
+_cranver=0.11
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc='Provides two convenience functions assert() and test_pkg() to facilitate testing R packages.'
-arch=('x86_64')
+pkgdesc="A Simple Package for Testing R Packages"
+arch=(any)
url="https://cran.r-project.org/package=${_cranname}"
-license=('GPL-2' 'GPL-3')
-depends=('r')
-optdepends=('r-rstudioapi')
-source=("https://cran.r-project.org/src/contrib/Archive/${_cranname}/${_pkgtar}")
-md5sums=('e19c52232a32060e86d8bef6f76b7d79')
+license=(GPL3)
+depends=(r)
+optdepends=(r-rstudioapi)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+md5sums=('1b6fc5492bc69de5f7832c735d5132fd')
+
+build() {
+ cd "${srcdir}"
-build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
}
+
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
+ cd "${srcdir}"
+
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
}
-