summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD93
2 files changed, 101 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92ef3ec4bb3f..530c2df3b034 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,40 @@
pkgbase = r-testthat
pkgdesc = Unit Testing for R
- pkgver = 2.3.0
+ pkgver = 3.2.1.1
pkgrel = 1
url = https://cran.r-project.org/package=testthat
+ arch = i686
arch = x86_64
license = MIT
- depends = r>=3.1
- depends = r-cli
- depends = r-crayon>=1.3.4
- depends = r-digest
- depends = r-ellipsis
- depends = r-evaluate
- depends = r-magrittr
- depends = r-pkgload
- depends = r-praise
- depends = r-r6>=2.2.0
- depends = r-rlang>=0.4.1
- depends = r-withr>=2.0.0
+ depends = r>=3.6.0
+ depends = r-brio>=1.1.3
+ depends = r-callr>=3.7.3
+ depends = r-cli>=3.6.1
+ depends = r-desc>=1.4.2
+ depends = r-digest>=0.6.33
+ depends = r-evaluate>=0.21
+ depends = r-jsonlite>=1.8.7
+ depends = r-lifecycle>=1.0.3
+ depends = r-magrittr>=2.0.3
+ depends = r-pkgload>=1.3.2.1
+ depends = r-praise>=1.0.0
+ depends = r-processx>=3.8.2
+ depends = r-ps>=1.7.5
+ depends = r-r6>=2.5.1
+ depends = r-rlang>=1.1.1
+ depends = r-waldo>=0.5.1
+ depends = r-withr>=2.5.0
optdepends = r-covr
- optdepends = r-curl
- optdepends = r-devtools
+ optdepends = r-curl>=0.9.5
+ optdepends = r-diffviewer>=0.1.0
optdepends = r-knitr
optdepends = r-rmarkdown
+ optdepends = r-rstudioapi
+ optdepends = r-shiny
optdepends = r-usethis
- optdepends = r-vctrs
+ optdepends = r-vctrs>=0.1.0
optdepends = r-xml2
- source = https://cran.r-project.org/src/contrib/testthat_2.3.0.tar.gz
- md5sums = 80902ddc45eb994b49287b0bfaa2f6e6
+ source = https://cran.r-project.org/src/contrib/testthat_3.2.1.1.tar.gz
+ b2sums = c2fa93c7027ebcc56ab1f1d1322b151b46436c7f1533249843f4655053c5c0a413103b2a3e9752f6a973de5db2fd5208ae4e30d79799475483b119f82344fb45
pkgname = r-testthat
-
diff --git a/PKGBUILD b/PKGBUILD
index c1095f7ec88b..dc092fdafb5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,88 @@
-# Maintainer: Matt Frichtl <frichtlm@gmail.com>
+# Maintainer: peippo <christoph+aur@christophfink.com>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Matt Frichtl <frichtlm@gmail.com>
# Contributor: Kibouo <csonka.mihaly@hotmail.com>
# Contributor: Ward Segers <w@rdsegers.be>
# Contributor: Alex Branham <alex.branham@gmail.com>
-_cranver=2.3.0
+
_cranname=testthat
-_pkgtar=${_cranname}_${_cranver}.tar.gz
-pkgname=r-testthat
+_cranver=3.2.1.1
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
pkgdesc="Unit Testing for R"
-arch=('x86_64')
+arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
-license=('MIT')
-depends=('r>=3.1' 'r-cli' 'r-crayon>=1.3.4' 'r-digest' 'r-ellipsis' 'r-evaluate' 'r-magrittr' 'r-pkgload' 'r-praise' 'r-r6>=2.2.0' 'r-rlang>=0.4.1' 'r-withr>=2.0.0')
-optdepends=('r-covr' 'r-curl' 'r-devtools' 'r-knitr' 'r-rmarkdown' 'r-usethis' 'r-vctrs' 'r-xml2')
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-#source=("https://cran.r-project.org/src/contrib/Archive/${_cranname}/${_cranname}_${_cranver}.tar.gz") # unccoment if 404 error
-md5sums=('80902ddc45eb994b49287b0bfaa2f6e6')
+license=(MIT)
+depends=(
+ "r>=3.6.0"
+ "r-brio>=1.1.3"
+ "r-callr>=3.7.3"
+ "r-cli>=3.6.1"
+ "r-desc>=1.4.2"
+ "r-digest>=0.6.33"
+ "r-evaluate>=0.21"
+ "r-jsonlite>=1.8.7"
+ "r-lifecycle>=1.0.3"
+ "r-magrittr>=2.0.3"
+ "r-pkgload>=1.3.2.1"
+ "r-praise>=1.0.0"
+ "r-processx>=3.8.2"
+ "r-ps>=1.7.5"
+ "r-r6>=2.5.1"
+ "r-rlang>=1.1.1"
+ "r-waldo>=0.5.1"
+ "r-withr>=2.5.0"
+)
+optdepends=(
+ "r-covr"
+ "r-curl>=0.9.5"
+ "r-diffviewer>=0.1.0"
+ "r-knitr"
+ "r-rmarkdown"
+ "r-rstudioapi"
+ "r-shiny"
+ "r-usethis"
+ "r-vctrs>=0.1.0"
+ "r-xml2"
+)
-build(){
- cd "${srcdir}"
+# The unittests for `r-testthat` have multiple circular
+# dependency chains (including itself!).
- R CMD INSTALL testthat_"$_cranver".tar.gz -l "$srcdir"
-}
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
-package() {
- cd "${srcdir}"
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-testthat`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat>=3.0.0"
+# )
- install -dm0755 "$pkgdir/usr/lib/R/library"
- cp -a --no-preserve=ownership "$_cranname" "$pkgdir/usr/lib/R/library"
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+b2sums=("c2fa93c7027ebcc56ab1f1d1322b151b46436c7f1533249843f4655053c5c0a413103b2a3e9752f6a973de5db2fd5208ae4e30d79799475483b119f82344fb45")
+
+build() {
+ mkdir -p "${srcdir}/build/"
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual --ignore-vignettes "${_cranname}"
+# }
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
+ if [[ -f "${_cranname}/LICENSE" ]]; then
+ install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ fi
+}