summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD41
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f0e3d070bd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = r-vcfarray
+ pkgdesc = Representing on-disk / remote VCF files as array-like objects
+ pkgver = 1.12.0
+ pkgrel = 1
+ url = https://bioconductor.org/packages/VCFArray
+ arch = any
+ license = GPL
+ depends = r
+ depends = r-biocgenerics
+ depends = r-delayedarray
+ depends = r-genomicfiles
+ depends = r-genomicranges
+ depends = r-rsamtools
+ depends = r-s4vectors
+ depends = r-variantannotation
+ optdepends = r-biocmanager
+ optdepends = r-biocstyle
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-seqarray
+ optdepends = r-testthat
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/VCFArray_1.12.0.tar.gz
+ sha256sums = 490a97af0ee4ee1a4482bf03d322fde6ad7bb1ff09544fbf97220566d1e6ef9f
+
+pkgname = r-vcfarray
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cf2305f76cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=VCFArray
+_pkgver=1.12.0
+pkgname=r-${_pkgname,,}
+pkgver=1.12.0
+pkgrel=1
+pkgdesc='Representing on-disk / remote VCF files as array-like objects'
+arch=('any')
+url="https://bioconductor.org/packages/${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-biocgenerics
+ r-delayedarray
+ r-genomicfiles
+ r-genomicranges
+ r-rsamtools
+ r-s4vectors
+ r-variantannotation
+)
+optdepends=(
+ r-biocmanager
+ r-biocstyle
+ r-knitr
+ r-rmarkdown
+ r-seqarray
+ r-testthat
+)
+source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('490a97af0ee4ee1a4482bf03d322fde6ad7bb1ff09544fbf97220566d1e6ef9f')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: