summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
-rw-r--r--r3broot.install (renamed from r3broot-svn.install)2
3 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a976f356d96..080cda57f0aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-pkgbase = r3broot-svn
+pkgbase = r3broot-git
pkgdesc = Analysis framework based on root for the R3B experiment provided by GSI/FAIR.
- pkgver = trunk
- pkgrel = 2
- url = http://fairroot.gsi.de
- install = r3broot-svn.install
+ pkgver = jul15
+ pkgrel = 1
+ url = http://www.r3broot.gsi.de
+ install = r3broot.install
arch = x86_64
license = unknown
makedepends = cmake
@@ -20,8 +20,10 @@ pkgbase = r3broot-svn
options = staticlibs
options = libtool
options = !strip
- source = r3broot-svn::svn+https://subversion.gsi.de/fairroot/r3broot/trunk
+ source = r3broot-git::git+https://github.com/R3BRootGroup/R3BRoot
+ source = r3broot.install
md5sums = SKIP
+ md5sums = 29d9cea27a2cf33f7dfd028447f300d1
-pkgname = r3broot-svn
+pkgname = r3broot-git
diff --git a/PKGBUILD b/PKGBUILD
index 141d1731c7e5..8e20b7b88f5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Bastian Löher <b.loeher@gsi.de>
-pkgname=r3broot-svn
-pkgver=trunk
-pkgrel=2
+pkgname=r3broot-git
+pkgver=jul15
+pkgrel=1
pkgdesc="Analysis framework based on root for the R3B experiment provided by GSI/FAIR."
arch=('x86_64')
-url="http://fairroot.gsi.de"
+url="http://www.r3broot.gsi.de"
license=('unknown')
groups=()
fairsoftver=jul15p1-1
@@ -24,11 +24,14 @@ provides=('r3broot')
replaces=()
backup=()
options=('!emptydirs' 'staticlibs' 'libtool' '!strip')
-install=r3broot-svn.install
+install=r3broot.install
changelog=
-source=("${pkgname}::svn+https://subversion.gsi.de/fairroot/r3broot/trunk")
+source=("${pkgname}::git+https://github.com/R3BRootGroup/R3BRoot"
+ 'r3broot.install'
+ )
noextract=()
-md5sums=('SKIP')
+md5sums=('SKIP'
+ '29d9cea27a2cf33f7dfd028447f300d1')
# Do not compress the package for installation
# PKGEXT='.pkg.tar'
@@ -37,8 +40,8 @@ PKGEXT='.pkg.tar.gz'
pkgver() {
cd "$pkgname"
- local ver="$(svnversion)"
- printf "r%s" "${ver//[[:alpha:]]}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
}
prepare() {
@@ -54,7 +57,7 @@ prepare() {
cd build
cmake \
-DUSE_DIFFERENT_COMPILER=TRUE \
- -DCMAKE_INSTALL_PREFIX="/opt/r3broot/svn" \
+ -DCMAKE_INSTALL_PREFIX="/opt/r3broot/git" \
../${pkgname}
:
}
@@ -67,7 +70,7 @@ build() {
}
package() {
- installdir=${pkgdir}/opt/r3broot/svn
+ installdir=${pkgdir}/opt/r3broot/git
cd ${srcdir}/build
make DESTDIR="${pkgdir}/" install
diff --git a/r3broot-svn.install b/r3broot.install
index 3b730f2d83ce..65bfcafd7f33 100644
--- a/r3broot-svn.install
+++ b/r3broot.install
@@ -1,6 +1,6 @@
post_install() {
echo "Add the following line to your ~/.profile"
- echo " source /opt/r3broot/svn/config.sh"
+ echo " source /opt/r3broot/git/config.sh"
}
post_upgrade() {