summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD23
-rw-r--r--dkms.conf2
-rw-r--r--r8152-dkms.install20
5 files changed, 20 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d663010a36f1..51c75833d391 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = r8152-dkms
- pkgdesc = A kernel module for Realtek RTL8152/RTL8153 Based USB Ethernet Adapters
- pkgver = 2.12
+ pkgdesc = A kernel module for Realtek RTL8152/RTL8153/RTL8154/RTL8156 Based USB Ethernet Adapters
+ pkgver = 2.17.1.20240405
pkgrel = 1
- url = http://www.realtek.com.tw
+ url = http://www.realtek.com
arch = i686
arch = x86_64
license = GPL
@@ -11,10 +11,9 @@ pkgbase = r8152-dkms
optdepends = linux-headers: Build the module for Arch kernel
optdepends = linux-lts-headers: Build the module for LTS Arch kernel
conflicts = r8152
- source = https://github.com/wget/realtek-r8152-linux/archive/v2.12.tar.gz
+ source = https://github.com/wget/realtek-r8152-linux/archive/v2.17.1.20240405.tar.gz
source = dkms.conf
- sha512sums = 0e9d6dbadcc03c20f41a291aa550cb50a14bf44e4bd3578287d02c7d9d4746b96c9ac84e55b6b5dd613b41079a09f3ed618ae0880f283c81d8ebd1a0bec38062
- sha512sums = 2272d18f24a940fb878245849a0950d560b97ece8d492ebfe7ccf53f8ac6093b6b9da2b45c5ea3f99c77b36ffbd75337aa560cfd84428052f5436a9cda7c1605
+ sha512sums = d188256a0c9eeea992741fe0b6856161db785fa324b4371e1266aa62cb457af92ae8759dfdb602fc01e2da7ef28cef20e66260dd84d857ed554b4ab0a0ba3655
+ sha512sums = 04d93f2297be0ffbd9ad8611ee619406af26f8fc987686e7150a68d4e8d9d94d104b76583a3190699587fd568c995e31c96332afa77b880a972eb24861ba5dea
pkgname = r8152-dkms
-
diff --git a/.gitignore b/.gitignore
index d4794f0b7fb5..6ea35b4a49e1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ src/
*.pkg.tar.xz
*.tar.bz2
*.tar.gz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 749439581db1..3cfe5416ab16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,30 @@
# Contributor: Richard Mathot <rim at odoo dot com>
_pkgbase=r8152
pkgname=${_pkgbase}-dkms
-pkgver=2.12
+pkgver=2.17.1.20240405
pkgrel=1
-pkgdesc="A kernel module for Realtek RTL8152/RTL8153 Based USB Ethernet Adapters"
-url="http://www.realtek.com.tw"
+pkgdesc="A kernel module for Realtek RTL8152/RTL8153/RTL8154/RTL8156 Based USB Ethernet Adapters"
+url="http://www.realtek.com"
license=("GPL")
arch=('i686' 'x86_64')
depends=('glibc' 'dkms')
conflicts=("${_pkgbase}")
optdepends=('linux-headers: Build the module for Arch kernel'
- 'linux-lts-headers: Build the module for LTS Arch kernel')
+ 'linux-lts-headers: Build the module for LTS Arch kernel')
source=(
"https://github.com/wget/realtek-r8152-linux/archive/v${pkgver}.tar.gz"
'dkms.conf'
)
-sha512sums=('0e9d6dbadcc03c20f41a291aa550cb50a14bf44e4bd3578287d02c7d9d4746b96c9ac84e55b6b5dd613b41079a09f3ed618ae0880f283c81d8ebd1a0bec38062'
- '2272d18f24a940fb878245849a0950d560b97ece8d492ebfe7ccf53f8ac6093b6b9da2b45c5ea3f99c77b36ffbd75337aa560cfd84428052f5436a9cda7c1605')
+sha512sums=('d188256a0c9eeea992741fe0b6856161db785fa324b4371e1266aa62cb457af92ae8759dfdb602fc01e2da7ef28cef20e66260dd84d857ed554b4ab0a0ba3655'
+ '04d93f2297be0ffbd9ad8611ee619406af26f8fc987686e7150a68d4e8d9d94d104b76583a3190699587fd568c995e31c96332afa77b880a972eb24861ba5dea')
package() {
- install -Dm644 dkms.conf "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/dkms.conf"
+ install -Dm644 dkms.conf "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/dkms.conf"
- sed -e "s/@PKGNAME@/${_pkgbase}/g" \
- -e "s/@PKGVER@/${_pkgbase}/g" \
- -i "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/dkms.conf"
+ sed -e "s/@PKGNAME@/${_pkgbase}/g" \
+ -e "s/@PKGVER@/${_pkgbase}/g" \
+ -i "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/dkms.conf"
- cp -dr --no-preserve='ownership' "realtek-${_pkgbase}-linux-${pkgver}" "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/src"
+ cp -dr --no-preserve='ownership' "realtek-${_pkgbase}-linux-${pkgver}" "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/src"
+ install -D -m644 "realtek-${_pkgbase}-linux-${pkgver}/50-usb-realtek-net.rules" "${pkgdir}/usr/lib/udev/rules.d/50-usb-realtek-net.rules"
}
diff --git a/dkms.conf b/dkms.conf
index 681c2fb1af53..fd5ca33d8153 100644
--- a/dkms.conf
+++ b/dkms.conf
@@ -1,6 +1,6 @@
PACKAGE_NAME="@PKGNAME@"
PACKAGE_VERSION="@PKGVER@"
-MAKE[0]="make -C $kernel_source_dir SUBDIRS=$dkms_tree/$module/$module_version/build/src EXTRA_CFLAGS='-DCONFIG_R8152_NAPI -DCONFIG_R8152_VLAN' modules"
+MAKE[0]="make -C $kernel_source_dir M=$dkms_tree/$module/$module_version/build/src EXTRA_CFLAGS='-DCONFIG_R8152_NAPI -DCONFIG_R8152_VLAN' modules"
CLEAN="rm src/@PKGNAME@.ko src/*.o || true"
BUILT_MODULE_NAME[0]="@PKGNAME@"
BUILT_MODULE_LOCATION[0]="src/"
diff --git a/r8152-dkms.install b/r8152-dkms.install
deleted file mode 100644
index ddd32c44a3c5..000000000000
--- a/r8152-dkms.install
+++ /dev/null
@@ -1,20 +0,0 @@
-#/bin/sh
-post_install() {
- dkms add r8152/${1%-*}
- cat << EOF
-==> To build and install your modules run: dkms install r8152/${1%-*}
-==> To do this automatically at startup run: systemctl enable dkms.service
-EOF
-}
-
-pre_upgrade() {
- pre_remove "$2"
-}
-
-post_upgrade() {
- post_install "$1"
-}
-
-pre_remove() {
- [ -n "${1%-*}" ] && dkms remove r8152/${1%-*} --all &>/dev/null || true
-}