summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3c708c3f04f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rabbit-plugin-bin
+ pkgdesc = A SIP003 plugin based on rabbit-tcp for shadowsocks (binary version)
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://github.com/ihciah/rabbit-plugin
+ arch = x86_64
+ license = unknown
+ depends = glibc
+ provides = rabbit-plugin
+ conflicts = rabbit-plugin
+ source = rabbit-plugin-bin-0.1.5.gz::https://github.com/ihciah/rabbit-plugin/releases/download/v0.1.5/rabbit-plugin-linux-amd64.gz
+ sha512sums = 956aef7e6a891318b339d9d96f34b6381378dc8677fc36c250929a384044a772c359e8cd47aba80d8e15679f9a10723cc111215bc9ef11ddfe74b8f5b8dd9ea4
+
+pkgname = rabbit-plugin-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..058bd27da974
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: 4679 <4679@pm.me>
+
+pkgname=rabbit-plugin-bin
+pkgver=0.1.5
+pkgrel=1
+pkgdesc='A SIP003 plugin based on rabbit-tcp for shadowsocks (binary version)'
+arch=('x86_64')
+url='https://github.com/ihciah/rabbit-plugin'
+license=('unknown')
+depends=('glibc')
+provides=('rabbit-plugin')
+conflicts=('rabbit-plugin')
+source=("${pkgname}-${pkgver}.gz::${url}/releases/download/v${pkgver}/rabbit-plugin-linux-amd64.gz")
+sha512sums=('956aef7e6a891318b339d9d96f34b6381378dc8677fc36c250929a384044a772c359e8cd47aba80d8e15679f9a10723cc111215bc9ef11ddfe74b8f5b8dd9ea4')
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 "${pkgname}-${pkgver}" "${pkgdir}/usr/bin/rabbit-plugin"
+}
+