summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
2 files changed, 30 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96db94c3f60b..2851dac03639 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Mon May 4 18:57:39 UTC 2020
pkgbase = radeon-profile-git
pkgdesc = App for display info about radeon card
- pkgver = 20200504.r0.g2e0b4d9
- pkgrel = 1
- url = http://github.com/marazmista/radeon-profile
+ pkgver = 20200824.r22.g295d189
+ pkgrel = 3
+ url = http://github.com/emerge-e-world/radeon-profile
arch = i686
arch = x86_64
license = GPL2
@@ -14,6 +12,9 @@ pkgbase = radeon-profile-git
depends = qt5-charts
depends = libxkbcommon-x11
depends = libxrandr
+ depends = libx11
+ depends = gcc-libs
+ depends = glibc
optdepends = radeon-profile-daemon: system daemon for reading card info
optdepends = sudo: start with root privilages without password
optdepends = mesa-demos: for glxinfo
@@ -22,9 +23,8 @@ pkgbase = radeon-profile-git
optdepends = xf86-video-ati: radeon open source driver
optdepends = xf86-video-amdgpu: amdgpu open source driver
provides = radeon-profile
- replaces = radeon-profile
- source = git+https://github.com/marazmista/radeon-profile.git
+ conflicts = radeon-profile
+ source = git+https://github.com/emerge-e-world/radeon-profile.git
sha256sums = SKIP
pkgname = radeon-profile-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9086fe1bb58c..901257641225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: marazmista <marazmista@tuta.io>
pkgname=radeon-profile-git
-pkgver=20200504.r0.g2e0b4d9
-pkgrel=1
+pkgver=20200824.r22.g295d189
+pkgrel=3
pkgdesc="App for display info about radeon card"
-url="http://github.com/marazmista/radeon-profile"
+url="http://github.com/emerge-e-world/radeon-profile"
arch=('i686' 'x86_64')
license=('GPL2')
-depends=('qt5-base' 'qt5-charts' 'libxkbcommon-x11' 'libxrandr')
+depends=('qt5-base' 'qt5-charts' 'libxkbcommon-x11' 'libxrandr' 'libx11' 'gcc-libs' 'glibc')
makedepends=('qt5-tools' 'git')
optdepends=('radeon-profile-daemon: system daemon for reading card info'
'sudo: start with root privilages without password'
@@ -17,34 +17,31 @@ optdepends=('radeon-profile-daemon: system daemon for reading card info'
'xf86-video-ati: radeon open source driver'
'xf86-video-amdgpu: amdgpu open source driver')
provides=('radeon-profile')
-replaces=('radeon-profile')
-source=("git+https://github.com/marazmista/radeon-profile.git")
+conflicts=('radeon-profile')
+source=("git+https://github.com/emerge-e-world/radeon-profile.git")
sha256sums=('SKIP')
pkgver() {
-cd "$srcdir/radeon-profile"
-git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/radeon-profile"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
-cd "$srcdir/radeon-profile/radeon-profile"
-
-lrelease radeon-profile.pro
-qmake-qt5 QMAKE_CFLAGS_RELEASE="${CFLAGS}" QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" CONFIG+=silent
-make
+ cd "$srcdir/radeon-profile/radeon-profile"
+ lrelease radeon-profile.pro
+ qmake-qt5 QMAKE_CFLAGS_RELEASE="${CFLAGS}" QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" CONFIG+=silent
+ make
}
package() {
-cd "$srcdir/radeon-profile/radeon-profile"
-
-install -Dm755 "target/radeon-profile" "$pkgdir/usr/bin/radeon-profile"
-
-install -Dm644 "extra/radeon-profile.png" "$pkgdir/usr/share/pixmaps/radeon-profile.png"
-install -Dm644 "extra/radeon-profile.desktop" "$pkgdir/usr/share/applications/radeon-profile.desktop"
-
-cd translations
-for translation in *.qm
-do
-install -Dm644 $translation "$pkgdir/usr/share/radeon-profile/$translation"
-done
+ cd "$srcdir/radeon-profile/radeon-profile"
+ install -Dm755 "target/radeon-profile" "$pkgdir/usr/bin/radeon-profile"
+ install -Dm644 "extra/radeon-profile.png" "$pkgdir/usr/share/pixmaps/radeon-profile.png"
+ install -Dm644 "extra/radeon-profile.desktop" "$pkgdir/usr/share/applications/radeon-profile.desktop"
+
+ cd translations
+ for translation in *.qm
+ do
+ install -Dm644 $translation "$pkgdir/usr/share/radeon-profile/$translation"
+ done
}