summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD41
2 files changed, 22 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96db94c3f60b..55987291ec10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,8 @@
-# Generated by mksrcinfo v8
-# Mon May 4 18:57:39 UTC 2020
pkgbase = radeon-profile-git
pkgdesc = App for display info about radeon card
- pkgver = 20200504.r0.g2e0b4d9
+ pkgver = 20200824.r22.g295d189
pkgrel = 1
- url = http://github.com/marazmista/radeon-profile
+ url = http://github.com/emerge-e-world/radeon-profile
arch = i686
arch = x86_64
license = GPL2
@@ -23,8 +21,7 @@ pkgbase = radeon-profile-git
optdepends = xf86-video-amdgpu: amdgpu open source driver
provides = radeon-profile
replaces = radeon-profile
- source = git+https://github.com/marazmista/radeon-profile.git
+ source = git+https://github.com/emerge-e-world/radeon-profile.git
sha256sums = SKIP
pkgname = radeon-profile-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9086fe1bb58c..eb5e025449e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: marazmista <marazmista@tuta.io>
pkgname=radeon-profile-git
-pkgver=20200504.r0.g2e0b4d9
+pkgver=20200824.r22.g295d189
pkgrel=1
pkgdesc="App for display info about radeon card"
-url="http://github.com/marazmista/radeon-profile"
+url="http://github.com/emerge-e-world/radeon-profile"
arch=('i686' 'x86_64')
license=('GPL2')
depends=('qt5-base' 'qt5-charts' 'libxkbcommon-x11' 'libxrandr')
@@ -18,33 +18,30 @@ optdepends=('radeon-profile-daemon: system daemon for reading card info'
'xf86-video-amdgpu: amdgpu open source driver')
provides=('radeon-profile')
replaces=('radeon-profile')
-source=("git+https://github.com/marazmista/radeon-profile.git")
+source=("git+https://github.com/emerge-e-world/radeon-profile.git")
sha256sums=('SKIP')
pkgver() {
-cd "$srcdir/radeon-profile"
-git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/radeon-profile"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
-cd "$srcdir/radeon-profile/radeon-profile"
-
-lrelease radeon-profile.pro
-qmake-qt5 QMAKE_CFLAGS_RELEASE="${CFLAGS}" QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" CONFIG+=silent
-make
+ cd "$srcdir/radeon-profile/radeon-profile"
+ lrelease radeon-profile.pro
+ qmake-qt5 QMAKE_CFLAGS_RELEASE="${CFLAGS}" QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" CONFIG+=silent
+ make
}
package() {
-cd "$srcdir/radeon-profile/radeon-profile"
-
-install -Dm755 "target/radeon-profile" "$pkgdir/usr/bin/radeon-profile"
-
-install -Dm644 "extra/radeon-profile.png" "$pkgdir/usr/share/pixmaps/radeon-profile.png"
-install -Dm644 "extra/radeon-profile.desktop" "$pkgdir/usr/share/applications/radeon-profile.desktop"
-
-cd translations
-for translation in *.qm
-do
-install -Dm644 $translation "$pkgdir/usr/share/radeon-profile/$translation"
-done
+ cd "$srcdir/radeon-profile/radeon-profile"
+ install -Dm755 "target/radeon-profile" "$pkgdir/usr/bin/radeon-profile"
+ install -Dm644 "extra/radeon-profile.png" "$pkgdir/usr/share/pixmaps/radeon-profile.png"
+ install -Dm644 "extra/radeon-profile.desktop" "$pkgdir/usr/share/applications/radeon-profile.desktop"
+
+ cd translations
+ for translation in *.qm
+ do
+ install -Dm644 $translation "$pkgdir/usr/share/radeon-profile/$translation"
+ done
}