summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--suppress-qt-deprecation-errors.patch33
3 files changed, 5 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76859516e0b..e11f6f583b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 5.9.71
+ pkgver = 5.9.72
pkgrel = 1
url = https://users.notam02.no/~kjetism/radium
arch = i686
@@ -31,13 +31,11 @@ pkgbase = radium
optdepends = calf-ladspa: Default chorus plugin
optdepends = ladspa-plugins: Package group for default radium plugins incl in binary releases
options = !strip
- source = https://github.com/kmatheussen/radium/archive/5.9.71.tar.gz
- source = suppress-qt-deprecation-errors.patch
+ source = https://github.com/kmatheussen/radium/archive/5.9.72.tar.gz
source = use-libtirpc-headers.patch
source = use-system-libxcb.patch
source = use-system-vstsdk.patch
- sha256sums = 9815700d7ca3afbb0f9c0481fd5f04a2345f5fcab36a1c53a79d9aefe4b79fbe
- sha256sums = de9924d5e3dd39182bdd724dac4d8e85996c9fcd8489691e0317d6b5ea265483
+ sha256sums = 065ee12164ac861eb7b9605fdd3d2e267b0af1a8bceaae83cdc0fce6f7b1df3e
sha256sums = 0dfa3014bc6a66989564c7da2d963681f5d129eb0be28153744693dd533e4909
sha256sums = 6c29e825e06d1c3aec4afd915718b8c46da705d1411a94f7c0f777b888a9b50d
sha256sums = 045e4b4c444d1a37dffdcecb87e5245188fadf68444f9a4b14207a5b98671344
diff --git a/PKGBUILD b/PKGBUILD
index 9a76f017218..1b124c84fd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Teteros <teteros at teknik dot io>
pkgname=radium
-pkgver=5.9.71
+pkgver=5.9.72
pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
@@ -41,12 +41,10 @@ optdepends=(
)
options=(!strip)
source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
- "suppress-qt-deprecation-errors.patch"
"use-libtirpc-headers.patch"
"use-system-libxcb.patch"
"use-system-vstsdk.patch")
-sha256sums=('9815700d7ca3afbb0f9c0481fd5f04a2345f5fcab36a1c53a79d9aefe4b79fbe'
- 'de9924d5e3dd39182bdd724dac4d8e85996c9fcd8489691e0317d6b5ea265483'
+sha256sums=('065ee12164ac861eb7b9605fdd3d2e267b0af1a8bceaae83cdc0fce6f7b1df3e'
'0dfa3014bc6a66989564c7da2d963681f5d129eb0be28153744693dd533e4909'
'6c29e825e06d1c3aec4afd915718b8c46da705d1411a94f7c0f777b888a9b50d'
'045e4b4c444d1a37dffdcecb87e5245188fadf68444f9a4b14207a5b98671344')
@@ -54,9 +52,6 @@ sha256sums=('9815700d7ca3afbb0f9c0481fd5f04a2345f5fcab36a1c53a79d9aefe4b79fbe'
prepare() {
cd "${pkgname}-${pkgver}"
- # https://github.com/kmatheussen/radium/issues/1226
- patch -p1 < "${srcdir}/suppress-qt-deprecation-errors.patch"
-
# glibc-2.27 deprecated legacy rpc, header files for libpd are in libtirpc
patch -p1 < "${srcdir}/use-libtirpc-headers.patch"
diff --git a/suppress-qt-deprecation-errors.patch b/suppress-qt-deprecation-errors.patch
deleted file mode 100644
index 59b35e8ce12..00000000000
--- a/suppress-qt-deprecation-errors.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -aur --no-dereference radium-5.9.71.pristine/Makefile.Qt radium-5.9.71.new/Makefile.Qt
---- radium-5.9.71.pristine/Makefile.Qt 2019-07-13 10:45:22.009924291 +0100
-+++ radium-5.9.71.new/Makefile.Qt 2019-07-13 10:41:32.489932129 +0100
-@@ -1452,7 +1452,7 @@
- $(MOC) $(P)Qt_PopupMenu.cpp -DUSE_QT_MENU >$(P)mQt_PopupMenu.cpp
-
- Qt_MainWindow.o: $(BUILD_DEPENDENCIES) $(P)Qt_MainWindow.cpp $(P)mQt_bottom_bar_widget_callbacks.h $(P)mQt_upperleft_widget_callbacks.h $(P)Rational.h $(P)lzqlineedit.h $(P)helpers.h audio/CpuUsage.hpp Qt/EditorWidget.h Qt/FileRequester.hpp
-- $(CCC) $(P)Qt_MainWindow.cpp $(QTOPT)
-+ $(CCC) $(P)Qt_MainWindow.cpp $(QTOPT) -Wno-deprecated-declarations
-
- Qt_Time.o: $(BUILD_DEPENDENCIES) $(P)Qt_Time.cpp
- $(CCC) $(P)Qt_Time.cpp $(QTOPT)
-@@ -1656,7 +1656,7 @@
- @echo "Changed (bin/radium_error_message):"
- @echo $?
- @echo
-- $(CCC) -Wall -Werror $(P)Qt_Error.cpp $(CPPOPT) $(QT_CFLAGS) $(OS_OPTS) -DCOMPILE_EXECUTABLE $(QT_GUI_CFLAGS) -o errormessagebin.o -Wno-missing-declarations
-+ $(CCC) -Wall -Werror $(P)Qt_Error.cpp $(CPPOPT) $(QT_CFLAGS) $(OS_OPTS) -DCOMPILE_EXECUTABLE $(QT_GUI_CFLAGS) -o errormessagebin.o -Wno-missing-declarations -Wno-deprecated-declarations
- $(LINKER) `cat buildtype.opt` errormessagebin.o -o bin/radium_error_message $(QT_GUI_LDFLAGS)
- rm errormessagebin.o
-
-diff -aur --no-dereference radium-5.9.71.pristine/pluginhost/Builds/Linux/Makefile radium-5.9.71.new/pluginhost/Builds/Linux/Makefile
---- radium-5.9.71.pristine/pluginhost/Builds/Linux/Makefile 2019-07-13 10:45:22.009924291 +0100
-+++ radium-5.9.71.new/pluginhost/Builds/Linux/Makefile 2019-07-13 10:40:51.449933531 +0100
-@@ -99,7 +99,7 @@
- $(OBJDIR)/Juce_plugins_6c083ccb.o: ../../../audio/Juce_plugins.cpp
- -@mkdir -p $(OBJDIR)
- @echo "Compiling Juce_plugins.cpp"
-- $(CXX) $(CXXFLAGS) -Wall -o "$@" -c "$<"
-+ $(CXX) $(CXXFLAGS) -Wall -o "$@" -c "$<" -Wno-deprecated-declarations
-
- $(OBJDIR)/Juce_plugin_scanner.o: ../../../audio/Juce_plugin_scanner.cpp
- -@mkdir -p $(OBJDIR)