summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO65
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD195
-rw-r--r--build_linux_common.patch11
-rw-r--r--radium.install11
-rw-r--r--suppress-qt-deprecation-errors.patch33
-rw-r--r--use-libtirpc-headers.patch11
-rw-r--r--use-system-libxcb.patch112
-rw-r--r--use-system-vstsdk.patch44
9 files changed, 181 insertions, 302 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76859516e0b8..0c0a90fb58cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,46 +1,71 @@
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 5.9.71
+ pkgver = 7.3.84
pkgrel = 1
url = https://users.notam02.no/~kjetism/radium
- arch = i686
+ install = radium.install
arch = x86_64
- license = GPL
+ groups = pro-audio
+ license = GPL2
makedepends = boost
- makedepends = clang
makedepends = cmake
makedepends = libxcursor
makedepends = libxinerama
makedepends = libxkbfile
makedepends = libxrandr
- makedepends = llvm
+ makedepends = llvm15
+ makedepends = clang15
makedepends = qt5-tools
- makedepends = steinberg-vst36
+ makedepends = vst2sdk
depends = desktop-file-utils
depends = fftw
depends = glu
+ depends = gsfonts
depends = hicolor-icon-theme
depends = jack
+ depends = liblo
depends = liblrdf
depends = libmpc
- depends = libsamplerate
+ depends = libsndfile
depends = python2
+ depends = qt5-svg
depends = qt5-webkit
depends = qt5-x11extras
depends = speex
- optdepends = calf-ladspa: Default chorus plugin
- optdepends = ladspa-plugins: Package group for default radium plugins incl in binary releases
+ depends = ttf-bitstream-vera
+ depends = ttf-croscore
+ depends = ttf-lato
+ depends = libatomic_ops
+ depends = libsamplerate
+ depends = tk
+ depends = guile
+ depends = libxkbfile
+ depends = openssl
+ depends = ncurses
+ depends = gmp
+ depends = xcb-util-keysyms
+ depends = mpfr
+ depends = libmpc
+ depends = libogg
+ depends = libvorbis
+ depends = openssl
+ depends = alsa-lib
+ depends = glib2
+ depends = binutils
+ depends = xorg-util-macros
+ depends = qt5-base
+ depends = libmicrohttpd
+ depends = ladspa
+ optdepends = new-session-manager: for session management
+ optdepends = calf-ladspa: default chorus plugin used in new file templates
+ optdepends = ladspa-plugins: package group for plugins normally included in binary releases
+ optdepends = vst-plugins: more plugins
options = !strip
- source = https://github.com/kmatheussen/radium/archive/5.9.71.tar.gz
- source = suppress-qt-deprecation-errors.patch
- source = use-libtirpc-headers.patch
- source = use-system-libxcb.patch
- source = use-system-vstsdk.patch
- sha256sums = 9815700d7ca3afbb0f9c0481fd5f04a2345f5fcab36a1c53a79d9aefe4b79fbe
- sha256sums = de9924d5e3dd39182bdd724dac4d8e85996c9fcd8489691e0317d6b5ea265483
- sha256sums = 0dfa3014bc6a66989564c7da2d963681f5d129eb0be28153744693dd533e4909
- sha256sums = 6c29e825e06d1c3aec4afd915718b8c46da705d1411a94f7c0f777b888a9b50d
- sha256sums = 045e4b4c444d1a37dffdcecb87e5245188fadf68444f9a4b14207a5b98671344
+ source = radium-7.3.84.tar.gz::https://github.com/kmatheussen/radium/archive/7.3.84.tar.gz
+ source = radium.install
+ source = build_linux_common.patch
+ sha256sums = 99d42a56491812cbc04fa14f463588740eb2bed8c2f58eadd6e8f45b239fd3f6
+ sha256sums = f627730ff7a819e8cc5ac5c2b5f1fb2f2237327db6ea5442c55a23c1ce82ef14
+ sha256sums = 0decfc3adcba836004ac34d970a83d4d0b69743334a586f42be53b3de7bdd5a4
pkgname = radium
-
diff --git a/.gitignore b/.gitignore
index aabc5d3e2544..aa52232fbb6e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+.ccls-cache
*.tar.*
*.log
pkg/
diff --git a/PKGBUILD b/PKGBUILD
index 9a76f0172186..1619aa3d70ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,114 +1,145 @@
-# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
-# Maintainer: Teteros <teteros at teknik dot io>
+# Maintainer: yustin <#archlinux-proaudio@libera.chat>
+# Contributor: Teteros <teteros at teknik dot io>
+# Contributor: Karol "Kenji Takahashi" Woźniak <kenji.sx>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=radium
-pkgver=5.9.71
+pkgver=7.3.84
pkgrel=1
-pkgdesc="A graphical music editor. A next generation tracker."
-arch=('i686' 'x86_64')
-url="https://users.notam02.no/~kjetism/radium"
-license=('GPL')
+pkgdesc='A graphical music editor. A next generation tracker.'
+arch=(x86_64)
+url=https://users.notam02.no/~kjetism/radium
+license=(GPL2)
+groups=(pro-audio)
depends=(
- 'desktop-file-utils'
- 'fftw'
- 'glu'
- 'hicolor-icon-theme'
- 'jack'
- 'liblrdf'
- 'libmpc'
- 'libsamplerate'
- 'python2'
- 'qt5-webkit'
- 'qt5-x11extras'
- 'speex'
-)
+ desktop-file-utils
+ fftw
+ glu
+ gsfonts
+ hicolor-icon-theme
+ jack
+ liblo
+ liblrdf
+ libmpc
+ libsndfile
+ python2
+ qt5-svg
+ qt5-webkit
+ qt5-x11extras
+ speex
+ ttf-bitstream-vera
+ ttf-croscore
+ ttf-lato
+ libatomic_ops
+ libsamplerate
+ tk
+ guile
+ libxkbfile
+ openssl
+ ncurses
+ gmp
+ xcb-util-keysyms
+ mpfr
+ libmpc
+ libogg
+ libvorbis
+ openssl
+ alsa-lib
+ glib2
+ binutils
+ xorg-util-macros
+ qt5-base
+ libmicrohttpd
+ ladspa
+ )
makedepends=(
- 'boost'
- 'clang'
- 'cmake'
- 'libxcursor'
- 'libxinerama'
- 'libxkbfile'
- 'libxrandr'
- 'llvm'
- 'qt5-tools'
- 'steinberg-vst36'
+ boost
+ cmake
+ libxcursor
+ libxinerama
+ libxkbfile
+ libxrandr
+ llvm15
+ clang15
+ qt5-tools
+ vst2sdk
)
optdepends=(
- 'calf-ladspa: Default chorus plugin'
- 'ladspa-plugins: Package group for default radium plugins incl in binary releases'
+ 'new-session-manager: for session management'
+ 'calf-ladspa: default chorus plugin used in new file templates'
+ 'ladspa-plugins: package group for plugins normally included in binary releases'
+ 'vst-plugins: more plugins'
+)
+options=( !strip )
+source=("$pkgname-$pkgver.tar.gz::https://github.com/kmatheussen/radium/archive/$pkgver.tar.gz"
+ radium.install
+ build_linux_common.patch
)
-options=(!strip)
-source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
- "suppress-qt-deprecation-errors.patch"
- "use-libtirpc-headers.patch"
- "use-system-libxcb.patch"
- "use-system-vstsdk.patch")
-sha256sums=('9815700d7ca3afbb0f9c0481fd5f04a2345f5fcab36a1c53a79d9aefe4b79fbe'
- 'de9924d5e3dd39182bdd724dac4d8e85996c9fcd8489691e0317d6b5ea265483'
- '0dfa3014bc6a66989564c7da2d963681f5d129eb0be28153744693dd533e4909'
- '6c29e825e06d1c3aec4afd915718b8c46da705d1411a94f7c0f777b888a9b50d'
- '045e4b4c444d1a37dffdcecb87e5245188fadf68444f9a4b14207a5b98671344')
+sha256sums=('99d42a56491812cbc04fa14f463588740eb2bed8c2f58eadd6e8f45b239fd3f6'
+ 'f627730ff7a819e8cc5ac5c2b5f1fb2f2237327db6ea5442c55a23c1ce82ef14'
+ '0decfc3adcba836004ac34d970a83d4d0b69743334a586f42be53b3de7bdd5a4'
+ )
+install=radium.install
prepare() {
- cd "${pkgname}-${pkgver}"
-
- # https://github.com/kmatheussen/radium/issues/1226
- patch -p1 < "${srcdir}/suppress-qt-deprecation-errors.patch"
+ cd radium-$pkgver
- # glibc-2.27 deprecated legacy rpc, header files for libpd are in libtirpc
- patch -p1 < "${srcdir}/use-libtirpc-headers.patch"
+ # use llvm15 to compile
+ export PATH=$(pwd):$PATH
+ ln -sf /usr/lib/llvm15/bin/clang clang
+ ln -sf /usr/bin/llvm-config-15 llvm-config
- # Use system libxcb 1.13 instead of radium's to reduce build time
- patch -p1 < "${srcdir}/use-system-libxcb.patch"
-
- # JUCE expects the VST SDK in home directory, this adds paths for SDK in steinberg-vst36 from AUR
- patch -p1 < "${srcdir}/use-system-vstsdk.patch"
-
- # calf-ladspa in AUR uses LMMS's 'veal' fork of Calf LADSPA in which the chorus plugin ref contains a white space
- # Radium has not switched to veal yet for its demo songs, https://github.com/kmatheussen/radium/issues/1158
+ # fix for binutils 2.40
+ patch -p0 < "$srcdir/build_linux_common.patch"
+
+ # This tweak edits new file template and demo songs to be compatible with chorus plugin from calf-ladspa package
+ # New Demosong also needs fixes for LADSPA-Plugins
+ # !! NOTE TO LMMS USERS !!
+ # !! Comment next line out if you have LMMS installed as it already comes with their own version of Calf plugins !!
for file in bin/sounds/*.rad; do sed -i -e 's/Calf MultiChorus LADSPA/Calf Multi Chorus LADSPA/g' "$file"; done
+ for file in bin/sounds/*.RAD; do sed -i -e 's/Calf MultiChorus LADSPA/Calf Multi Chorus LADSPA/g' "$file"; done
+ sed -ie "s/C\* Eq - 10-band equalizer/C\* Eq10 - 10-band equaliser/g" bin/sounds/ROMANCE2.RAD
+ # See comment on calf-ladspa AUR page then on how to let Radium load Calf from LMMS package
}
build() {
- cd "${pkgname}-${pkgver}"
+ cd radium-$pkgver
+ export PATH=$(pwd):$PATH
+ export INCLUDE_FAUSTDEV_BUT_NOT_LLVM=1
- RADIUM_USE_CLANG=1 RADIUM_QT_VERSION=5 make packages
- RADIUM_USE_CLANG=1 RADIUM_QT_VERSION=5 BUILDTYPE=RELEASE ./build_linux.sh
+ RADIUM_QT_VERSION=5 RADIUM_VST2SDK_PATH=/usr/include/vst36 RADIUM_BUILD_LIBXCB=0 make packages
+ RADIUM_QT_VERSION=5 RADIUM_VST2SDK_PATH=/usr/include/vst36 BUILDTYPE=RELEASE ./build_linux.sh
}
package() {
- cd "${pkgname}-${pkgver}"
+ cd radium-$pkgver
# Install radium and its packages to /opt
- ./install.sh "${pkgdir}/opt"
+ RADIUM_INSTALL_LIBXCB=0 ./install.sh "$pkgdir/opt"
+ # radium.install will link ladspa-path here so remove it
+ rm -rf $pkgdir/opt/radium/ladspa
# Create startup script according to bin/packages/README
- mkdir -p "${pkgdir}/usr/bin"
- echo '#!/bin/bash' > "${pkgdir}/usr/bin/radium"
- echo LADSPA_PATH="$LADSPA_PATH:/usr/lib/ladspa" \
- QT_QPA_PLATFORM_PLUGIN_PATH="$($(RADIUM_QT_VERSION=5 ./find_moc_and_uic_paths.sh qmake) -query QT_INSTALL_PLUGINS)" \
- /opt/radium/radium >> "${pkgdir}/usr/bin/radium"
- chmod +x "${pkgdir}/usr/bin/radium"
+ mkdir -p "$pkgdir/usr/bin"
+ echo '#!/usr/bin/env bash' > "$pkgdir/usr/bin/radium"
+ echo QT_QPA_PLATFORM_PLUGIN_PATH="$($(RADIUM_QT_VERSION=5 ./find_moc_and_uic_paths.sh qmake) -query QT_INSTALL_PLUGINS)" \
+ /opt/radium/radium '"$@"' >> "$pkgdir/usr/bin/radium"
+ chmod +x "$pkgdir/usr/bin/radium"
# Icons, .desktop and mimetype files
- mkdir -p "${pkgdir}/usr/share/icons/hicolor/"{16x16,32x32,128x128,256x256}"/apps" \
- "${pkgdir}/usr/share/applications" \
- "${pkgdir}/usr/share/mime/packages"
- ln -s "/opt/radium/radium_16x16x8.png" "${pkgdir}/usr/share/icons/hicolor/16x16/apps/radium.png"
- ln -s "/opt/radium/radium_32x32x24.png" "${pkgdir}/usr/share/icons/hicolor/32x32/apps/radium.png"
- ln -s "/opt/radium/radium_128x128x32.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/radium.png"
- ln -s "/opt/radium/radium_256x256x32.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/radium.png"
- ln -s "/opt/radium/radium.desktop" "${pkgdir}/usr/share/applications/radium.desktop"
- ln -s "/opt/radium/radium-mimetype.xml" "${pkgdir}/usr/share/mime/packages/radium.xml"
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/"{16x16,32x32,128x128,256x256}"/apps" \
+ "$pkgdir/usr/share/applications" \
+ "$pkgdir/usr/share/mime/packages"
+ ln -s "/opt/radium/radium_16x16x8.png" "$pkgdir/usr/share/icons/hicolor/16x16/apps/radium.png"
+ ln -s "/opt/radium/radium_32x32x24.png" "$pkgdir/usr/share/icons/hicolor/32x32/apps/radium.png"
+ ln -s "/opt/radium/radium_128x128x32.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/radium.png"
+ ln -s "/opt/radium/radium_256x256x32.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/radium.png"
+ ln -s "/opt/radium/radium.desktop" "$pkgdir/usr/share/applications/radium.desktop"
+ ln -s "/opt/radium/radium-mimetype.xml" "$pkgdir/usr/share/mime/packages/radium.xml"
}
warn_build_references() {
- # Radium author would prefer if binaries are left unstripped.
- # Meaning debug information inside them will reference build dir, this silences the warning from makepkg.
+ # Silence warning about build dir refs as Radium's author prefers packagers don't strip binaries.
# https://github.com/kmatheussen/radium/issues/1153#issuecomment-421543245
true
}
-
-# vim:set sw=2 ts=2 indentexpr=GetShIndent() et:
diff --git a/build_linux_common.patch b/build_linux_common.patch
new file mode 100644
index 000000000000..cec22c044347
--- /dev/null
+++ b/build_linux_common.patch
@@ -0,0 +1,11 @@
+--- build_linux_common.sh.orig 2023-03-10 14:18:55.074248103 +0100
++++ build_linux_common.sh 2023-03-10 14:20:54.617578515 +0100
+@@ -216,7 +216,7 @@
+ if [[ $RADIUM_USE_CLANG == 1 ]] && [ -f "$CLANG_PREFIX/lib/libbfd.a" ]; then
+ export RADIUM_BFD_LDFLAGS="$CLANG_PREFIX/lib/libbfd.a"
+ else
+- export RADIUM_BFD_LDFLAGS="-Wl,-Bstatic -lbfd -Wl,-Bdynamic"
++ export RADIUM_BFD_LDFLAGS="-Wl,-Bstatic -lbfd -Wl,-Bdynamic -lzstd -lsframe"
+ fi
+ fi
+
diff --git a/radium.install b/radium.install
new file mode 100644
index 000000000000..9cf4f6312ab6
--- /dev/null
+++ b/radium.install
@@ -0,0 +1,11 @@
+### should create a symlink to ladspa in /opt/radium
+### to get rid off the errormessage
+
+post_install() {
+ ln -sf /usr/lib/ladspa /opt/radium/ladspa
+}
+
+pre_remove() {
+ rm /opt/radium/ladspa
+}
+
diff --git a/suppress-qt-deprecation-errors.patch b/suppress-qt-deprecation-errors.patch
deleted file mode 100644
index 59b35e8ce12c..000000000000
--- a/suppress-qt-deprecation-errors.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -aur --no-dereference radium-5.9.71.pristine/Makefile.Qt radium-5.9.71.new/Makefile.Qt
---- radium-5.9.71.pristine/Makefile.Qt 2019-07-13 10:45:22.009924291 +0100
-+++ radium-5.9.71.new/Makefile.Qt 2019-07-13 10:41:32.489932129 +0100
-@@ -1452,7 +1452,7 @@
- $(MOC) $(P)Qt_PopupMenu.cpp -DUSE_QT_MENU >$(P)mQt_PopupMenu.cpp
-
- Qt_MainWindow.o: $(BUILD_DEPENDENCIES) $(P)Qt_MainWindow.cpp $(P)mQt_bottom_bar_widget_callbacks.h $(P)mQt_upperleft_widget_callbacks.h $(P)Rational.h $(P)lzqlineedit.h $(P)helpers.h audio/CpuUsage.hpp Qt/EditorWidget.h Qt/FileRequester.hpp
-- $(CCC) $(P)Qt_MainWindow.cpp $(QTOPT)
-+ $(CCC) $(P)Qt_MainWindow.cpp $(QTOPT) -Wno-deprecated-declarations
-
- Qt_Time.o: $(BUILD_DEPENDENCIES) $(P)Qt_Time.cpp
- $(CCC) $(P)Qt_Time.cpp $(QTOPT)
-@@ -1656,7 +1656,7 @@
- @echo "Changed (bin/radium_error_message):"
- @echo $?
- @echo
-- $(CCC) -Wall -Werror $(P)Qt_Error.cpp $(CPPOPT) $(QT_CFLAGS) $(OS_OPTS) -DCOMPILE_EXECUTABLE $(QT_GUI_CFLAGS) -o errormessagebin.o -Wno-missing-declarations
-+ $(CCC) -Wall -Werror $(P)Qt_Error.cpp $(CPPOPT) $(QT_CFLAGS) $(OS_OPTS) -DCOMPILE_EXECUTABLE $(QT_GUI_CFLAGS) -o errormessagebin.o -Wno-missing-declarations -Wno-deprecated-declarations
- $(LINKER) `cat buildtype.opt` errormessagebin.o -o bin/radium_error_message $(QT_GUI_LDFLAGS)
- rm errormessagebin.o
-
-diff -aur --no-dereference radium-5.9.71.pristine/pluginhost/Builds/Linux/Makefile radium-5.9.71.new/pluginhost/Builds/Linux/Makefile
---- radium-5.9.71.pristine/pluginhost/Builds/Linux/Makefile 2019-07-13 10:45:22.009924291 +0100
-+++ radium-5.9.71.new/pluginhost/Builds/Linux/Makefile 2019-07-13 10:40:51.449933531 +0100
-@@ -99,7 +99,7 @@
- $(OBJDIR)/Juce_plugins_6c083ccb.o: ../../../audio/Juce_plugins.cpp
- -@mkdir -p $(OBJDIR)
- @echo "Compiling Juce_plugins.cpp"
-- $(CXX) $(CXXFLAGS) -Wall -o "$@" -c "$<"
-+ $(CXX) $(CXXFLAGS) -Wall -o "$@" -c "$<" -Wno-deprecated-declarations
-
- $(OBJDIR)/Juce_plugin_scanner.o: ../../../audio/Juce_plugin_scanner.cpp
- -@mkdir -p $(OBJDIR)
diff --git a/use-libtirpc-headers.patch b/use-libtirpc-headers.patch
deleted file mode 100644
index 7244f593f8c8..000000000000
--- a/use-libtirpc-headers.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -aur --no-dereference radium-5.9.60.pristine/bin/packages/build.sh radium-5.9.60.new/bin/packages/build.sh
---- radium-5.9.60.pristine/bin/packages/build.sh 2019-05-11 22:54:53.259293886 +0100
-+++ radium-5.9.60.new/bin/packages/build.sh 2019-05-11 22:55:12.335959902 +0100
-@@ -110,6 +110,7 @@
- rm -fr libpd-master
- tar xvzf libpd-master.tar.gz
- cd libpd-master/
-+sed -i '/define CFLAGS/ s|")| -I/usr/include/tirpc ")|' make.scm
- make clean
- make -j`nproc`
- cd ..
diff --git a/use-system-libxcb.patch b/use-system-libxcb.patch
deleted file mode 100644
index fc3b530af1ed..000000000000
--- a/use-system-libxcb.patch
+++ /dev/null
@@ -1,112 +0,0 @@
-diff -aur --no-dereference radium-5.9.60.pristine/bin/packages/build.sh radium-5.9.60.new/bin/packages/build.sh
---- radium-5.9.60.pristine/bin/packages/build.sh 2019-05-11 22:54:53.259293886 +0100
-+++ radium-5.9.60.new/bin/packages/build.sh 2019-05-11 22:57:03.595956087 +0100
-@@ -185,28 +185,28 @@
- cd ../
- fi
-
--if [[ $RADIUM_QT_VERSION == 5 ]]
--then
--
-- rm -fr xcb-proto-1.13/
-- tar xvjf xcb-proto-1.13.tar.bz2
-- cd xcb-proto-1.13/
-- mkdir install
-- ./configure --prefix=`pwd`/install PYTHON=`which python2`
-- make -j`proc`
-- make install
-- cd ..
--
-- rm -fr libxcb-1.13
-- tar xvjf libxcb-1.13.tar.bz2
-- cd libxcb-1.13
-- #patch -p1 <../libxcb-1.12.patch
-- export PKG_CONFIG_PATH=`pwd`/../xcb-proto-1.13/install/lib/pkgconfig:$PKG_CONFIG_PATH
-- CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" CPPFLAGS="$CXXFLAGS" ./configure PYTHON=`which python2`
-- CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" CPPFLAGS="$CXXFLAGS" make -j`nproc`
-- cd ..
--
--fi
-+#if [[ $RADIUM_QT_VERSION == 5 ]]
-+#then
-+#
-+# rm -fr xcb-proto-1.13/
-+# tar xvjf xcb-proto-1.13.tar.bz2
-+# cd xcb-proto-1.13/
-+# mkdir install
-+# ./configure --prefix=`pwd`/install PYTHON=`which python2`
-+# make -j`proc`
-+# make install
-+# cd ..
-+#
-+# rm -fr libxcb-1.13
-+# tar xvjf libxcb-1.13.tar.bz2
-+# cd libxcb-1.13
-+# #patch -p1 <../libxcb-1.12.patch
-+# export PKG_CONFIG_PATH=`pwd`/../xcb-proto-1.13/install/lib/pkgconfig:$PKG_CONFIG_PATH
-+# CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" CPPFLAGS="$CXXFLAGS" ./configure PYTHON=`which python2`
-+# CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" CPPFLAGS="$CXXFLAGS" make -j`nproc`
-+# cd ..
-+#
-+#fi
-
-
- touch deletemetorebuild
-diff -aur --no-dereference radium-5.9.60.pristine/bin/run_radium_linux.sh radium-5.9.60.new/bin/run_radium_linux.sh
---- radium-5.9.60.pristine/bin/run_radium_linux.sh 2019-05-11 22:54:53.262627219 +0100
-+++ radium-5.9.60.new/bin/run_radium_linux.sh 2019-05-11 22:57:03.595956087 +0100
-@@ -4,14 +4,14 @@
-
-
- THIS_DIR="$(dirname "$(readlink -f "$0")")"
--XCB_LIB_DIR="$THIS_DIR"/packages/libxcb-1.13/src/.libs
-+#XCB_LIB_DIR="$THIS_DIR"/packages/libxcb-1.13/src/.libs
-
--if ! file "$XCB_LIB_DIR" ; then
-- echo "Unable to find directory $XCB_LIB_DIR"
-- exit -1
--fi
-+#if ! file "$XCB_LIB_DIR" ; then
-+# echo "Unable to find directory $XCB_LIB_DIR"
-+# exit -1
-+#fi
-
--export LD_LIBRARY_PATH="$XCB_LIB_DIR"${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
-+#export LD_LIBRARY_PATH="$XCB_LIB_DIR"${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
-
- # To avoid buggy qt plugins crashing radium (very common).
- unset QT_QPA_PLATFORMTHEME
-diff -aur --no-dereference radium-5.9.60.pristine/install.sh radium-5.9.60.new/install.sh
---- radium-5.9.60.pristine/install.sh 2019-05-11 22:54:53.275960552 +0100
-+++ radium-5.9.60.new/install.sh 2019-05-11 22:57:03.595956087 +0100
-@@ -99,7 +99,7 @@
- cd "$THIS_DIR/bin"
-
- # libxcb
--cp -a packages/libxcb-1.13 "$TARGET/packages/"
--cd "$TARGET/packages/libxcb-1.13/src"
--rm -f *.o
--cd "$THIS_DIR/bin"
-+#cp -a packages/libxcb-1.13 "$TARGET/packages/"
-+#cd "$TARGET/packages/libxcb-1.13/src"
-+#rm -f *.o
-+#cd "$THIS_DIR/bin"
-diff -aur --no-dereference radium-5.9.60.pristine/Qt/Qt_Main.cpp radium-5.9.60.new/Qt/Qt_Main.cpp
---- radium-5.9.60.pristine/Qt/Qt_Main.cpp 2019-05-11 22:54:53.245960553 +0100
-+++ radium-5.9.60.new/Qt/Qt_Main.cpp 2019-05-11 22:57:03.595956087 +0100
-@@ -3536,6 +3536,7 @@
-
- #endif // !defined(RELEASE)
-
-+/*
- #if defined(FOR_LINUX)
- {
- QString name(dlpi_name);
-@@ -3547,6 +3548,7 @@
- }
- }
- #endif
-+*/
-
-
- if (is_main_root)
diff --git a/use-system-vstsdk.patch b/use-system-vstsdk.patch
deleted file mode 100644
index 471e217b57fa..000000000000
--- a/use-system-vstsdk.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -aur --no-dereference radium-5.9.61.pristine/check_dependencies.sh radium-5.9.61.new/check_dependencies.sh
---- radium-5.9.61.pristine/check_dependencies.sh 2019-05-15 14:04:11.000000000 +0100
-+++ radium-5.9.61.new/check_dependencies.sh 2019-05-16 10:03:43.252329929 +0100
-@@ -211,11 +211,11 @@
- exit 5
- fi
-
--if [[ ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/"VST3 SDK"/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h ]] ; then
-- echo 'Steinberg VST headers not found. (Missing "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h or "~/SDKs/VST3 SDK/pluginterfaces/vst2.x/aeffect.h" or "~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h")'
-- echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html . Unless Steinberg have changed the directory structure again, it should enough to unzip the file into your ~/SDKs directory.'
-- exit 5
--fi
-+#if [[ ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/"VST3 SDK"/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h ]] ; then
-+# echo 'Steinberg VST headers not found. (Missing "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h or "~/SDKs/VST3 SDK/pluginterfaces/vst2.x/aeffect.h" or "~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h")'
-+# echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html . Unless Steinberg have changed the directory structure again, it should enough to unzip the file into your ~/SDKs directory.'
-+# exit 5
-+#fi
-
-
- if [[ $4 == "test_build" ]] ; then
-diff -aur --no-dereference radium-5.9.61.pristine/Makefile.Qt radium-5.9.61.new/Makefile.Qt
---- radium-5.9.61.pristine/Makefile.Qt 2019-05-15 14:04:11.000000000 +0100
-+++ radium-5.9.61.new/Makefile.Qt 2019-05-16 10:05:39.962325937 +0100
-@@ -269,7 +269,7 @@
-
- FLAGOPTS = $(DEFINES) -DGUIISQT -DUSE_GFX_OP_QUEUE -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
-
--COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_70_0 -I${HOME}/boost_1_67_0 -I${HOME}/boost_1_63_0 -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ~/SDKs/vstsdk2.4/ -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers -Wnull-dereference
-+COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_70_0 -I${HOME}/boost_1_67_0 -I${HOME}/boost_1_63_0 -I /usr/include/vst36 -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ~/SDKs/vstsdk2.4/ -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers -Wnull-dereference
- #-fdelete-null-pointer-checks
- # -Werror
-
-diff -aur --no-dereference radium-5.9.61.pristine/pluginhost/Builds/Linux/Makefile radium-5.9.61.new/pluginhost/Builds/Linux/Makefile
---- radium-5.9.61.pristine/pluginhost/Builds/Linux/Makefile 2019-05-15 14:04:11.000000000 +0100
-+++ radium-5.9.61.new/pluginhost/Builds/Linux/Makefile 2019-05-16 10:03:43.272329928 +0100
-@@ -8,7 +8,7 @@
- CONFIG=Debug
- endif
-
--COMMONCPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I~/SDKs/VST_SDK/VST3_SDK -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I ~/SDKs/vstsdk2.4 -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\"" -mfpmath=sse -msse2
-+COMMONCPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I /usr/include/vst36 -I~/SDKs/VST_SDK/VST3_SDK -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I ~/SDKs/vstsdk2.4 -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\"" -mfpmath=sse -msse2
-
- ifeq (,$(findstring clang,$(CXX)))
- COMMONCPPFLAGS += -Wno-class-memaccess