summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD25
-rw-r--r--faust-accept-current-clang.patch (renamed from faust-accept-clang-390.patch)4
-rw-r--r--fix-X11_keyboard-compilation.patch14
-rw-r--r--use-system-libxcb.patch55
-rw-r--r--use-system-vstsdk.patch8
7 files changed, 104 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3f996c4dee1..11746a589474 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Nov 30 18:00:32 UTC 2016
+# Thu Feb 2 03:56:11 UTC 2017
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 4.3.2
+ pkgver = 4.4.4
pkgrel = 1
url = http://users.notam02.no/~kjetism/radium/
arch = i686
@@ -14,7 +14,6 @@ pkgbase = radium
makedepends = qt5-tools
makedepends = libxrandr
makedepends = steinberg-vst36
- makedepends = libpthread-stubs
depends = python2
depends = libxaw
depends = libsndfile
@@ -30,16 +29,20 @@ pkgbase = radium
depends = libxinerama
depends = libxcursor
options = !strip
- source = https://github.com/kmatheussen/radium/archive/4.3.2.tar.gz
- source = faust-accept-clang-390.patch
+ source = https://github.com/kmatheussen/radium/archive/4.4.4.tar.gz
+ source = faust-accept-current-clang.patch
source = dont-empty-qt-library-paths.patch
source = fix-misleading-indentation.patch
+ source = fix-X11_keyboard-compilation.patch
+ source = use-system-libxcb.patch
source = use-system-vstsdk.patch
- md5sums = 72317a81bf94a34ae0b27188e17f8957
- md5sums = 9c72bd466ead73e36b0c2d4297d76870
+ md5sums = 800c54b418a4247a105a7ceb89e62015
+ md5sums = df250d13d5826b35c9139e6d436ebac9
md5sums = 77c202bc0a36562eb7b805ad6b7a85b3
md5sums = 1ca36c75ce4b3fed28c22753b8dc045a
- md5sums = 661c15bc037131c1ad8f8f11d3bc957f
+ md5sums = 24e927620d8aeb09c83b903a92dacf9f
+ md5sums = 60e99f9362d08726877d14ea2cdfd5c6
+ md5sums = b8ae40ee614d56931f4f8f463912f3c4
pkgname = radium
diff --git a/.gitignore b/.gitignore
index d725ba4cf0d2..cc659a01dad5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
*.tar.*
pkg/
src/
+package.*
diff --git a/PKGBUILD b/PKGBUILD
index 248be2d9a78e..610984d6bb19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=radium
-pkgver=4.3.2
+pkgver=4.4.4
pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
@@ -31,25 +31,28 @@ makedepends=(
'qt5-tools'
'libxrandr'
'steinberg-vst36'
- 'libpthread-stubs'
)
options=(!strip)
source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
- "faust-accept-clang-390.patch"
+ "faust-accept-current-clang.patch"
"dont-empty-qt-library-paths.patch"
"fix-misleading-indentation.patch"
+ "fix-X11_keyboard-compilation.patch"
+ "use-system-libxcb.patch"
"use-system-vstsdk.patch")
-md5sums=('72317a81bf94a34ae0b27188e17f8957'
- '9c72bd466ead73e36b0c2d4297d76870'
+md5sums=('800c54b418a4247a105a7ceb89e62015'
+ 'df250d13d5826b35c9139e6d436ebac9'
'77c202bc0a36562eb7b805ad6b7a85b3'
'1ca36c75ce4b3fed28c22753b8dc045a'
- '661c15bc037131c1ad8f8f11d3bc957f')
+ '24e927620d8aeb09c83b903a92dacf9f'
+ '60e99f9362d08726877d14ea2cdfd5c6'
+ 'b8ae40ee614d56931f4f8f463912f3c4')
prepare() {
cd "${pkgname}-${pkgver}"
- msg2 "Fixing faust2 compilation on llvm 3.9.0"
- patch -Nsp1 < "${srcdir}/faust-accept-clang-390.patch"
+ msg2 "Fixing faust2 compilation on llvm 3.9.1"
+ patch -Nsp1 < "${srcdir}/faust-accept-current-clang.patch"
msg2 "Fixing QT_QPA_PLATFORM_PLUGIN_PATH problem"
patch -Nsp1 < "${srcdir}/dont-empty-qt-library-paths.patch"
@@ -57,6 +60,12 @@ prepare() {
msg2 "Fixing misleading indentation"
patch -Nsp1 < "${srcdir}/fix-misleading-indentation.patch"
+ msg2 "Fixing X11_keyboard compilation"
+ patch -Nsp1 < "${srcdir}/fix-X11_keyboard-compilation.patch"
+
+ msg2 "Switching to systemd-wide libxcb"
+ patch -Nsp1 < "${srcdir}/use-system-libxcb.patch"
+
# Use the VST SDK from steinberg-vst36, so the user doesn't have to
# manually put it into his home directory
msg2 "Switching to system-wide VST SDK"
diff --git a/faust-accept-clang-390.patch b/faust-accept-current-clang.patch
index 568fec8cf42a..d21a1c9e06aa 100644
--- a/faust-accept-clang-390.patch
+++ b/faust-accept-current-clang.patch
@@ -5,8 +5,8 @@ diff -aur --no-dereference package.pristine/bin/packages/faust2/compiler/Makefil
CLANGLIBS=$(CLANGLIBSLIST)
CXXFLAGS += -std=gnu++11
--else ifeq ($(LLVM_VERSION),$(filter $(LLVM_VERSION), 3.8.0))
-+else ifeq ($(LLVM_VERSION),$(filter $(LLVM_VERSION), 3.8.0 3.9.0))
+-else ifeq ($(LLVM_VERSION),$(filter $(LLVM_VERSION), 3.8.0 3.8.1))
++else ifeq ($(LLVM_VERSION),$(filter $(LLVM_VERSION), 3.8.0 3.8.1 3.9.1))
LLVM_VERSION = LLVM_38
CLANGLIBS=$(CLANGLIBSLIST)
CXXFLAGS += -std=gnu++11
diff --git a/fix-X11_keyboard-compilation.patch b/fix-X11_keyboard-compilation.patch
new file mode 100644
index 000000000000..219dc6b94695
--- /dev/null
+++ b/fix-X11_keyboard-compilation.patch
@@ -0,0 +1,14 @@
+Only in package.new: .Makefile.Qt.swp
+diff -aur --no-dereference package.pristine/Makefile.Qt package.new/Makefile.Qt
+--- package.pristine/Makefile.Qt 2017-02-02 01:15:50.335803833 +0100
++++ package.new/Makefile.Qt 2017-02-02 02:18:48.679033631 +0100
+@@ -1087,7 +1087,7 @@
+ $(CC) X11/X11_instrument.c $(OPT)
+
+ X11_keyboard.o: $(BUILD_DEPENDENCIES) X11/X11_keyboard.cpp
+- $(CCC) X11/X11_keyboard.cpp $(QTOPT) -DUSE_QT$(RADIUM_QT_VERSION)
++ $(CCC) X11/X11_keyboard.cpp $(CPPOPT) $(QT_CFLAGS) -DUSE_QT$(RADIUM_QT_VERSION)
+
+ #X11_MidiProperties.o: $(BUILD_DEPENDENCIES) X11/X11_MidiProperties.c
+ # $(CC) X11/X11_MidiProperties.c $(OPT)
+Only in package.new: Makefile.Qt~
diff --git a/use-system-libxcb.patch b/use-system-libxcb.patch
new file mode 100644
index 000000000000..5c5e3872aa88
--- /dev/null
+++ b/use-system-libxcb.patch
@@ -0,0 +1,55 @@
+diff -aur --no-dereference package.pristine/Qt/Qt_Main.cpp package.new/Qt/Qt_Main.cpp
+--- package.pristine/Qt/Qt_Main.cpp 2017-01-26 17:00:32.000000000 +0100
++++ package.new/Qt/Qt_Main.cpp 2017-02-02 02:36:04.552338576 +0100
+@@ -2426,18 +2426,6 @@
+ //abort();
+
+ #endif // !defined(RELEASE)
+-
+-#if defined(FOR_LINUX)
+- {
+- QString name(dlpi_name);
+- if (name.contains("libxcb.so")){
+- if (!name.contains("bin/packages/libxcb-1.12/src/.libs/")){
+- fprintf(stderr,"\n\n%c[31mError. A version of libxcb not included with Radium has been dynamically linked into the program. Something is wrong the installation of Radium.\nOlder versions of libxcb (probably before 1.11.1) are unstable with Radium.%c[0m\n\n", 0x1b, 0x1b);
+- abort();
+- }
+- }
+- }
+-#endif
+
+
+
+Only in package.new/Qt: Qt_Main.cpp~
+diff -aur --no-dereference package.pristine/bin/packages/build.sh package.new/bin/packages/build.sh
+--- package.pristine/bin/packages/build.sh 2017-01-26 17:00:32.000000000 +0100
++++ package.new/bin/packages/build.sh 2017-02-02 02:36:22.135671428 +0100
+@@ -189,27 +189,5 @@
+ cd ../
+ fi
+
+-if [[ $RADIUM_QT_VERSION == 5 ]]
+-then
+-
+- rm -fr xcb-proto-1.12/
+- tar xvjf xcb-proto-1.12.tar.bz2
+- cd xcb-proto-1.12/
+- mkdir install
+- ./configure --prefix=`pwd`/install
+- make
+- make install
+- cd ..
+-
+- rm -fr libxcb-1.12
+- tar xvjf libxcb-1.12.tar.bz2
+- cd libxcb-1.12
+- export PKG_CONFIG_PATH=`pwd`/../xcb-proto-1.12/install/lib/pkgconfig:$PKG_CONFIG_PATH
+- ./configure
+- make
+- cd ..
+-
+-fi
+-
+
+ touch deletemetorebuild
+Only in package.new/bin/packages: build.sh~
diff --git a/use-system-vstsdk.patch b/use-system-vstsdk.patch
index 83f906bdba98..2fe716d09343 100644
--- a/use-system-vstsdk.patch
+++ b/use-system-vstsdk.patch
@@ -5,8 +5,8 @@ diff -aur --no-dereference package.pristine/Makefile.Qt package.new/Makefile.Qt
FLAGOPTS = $(DEFINES) -DGUIISQT -DUSE_GFX_OP_QUEUE -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
--COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_61_0 -I${HOME}/SDKs/vstsdk2.4 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer
-+COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_61_0 -I/usr/include/vst36 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer
+-COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_62_0 -I ~/SDKs/VST3\ SDK -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer -Wno-unknown-pragmas
++COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_62_0 -I/usr/include/vst36 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer -Wno-unknown-pragmas
ifeq ($(RADIUM_QT_VERSION),5)
COMMONOPT += -DUSE_QT5
@@ -17,8 +17,8 @@ diff -aur --no-dereference package.pristine/check_dependencies.sh package.new/ch
exit 5
fi
--if [ ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h ] ; then
-- echo 'Steinberg VST headers not found. (Missing "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h")'
+-if [[ ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/"VST3 SDK"/pluginterfaces/vst2.x/aeffect.h ]] ; then
+- echo 'Steinberg VST headers not found. (Missing "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h or "~/SDKs/VST3 SDK/pluginterfaces/vst2.x/aeffect.h")'
+if [ ! -f /usr/include/vst36/pluginterfaces/vst2.x/aeffect.h ] ; then
+ echo 'Steinberg VST headers not found. (Missing "/usr/include/vst36/pluginterfaces/vst2.x/aeffect.h")'
echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html'