summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD191
-rw-r--r--include-glibc-rpc.patch11
-rwxr-xr-xradium3
-rw-r--r--use-libtirpc-headers.patch11
-rw-r--r--use-static-llvm40.patch (renamed from use-llvm40-static-libs.patch)32
-rw-r--r--use-system-libxcb.patch70
-rw-r--r--use-system-vstsdk.patch33
9 files changed, 177 insertions, 213 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd99d7f76d5a..c8686925d8cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 5.8.9
+ pkgver = 5.9.0
pkgrel = 1
- url = https://users.notam02.no/~kjetism/radium/
+ url = https://users.notam02.no/~kjetism/radium
arch = i686
arch = x86_64
license = GPL
makedepends = boost
makedepends = cmake
+ makedepends = libxcursor
+ makedepends = libxinerama
+ makedepends = libxkbfile
makedepends = libxrandr
- makedepends = lld
makedepends = llvm40
makedepends = qt5-tools
makedepends = steinberg-vst36
+ depends = desktop-file-utils
depends = fftw
depends = glu
depends = hicolor-icon-theme
@@ -20,31 +23,23 @@ pkgbase = radium
depends = liblrdf
depends = libmpc
depends = libsamplerate
- depends = libxaw
- depends = libxcursor
- depends = libxinerama
- depends = libxkbfile
depends = python2
depends = qt5-webkit
depends = qt5-x11extras
depends = speex
- depends = libmpc
- optdepends = calf-ladspa
- optdepends = ladspa-plugins
- optdepends = tcl
+ optdepends = calf-ladspa: Default chorus plugin
+ optdepends = ladspa-plugins: Package group for default radium plugins incl in binary releases
options = !strip
- source = https://github.com/kmatheussen/radium/archive/5.8.9.tar.gz
- source = include-glibc-rpc.patch
- source = radium
- source = use-llvm40-static-libs.patch
+ source = https://github.com/kmatheussen/radium/archive/5.9.0.tar.gz
+ source = use-libtirpc-headers.patch
source = use-system-libxcb.patch
source = use-system-vstsdk.patch
- sha256sums = cc24db8a42bb0d757bff06e2ab7ad34df5fc32214a3819533dace4aace71882c
- sha256sums = 3436c478637fd1c8f7ff4089c30ba7f2048a71de8243756893df35cdb25be893
- sha256sums = 6ea834fbf695187c244bbb1dacc1d462ded807ee4997761fdaa60d5373b386cd
- sha256sums = 4155b427be299ba74c1d9278bcf2b72f720f55c814e01ca38f6f0afbda282890
- sha256sums = ac41c94513ca615a71198a91160b2d605ea73c8a97a0192d275105248669df8d
- sha256sums = 7cfc4d4d5b40055a6f11c304cfc3a64f491880f9028197573090d67d6fd6ddc2
+ source = use-static-llvm40.patch
+ sha256sums = 44f67ea67a05f66090920ed4e68fe30b5ed7ab9dd3249b556ed07611a58e65ba
+ sha256sums = f2596261f9ebd859f9850cbfc97edb7fd5d45cf8768ce47d0721cbf4b2d80c7e
+ sha256sums = 94de9befbe6530c721917445ee3a0c0202371e1b2229784b2ea6e0c0efaf7808
+ sha256sums = 75c606ed2c0f1f42449b2b2a7f6936c37be7a78e658ef4306f21edcd16eb2304
+ sha256sums = 413523f60ae7dea7aa2e223fc035f57b05693eea17ba3889eafaca9173fe5f3d
pkgname = radium
diff --git a/.gitignore b/.gitignore
index 650ccacf84dc..aabc5d3e2544 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,3 @@
*.log
pkg/
src/
-package.*
-steinberg-vst36
diff --git a/PKGBUILD b/PKGBUILD
index a101ca11edc0..d6d09c560bc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,145 +1,104 @@
# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
-# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
-# Contributor: Teteros <teteros at teknik dot io>
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: Teteros <teteros at teknik dot io>
pkgname=radium
-pkgver=5.8.9
+pkgver=5.9.0
pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
-url="https://users.notam02.no/~kjetism/radium/"
+url="https://users.notam02.no/~kjetism/radium"
license=('GPL')
depends=(
- 'fftw'
- 'glu'
- 'hicolor-icon-theme'
- 'jack'
- 'liblrdf'
- 'libmpc'
- 'libsamplerate'
- 'libxaw'
- 'libxcursor'
- 'libxinerama'
- 'libxkbfile'
- 'python2'
- 'qt5-webkit'
- 'qt5-x11extras'
- 'speex'
- 'libmpc'
+ 'desktop-file-utils'
+ 'fftw'
+ 'glu'
+ 'hicolor-icon-theme'
+ 'jack'
+ 'liblrdf'
+ 'libmpc'
+ 'libsamplerate'
+ 'python2'
+ 'qt5-webkit'
+ 'qt5-x11extras'
+ 'speex'
)
-optdepends=('calf-ladspa' 'ladspa-plugins' 'tcl')
makedepends=(
- 'boost'
- 'cmake'
- 'libxrandr'
- 'lld'
- 'llvm40'
- 'qt5-tools'
- 'steinberg-vst36'
+ 'boost'
+ 'cmake'
+ 'libxcursor'
+ 'libxinerama'
+ 'libxkbfile'
+ 'libxrandr'
+ 'llvm40'
+ 'qt5-tools'
+ 'steinberg-vst36'
)
-options=(!strip)
+optdepends=(
+ 'calf-ladspa: Default chorus plugin'
+ 'ladspa-plugins: Package group for default radium plugins incl in binary releases'
+)
+options=(!strip) # https://github.com/kmatheussen/radium/issues/1153#issuecomment-421543245
source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
- "include-glibc-rpc.patch"
- "radium"
- "use-llvm40-static-libs.patch"
+ "use-libtirpc-headers.patch"
"use-system-libxcb.patch"
"use-system-vstsdk.patch"
-)
-sha256sums=('cc24db8a42bb0d757bff06e2ab7ad34df5fc32214a3819533dace4aace71882c'
- '3436c478637fd1c8f7ff4089c30ba7f2048a71de8243756893df35cdb25be893'
- '6ea834fbf695187c244bbb1dacc1d462ded807ee4997761fdaa60d5373b386cd'
- '4155b427be299ba74c1d9278bcf2b72f720f55c814e01ca38f6f0afbda282890'
- 'ac41c94513ca615a71198a91160b2d605ea73c8a97a0192d275105248669df8d'
- '7cfc4d4d5b40055a6f11c304cfc3a64f491880f9028197573090d67d6fd6ddc2')
+ "use-static-llvm40.patch")
+sha256sums=('44f67ea67a05f66090920ed4e68fe30b5ed7ab9dd3249b556ed07611a58e65ba'
+ 'f2596261f9ebd859f9850cbfc97edb7fd5d45cf8768ce47d0721cbf4b2d80c7e'
+ '94de9befbe6530c721917445ee3a0c0202371e1b2229784b2ea6e0c0efaf7808'
+ '75c606ed2c0f1f42449b2b2a7f6936c37be7a78e658ef4306f21edcd16eb2304'
+ '413523f60ae7dea7aa2e223fc035f57b05693eea17ba3889eafaca9173fe5f3d')
prepare() {
- cd "${pkgname}-${pkgver}"
-
- # glibc legacy rpc includes were moved to libtirpc, this patches radium's libpd to locate them
- msg2 "Patching libpd to use legacy rpc includes in libtirpc"
- patch -Nsp1 < "${srcdir}/include-glibc-rpc.patch"
+ cd "${pkgname}-${pkgver}"
- # LLVM5 is not currently supported by Radium's faust fork so we need to
- # link llvm40 statically to avoid conflicts with newer system llvm
- # See https://github.com/kmatheussen/radium/issues/1068
- # and https://users.notam02.no/~kjetism/radium/forum/viewtopic.php?f=7&t=39
- msg2 "Patching faust to link with llvm40-libs statically"
- patch -Nsp1 < "${srcdir}/use-llvm40-static-libs.patch"
+ # glibc-2.27 deprecated legacy rpc, header files for libpd are in libtirpc
+ patch -p1 < "${srcdir}/use-libtirpc-headers.patch"
- # Radium bundles libxcb 1.13+ as F22 has an older version available in repos
- # We can use libxcb from extra repo instead
- msg2 "Switching to system-wide libxcb"
- patch -Nsp1 < "${srcdir}/use-system-libxcb.patch"
+ # Use system libxcb 1.13 instead of radium's to reduce build time
+ patch -p1 < "${srcdir}/use-system-libxcb.patch"
- # Patch paths to use VST SDK from steinberg-vst36 AUR package as
- # JUCE expects the SDK in the users home directory
- msg2 "Using VST SDK from steinberg-vst36 package"
- patch -Nsp1 < "${srcdir}/use-system-vstsdk.patch"
+ # JUCE expects the VST SDK in home directory, this adds paths for SDK in steinberg-vst36
+ patch -p1 < "${srcdir}/use-system-vstsdk.patch"
- # s7 scheme tarball seems to not unpack for some users during make,
- # extracting it here is a workaround until someone with that issue can debug it
- msg2 "Extracting s7.tar.gz"
- tar xvzf bin/packages/s7.tar.gz -C bin/packages
+ # FAUST package is not compatible with LLVM<4.0.1
+ # Link llvm40 statically in radium and faust binaries to avoid conflicts with system llvm
+ # https://github.com/kmatheussen/radium/issues/1068
+ # https://users.notam02.no/~kjetism/radium/forum/viewtopic.php?f=7&t=39
+ patch -p1 < "${srcdir}/use-static-llvm40.patch"
}
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${pkgname}-${pkgver}"
- msg2 "Building packages"
- RADIUM_QT_VERSION=5 make packages
-
- msg2 "Building Radium"
- RADIUM_QT_VERSION=5 BUILDTYPE=RELEASE ./build_linux.sh
+ RADIUM_QT_VERSION=5 make packages
+ RADIUM_QT_VERSION=5 BUILDTYPE=RELEASE ./build_linux.sh
}
package() {
- cd "${pkgname}-${pkgver}"
-
- msg2 "Installing Radium core files"
- install -dm755 "${pkgdir}/opt/radium"
- # Copy everything from bin except packages
- find "bin" -mindepth 1 -maxdepth 1 -name packages -o -exec cp -a "{}" "${pkgdir}/opt/radium/" \;
-
- msg2 "Installing Radium binary wrapper"
- install -Dm755 "${srcdir}/radium" "${pkgdir}/usr/bin/radium"
-
- # Needed to make the Scheme parts of Radium work
- msg2 "Installing s7 sources"
- install -dm755 "${pkgdir}/opt/radium/packages"
- tar -xf "bin/packages/s7.tar.gz" -C "${pkgdir}/opt/radium/packages" \
- --no-same-owner --no-same-permissions --wildcards '*.scm'
-
- msg2 "Installing libpd-master pure-data"
- install -dm755 "${pkgdir}/opt/radium/packages/libpd-master/"
- cp -a "bin/packages/libpd-master/pure-data/" \
- "${pkgdir}/opt/radium/packages/libpd-master/"
-
- msg2 "Installing FAUST libraries and GUI styles"
- install -dm755 "${pkgdir}/opt/radium/packages/faust2/architecture/faust/gui/Styles"
- cp -a "bin/packages/faust2/architecture/faust/gui/Styles" \
- "${pkgdir}/opt/radium/packages/faust2/architecture/faust/gui"
- # Copy faust's *.lib files to be able to import them in faustdev
- cp -a "bin/packages/faust2/architecture/"*".lib" \
- "${pkgdir}/opt/radium/packages/faust2/architecture/"
-
- msg2 "Installing .desktop, icon and mimetype files"
- install -dm755 "${pkgdir}/usr/share/applications"
- ln -s "/opt/radium/radium.desktop" \
- "${pkgdir}/usr/share/applications/radium.desktop"
-
- install -dm755 "${pkgdir}/usr/share/icons/hicolor/"{256x256,128x128,32x32,16x16}"/apps"
- ln -s "/opt/radium/radium_256x256x32.png" \
- "${pkgdir}/usr/share/icons/hicolor/256x256/apps/radium.png"
- ln -s "/opt/radium/radium_128x128x32.png" \
- "${pkgdir}/usr/share/icons/hicolor/128x128/apps/radium.png"
- ln -s "/opt/radium/radium_32x32x24.png" \
- "${pkgdir}/usr/share/icons/hicolor/32x32/apps/radium.png"
- ln -s "/opt/radium/radium_16x16x8.png" \
- "${pkgdir}/usr/share/icons/hicolor/16x16/apps/radium.png"
-
- install -dm755 "${pkgdir}/usr/share/mime/packages"
- ln -s "/opt/radium/radium-mimetype.xml" \
- "${pkgdir}/usr/share/mime/packages/radium.xml"
+ cd "${pkgname}-${pkgver}"
+
+ # Install radium and its packages to /opt
+ ./install.sh "${pkgdir}/opt"
+
+ # Create startup script according to bin/packages/README
+ mkdir -p "${pkgdir}/usr/bin"
+ echo '#!/bin/sh' > "${pkgdir}/usr/bin/radium"
+ echo QT_QPA_PLATFORM_PLUGIN_PATH="$($(RADIUM_QT_VERSION=5 ./find_moc_and_uic_paths.sh qmake) -query QT_INSTALL_PLUGINS)" \
+ /opt/radium/radium >> "${pkgdir}/usr/bin/radium"
+ chmod +x "${pkgdir}/usr/bin/radium"
+
+ # Icons, .desktop and mimetype files
+ mkdir -p "${pkgdir}/usr/share/icons/hicolor/"{16x16,32x32,128x128,256x256}"/apps" \
+ "${pkgdir}/usr/share/applications" \
+ "${pkgdir}/usr/share/mime/packages"
+ ln -s "/opt/radium/radium_16x16x8.png" "${pkgdir}/usr/share/icons/hicolor/16x16/apps/radium.png"
+ ln -s "/opt/radium/radium_32x32x24.png" "${pkgdir}/usr/share/icons/hicolor/32x32/apps/radium.png"
+ ln -s "/opt/radium/radium_128x128x32.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps/radium.png"
+ ln -s "/opt/radium/radium_256x256x32.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/radium.png"
+ ln -s "/opt/radium/radium.desktop" "${pkgdir}/usr/share/applications/radium.desktop"
+ ln -s "/opt/radium/radium-mimetype.xml" "${pkgdir}/usr/share/mime/packages/radium.xml"
}
-# vim:set ts=4 sw=4 et:
+# vim:set sw=2 ts=2 indentexpr=GetShIndent() et:
diff --git a/include-glibc-rpc.patch b/include-glibc-rpc.patch
deleted file mode 100644
index 05424c6f33f8..000000000000
--- a/include-glibc-rpc.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -x .sh -aur radium-5.6.5.pristine/bin/packages/build.sh radium-5.6.5.new/bin/packages/build.sh
---- radium-5.6.5.pristine/bin/packages/build.sh 2018-05-09 21:55:12.740084438 +0100
-+++ radium-5.6.5.new/bin/packages/build.sh 2018-05-09 23:14:07.360090134 +0100
-@@ -97,6 +97,7 @@
- tar xvzf libpd-master.tar.gz
- cd libpd-master/
- make clean
-+sed -i '/define CFLAGS/ s|")| -I/usr/include/tirpc ")|' make.scm
- make -j `nproc`
- cd ..
-
diff --git a/radium b/radium
deleted file mode 100755
index 2c21a2307ff4..000000000000
--- a/radium
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/usr/bin/env bash
-
-QT_QPA_PLATFORM_PLUGIN_PATH=`qmake-qt5 -query QT_INSTALL_PLUGINS` /opt/radium/radium_linux.bin "$@"
diff --git a/use-libtirpc-headers.patch b/use-libtirpc-headers.patch
new file mode 100644
index 000000000000..705b82e8df9a
--- /dev/null
+++ b/use-libtirpc-headers.patch
@@ -0,0 +1,11 @@
+diff -aur --no-dereference radium-5.8.9.pristine/bin/packages/build.sh radium-5.8.9.new/bin/packages/build.sh
+--- radium-5.8.9.pristine/bin/packages/build.sh 2018-09-12 17:40:04.000000000 +0100
++++ radium-5.8.9.new/bin/packages/build.sh 2018-09-15 08:11:31.031841089 +0100
+@@ -97,6 +97,7 @@
+ tar xvzf libpd-master.tar.gz
+ cd libpd-master/
+ make clean
++sed -i '/define CFLAGS/ s|")| -I/usr/include/tirpc ")|' make.scm
+ make -j `nproc`
+ cd ..
+
diff --git a/use-llvm40-static-libs.patch b/use-static-llvm40.patch
index 65e3c4a81d26..00c734171fa0 100644
--- a/use-llvm40-static-libs.patch
+++ b/use-static-llvm40.patch
@@ -1,24 +1,6 @@
-diff -aur radium-5.7.0.pristine/bin/packages/faust2/compiler/CMakeLists.txt radium-5.7.0.new/bin/packages/faust2/compiler/CMakeLists.txt
---- radium-5.7.0.pristine/bin/packages/faust2/compiler/CMakeLists.txt 2018-05-29 13:38:11.000000000 +0100
-+++ radium-5.7.0.new/bin/packages/faust2/compiler/CMakeLists.txt 2018-06-02 16:00:34.790083772 +0100
-@@ -5,12 +5,12 @@
- include_directories(boxes documentator draw draw/device draw/schema errors evaluate extended generator normalize parallelize
- parser patternmatcher propagate signals tlib utils ../libraries . ../architecture)
- find_package(OpenSSL REQUIRED)
--find_program(LLVM_CONFIG llvm-config HINTS /usr/bin /usr/local/bin /usr/local/opt/llvm/bin)
-+find_program(LLVM_CONFIG llvm-config-4.0 HINTS /usr/bin /usr/local/bin /usr/local/opt/llvm/bin)
- if(NOT LLVM_CONFIG)
- message(FATAL_ERROR "Faust2 requires LLVM tooling to be present in the path")
- endif()
- exec_program(${LLVM_CONFIG} ARGS --includedir OUTPUT_VARIABLE LLVM_DIR)
--exec_program(${LLVM_CONFIG} ARGS --libs OUTPUT_VARIABLE LLVM_LIBS)
-+exec_program(${LLVM_CONFIG} ARGS --link-static --libfiles OUTPUT_VARIABLE LLVM_LIBS)
- exec_program(${LLVM_CONFIG} ARGS --version OUTPUT_VARIABLE LLVM_VERSION)
- exec_program(${LLVM_CONFIG} ARGS --ldflags OUTPUT_VARIABLE LLVM_LDFLAGS)
-
-diff -aur radium-5.7.0.pristine/bin/packages/faust2/compiler/Makefile.unix radium-5.7.0.new/bin/packages/faust2/compiler/Makefile.unix
---- radium-5.7.0.pristine/bin/packages/faust2/compiler/Makefile.unix 2018-05-29 13:38:11.000000000 +0100
-+++ radium-5.7.0.new/bin/packages/faust2/compiler/Makefile.unix 2018-06-02 16:00:34.790083772 +0100
+diff -aur --no-dereference radium-5.8.9.pristine/bin/packages/faust2/compiler/Makefile.unix radium-5.8.9.new/bin/packages/faust2/compiler/Makefile.unix
+--- radium-5.8.9.pristine/bin/packages/faust2/compiler/Makefile.unix 2018-09-12 17:40:04.000000000 +0100
++++ radium-5.8.9.new/bin/packages/faust2/compiler/Makefile.unix 2018-09-15 08:12:35.291841616 +0100
@@ -26,7 +26,7 @@
# link a suitable llvm-config to a location somewhere on your PATH, or just
# set LLVM_CONFIG manually.
@@ -42,13 +24,13 @@ diff -aur radium-5.7.0.pristine/bin/packages/faust2/compiler/Makefile.unix radiu
$(CXX) $(CXXFLAGS) $(LDFLAGS) $(objects) main.o libcode.o global.o `$(LLVM_CONFIG) --ldflags` $(LLVMLIBS) $(CLANGLIBS) $(LIBS) -lpthread -o faust
else
- $(CXX) $(CXXFLAGS) $(LDFLAGS) $(objects) main.o libcode.o global.o `$(LLVM_CONFIG) --ldflags` $(LLVMLIBS) $(CLANGLIBS) -ldl -lcrypto -lz -lncurses -lpthread -o faust
-+ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(objects) main.o libcode.o global.o `$(LLVM_CONFIG) --ldflags` $(LLVM_STATIC_LIBS) $(CLANGLIBS) -ldl -lcrypto -lz -lncurses -lpthread -o faust
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(objects) main.o libcode.o global.o $(LLVM_STATIC_LIBS) $(CLANGLIBS) -ldl -lcrypto -lz -lncurses -lpthread -o faust
endif
ifeq ($(system), Darwin)
-diff -aur radium-5.7.0.pristine/build_linux_common.sh radium-5.7.0.new/build_linux_common.sh
---- radium-5.7.0.pristine/build_linux_common.sh 2018-05-29 13:38:11.000000000 +0100
-+++ radium-5.7.0.new/build_linux_common.sh 2018-06-02 16:03:46.770084003 +0100
+diff -aur --no-dereference radium-5.8.9.pristine/build_linux_common.sh radium-5.8.9.new/build_linux_common.sh
+--- radium-5.8.9.pristine/build_linux_common.sh 2018-09-12 17:40:04.000000000 +0100
++++ radium-5.8.9.new/build_linux_common.sh 2018-09-15 08:12:35.291841616 +0100
@@ -106,17 +106,11 @@
PYTHONLIBPATH=`$PYTHONEXE -c "import sys;print '-L'+sys.prefix+'/lib'"`
PYTHONLIBNAME=`$PYTHONEXE -c "import sys;print '-lpython'+sys.version[:3]"`
diff --git a/use-system-libxcb.patch b/use-system-libxcb.patch
index 66ee585a26f8..ebf98b8f0c9a 100644
--- a/use-system-libxcb.patch
+++ b/use-system-libxcb.patch
@@ -1,7 +1,7 @@
-diff --no-dereference -aur radium-5.7.6.pristine/bin/packages/build.sh radium-5.7.6.new/bin/packages/build.sh
---- radium-5.7.6.pristine/bin/packages/build.sh 2018-06-16 09:43:05.000000000 +0100
-+++ radium-5.7.6.new/bin/packages/build.sh 2018-06-17 07:54:17.473316625 +0100
-@@ -168,29 +168,6 @@
+diff -aur --no-dereference radium-5.9.0.pristine/bin/packages/build.sh radium-5.9.0.new/bin/packages/build.sh
+--- radium-5.9.0.pristine/bin/packages/build.sh 2018-09-16 16:43:47.000000000 +0100
++++ radium-5.9.0.new/bin/packages/build.sh 2018-09-16 16:57:25.576723176 +0100
+@@ -171,28 +171,6 @@
cd ../
fi
@@ -27,29 +27,61 @@ diff --no-dereference -aur radium-5.7.6.pristine/bin/packages/build.sh radium-5.
- cd ..
-
-fi
--
+
# Build faust last since we reset the build flags.
+diff -aur --no-dereference radium-5.9.0.pristine/bin/run_radium_linux.sh radium-5.9.0.new/bin/run_radium_linux.sh
+--- radium-5.9.0.pristine/bin/run_radium_linux.sh 2018-09-16 16:43:47.000000000 +0100
++++ radium-5.9.0.new/bin/run_radium_linux.sh 2018-09-16 16:57:25.576723176 +0100
+@@ -4,14 +4,14 @@
+
+
+ THIS_DIR="$(dirname "$(readlink -f "$0")")"
+-XCB_LIB_DIR="$THIS_DIR"/packages/libxcb-1.13/src/.libs
++#XCB_LIB_DIR="$THIS_DIR"/packages/libxcb-1.13/src/.libs
-diff --no-dereference -aur radium-5.7.6.pristine/Qt/Qt_Main.cpp radium-5.7.6.new/Qt/Qt_Main.cpp
---- radium-5.7.6.pristine/Qt/Qt_Main.cpp 2018-06-16 09:43:05.000000000 +0100
-+++ radium-5.7.6.new/Qt/Qt_Main.cpp 2018-06-17 07:58:40.783307624 +0100
-@@ -3444,18 +3444,6 @@
-
- #endif // !defined(RELEASE)
+-if ! file "$XCB_LIB_DIR" ; then
+- echo "Unable to find directory $XCB_LIB_DIR"
+- exit -1
+-fi
++#if ! file "$XCB_LIB_DIR" ; then
++# echo "Unable to find directory $XCB_LIB_DIR"
++# exit -1
++#fi
+
+-export LD_LIBRARY_PATH="$XCB_LIB_DIR"${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
++#export LD_LIBRARY_PATH="$XCB_LIB_DIR"${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
--#if defined(FOR_LINUX)
-- {
-- QString name(dlpi_name);
+ # To avoid buggy qt plugins from crashing radium (very common).
+ unset QT_QPA_PLATFORMTHEME
+diff -aur --no-dereference radium-5.9.0.pristine/install.sh radium-5.9.0.new/install.sh
+--- radium-5.9.0.pristine/install.sh 2018-09-16 16:43:47.000000000 +0100
++++ radium-5.9.0.new/install.sh 2018-09-16 16:58:34.036723259 +0100
+@@ -79,7 +79,7 @@
+ cd "$THIS_DIR/bin"
+
+ # libxcb
+-cp -a packages/libxcb-1.13 "$TARGET/packages/"
+-cd "$TARGET/packages/libxcb-1.13/src"
+-rm -f *.o
+-cd "$THIS_DIR/bin"
++#cp -a packages/libxcb-1.13 "$TARGET/packages/"
++#cd "$TARGET/packages/libxcb-1.13/src"
++#rm -f *.o
++#cd "$THIS_DIR/bin"
+diff -aur --no-dereference radium-5.9.0.pristine/Qt/Qt_Main.cpp radium-5.9.0.new/Qt/Qt_Main.cpp
+--- radium-5.9.0.pristine/Qt/Qt_Main.cpp 2018-09-16 16:43:47.000000000 +0100
++++ radium-5.9.0.new/Qt/Qt_Main.cpp 2018-09-16 16:57:25.586723176 +0100
+@@ -3449,12 +3449,6 @@
+ #if defined(FOR_LINUX)
+ {
+ QString name(dlpi_name);
- if (name.contains("libxcb.so")){
- if (!name.contains("bin/packages/libxcb-1.13/src/.libs/")){
- fprintf(stderr,"\n\n%c[31mError. A version of libxcb not included with Radium has been dynamically linked into the program. Something is wrong the installation of Radium.\nOlder versions of libxcb (probably before 1.11.1) are unstable with Radium.%c[0m\n\n", 0x1b, 0x1b);
- abort();
- }
- }
-- }
--#endif
--
+ }
+ #endif
-
- if (is_main_root)
diff --git a/use-system-vstsdk.patch b/use-system-vstsdk.patch
index 727297f87d08..2a55aa1b988d 100644
--- a/use-system-vstsdk.patch
+++ b/use-system-vstsdk.patch
@@ -1,32 +1,33 @@
-diff -aur --no-dereference radium-5.8.6.pristine/check_dependencies.sh radium-5.8.6.new/check_dependencies.sh
---- radium-5.8.6.pristine/check_dependencies.sh 2018-09-08 10:49:44.000000000 +0100
-+++ radium-5.8.6.new/check_dependencies.sh 2018-09-08 12:56:23.433056983 +0100
-@@ -181,8 +181,8 @@
+diff -aur --no-dereference radium-5.8.9.pristine/check_dependencies.sh radium-5.8.9.new/check_dependencies.sh
+--- radium-5.8.9.pristine/check_dependencies.sh 2018-09-12 17:40:04.000000000 +0100
++++ radium-5.8.9.new/check_dependencies.sh 2018-09-15 08:13:53.091842255 +0100
+@@ -181,11 +181,6 @@
exit 5
fi
-if [[ ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/"VST3 SDK"/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h ]] ; then
- echo 'Steinberg VST headers not found. (Missing "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h or "~/SDKs/VST3 SDK/pluginterfaces/vst2.x/aeffect.h" or "~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h")'
-+if [[ ! -f /usr/include/vst36/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/"VST3 SDK"/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h ]] ; then
-+ echo 'Steinberg VST headers not found. (Missing "/usr/include/vst36/pluginterfaces/vst2.x/aeffect.h" or "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h or "~/SDKs/VST3 SDK/pluginterfaces/vst2.x/aeffect.h" or "~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h")'
- echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html . Unless Steinberg have changed the directory structure again, it should enough to unzip the file into your ~/SDKs directory.'
- exit 5
- fi
-diff -aur --no-dereference radium-5.8.6.pristine/Makefile.Qt radium-5.8.6.new/Makefile.Qt
---- radium-5.8.6.pristine/Makefile.Qt 2018-09-08 10:49:44.000000000 +0100
-+++ radium-5.8.6.new/Makefile.Qt 2018-09-08 12:57:44.603057081 +0100
+- echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html . Unless Steinberg have changed the directory structure again, it should enough to unzip the file into your ~/SDKs directory.'
+- exit 5
+-fi
+
+
+ if [[ $4 == "test_build" ]] ; then
+diff -aur --no-dereference radium-5.8.9.pristine/Makefile.Qt radium-5.8.9.new/Makefile.Qt
+--- radium-5.8.9.pristine/Makefile.Qt 2018-09-12 17:40:04.000000000 +0100
++++ radium-5.8.9.new/Makefile.Qt 2018-09-15 08:13:53.091842255 +0100
@@ -235,7 +235,7 @@
FLAGOPTS = $(DEFINES) -DGUIISQT -DUSE_GFX_OP_QUEUE -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
-COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_63_0 -I${HOME}/boost_1_67_0 -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ~/SDKs/vstsdk2.4/ -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers
-+COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_63_0 -I /usr/include/vst36 -I${HOME}/boost_1_67_0 -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ~/SDKs/vstsdk2.4/ -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers
++COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_63_0 -I${HOME}/boost_1_67_0 -I /usr/include/vst36 -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ~/SDKs/vstsdk2.4/ -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers
#-Wstrict-overflow=4 -Wsuggest-attribute=format -Wstringop-overflow=4
#-Wsuggest-final-types -Wsuggest-final-methods
-diff -aur --no-dereference radium-5.8.6.pristine/pluginhost/Builds/Linux/Makefile radium-5.8.6.new/pluginhost/Builds/Linux/Makefile
---- radium-5.8.6.pristine/pluginhost/Builds/Linux/Makefile 2018-09-08 10:49:44.000000000 +0100
-+++ radium-5.8.6.new/pluginhost/Builds/Linux/Makefile 2018-09-08 12:56:23.433056983 +0100
+diff -aur --no-dereference radium-5.8.9.pristine/pluginhost/Builds/Linux/Makefile radium-5.8.9.new/pluginhost/Builds/Linux/Makefile
+--- radium-5.8.9.pristine/pluginhost/Builds/Linux/Makefile 2018-09-12 17:40:04.000000000 +0100
++++ radium-5.8.9.new/pluginhost/Builds/Linux/Makefile 2018-09-15 08:13:53.091842255 +0100
@@ -8,7 +8,7 @@
CONFIG=Debug
endif