summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD37
-rw-r--r--use-libtirpc-headers.patch14
-rw-r--r--use-static-llvm40.patch56
-rw-r--r--use-system-libxcb.patch75
-rw-r--r--use-system-vstsdk.patch35
6 files changed, 101 insertions, 132 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e225c4087064..81c618195006 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 5.9.52
+ pkgver = 5.9.60
pkgrel = 1
url = https://users.notam02.no/~kjetism/radium
arch = i686
@@ -12,7 +12,7 @@ pkgbase = radium
makedepends = libxinerama
makedepends = libxkbfile
makedepends = libxrandr
- makedepends = llvm40
+ makedepends = llvm
makedepends = qt5-tools
makedepends = steinberg-vst36
depends = desktop-file-utils
@@ -30,16 +30,14 @@ pkgbase = radium
optdepends = calf-ladspa: Default chorus plugin
optdepends = ladspa-plugins: Package group for default radium plugins incl in binary releases
options = !strip
- source = https://github.com/kmatheussen/radium/archive/5.9.52.tar.gz
+ source = https://github.com/kmatheussen/radium/archive/5.9.60.tar.gz
source = use-libtirpc-headers.patch
source = use-system-libxcb.patch
source = use-system-vstsdk.patch
- source = use-static-llvm40.patch
- sha256sums = 86afd2977bc091faca0235f1fd48226233e111e9e50b4c52e1762e8e07cdbc3b
- sha256sums = f2596261f9ebd859f9850cbfc97edb7fd5d45cf8768ce47d0721cbf4b2d80c7e
- sha256sums = 94de9befbe6530c721917445ee3a0c0202371e1b2229784b2ea6e0c0efaf7808
- sha256sums = aefb2973d28056956d55ff89c7ff77e36e6a1213463741d72bf1afe2cfb5affe
- sha256sums = 8b5a038fd3320bd49ed2cd81150aa2550c5f5389529f24fbcd603755977644a7
+ sha256sums = 330d7346b45d0b1bcd04e903da17d87cec8c2261a7e8a335f2372509cab8109f
+ sha256sums = 0dfa3014bc6a66989564c7da2d963681f5d129eb0be28153744693dd533e4909
+ sha256sums = 6c29e825e06d1c3aec4afd915718b8c46da705d1411a94f7c0f777b888a9b50d
+ sha256sums = 0471dab0a9ae8c52fdb15a453b4863d31e82c32ee493c31d9473e34e8391d9df
pkgname = radium
diff --git a/PKGBUILD b/PKGBUILD
index 37d211bfeb90..932594ac2e5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Teteros <teteros at teknik dot io>
pkgname=radium
-pkgver=5.9.52
+pkgver=5.9.60
pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
@@ -30,7 +30,7 @@ makedepends=(
'libxinerama'
'libxkbfile'
'libxrandr'
- 'llvm40'
+ 'llvm'
'qt5-tools'
'steinberg-vst36'
)
@@ -38,17 +38,15 @@ optdepends=(
'calf-ladspa: Default chorus plugin'
'ladspa-plugins: Package group for default radium plugins incl in binary releases'
)
-options=(!strip) # https://github.com/kmatheussen/radium/issues/1153#issuecomment-421543245
+options=(!strip)
source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
"use-libtirpc-headers.patch"
"use-system-libxcb.patch"
- "use-system-vstsdk.patch"
- "use-static-llvm40.patch")
-sha256sums=('86afd2977bc091faca0235f1fd48226233e111e9e50b4c52e1762e8e07cdbc3b'
- 'f2596261f9ebd859f9850cbfc97edb7fd5d45cf8768ce47d0721cbf4b2d80c7e'
- '94de9befbe6530c721917445ee3a0c0202371e1b2229784b2ea6e0c0efaf7808'
- 'aefb2973d28056956d55ff89c7ff77e36e6a1213463741d72bf1afe2cfb5affe'
- '8b5a038fd3320bd49ed2cd81150aa2550c5f5389529f24fbcd603755977644a7')
+ "use-system-vstsdk.patch")
+sha256sums=('330d7346b45d0b1bcd04e903da17d87cec8c2261a7e8a335f2372509cab8109f'
+ '0dfa3014bc6a66989564c7da2d963681f5d129eb0be28153744693dd533e4909'
+ '6c29e825e06d1c3aec4afd915718b8c46da705d1411a94f7c0f777b888a9b50d'
+ '0471dab0a9ae8c52fdb15a453b4863d31e82c32ee493c31d9473e34e8391d9df')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -62,16 +60,8 @@ prepare() {
# JUCE expects the VST SDK in home directory, this adds paths for SDK in steinberg-vst36 from AUR
patch -p1 < "${srcdir}/use-system-vstsdk.patch"
- # Bundled FAUST package is not compatible with LLVM above 4.0.1
- # Link llvm40 statically in radium and faust binaries to avoid conflicts with system llvm
- # https://github.com/kmatheussen/radium/issues/1174
- patch -p1 < "${srcdir}/use-static-llvm40.patch"
-
- # The optional calf-ladspa package in AUR switched to LMMS's 'veal' fork of Calf LADSPA
- # Radium's demo and new .rad song files reference the old/unmaintained calf plugins used in its binary distribution
- # Currently only Calf's 'Multi-Chorus' plugin is used in the preset chorus bus which is replaced by a pipe if missing
- # Simple sed search and replace can be used to replace the old chorus plugin name with the one used in 'veal' plugins
- # https://github.com/kmatheussen/radium/issues/1158
+ # calf-ladspa in AUR uses LMMS's 'veal' fork of Calf LADSPA in which the chorus plugin ref contains a white space
+ # Radium has not switched to veal yet for its demo songs, https://github.com/kmatheussen/radium/issues/1158
for file in bin/sounds/*.rad; do sed -i -e 's/Calf MultiChorus LADSPA/Calf Multi Chorus LADSPA/g' "$file"; done
}
@@ -108,4 +98,11 @@ package() {
ln -s "/opt/radium/radium-mimetype.xml" "${pkgdir}/usr/share/mime/packages/radium.xml"
}
+warn_build_references() {
+ # Radium author would prefer if binaries are left unstripped.
+ # Meaning debug information inside them will reference build dir, this silences the warning from makepkg.
+ # https://github.com/kmatheussen/radium/issues/1153#issuecomment-421543245
+ true
+}
+
# vim:set sw=2 ts=2 indentexpr=GetShIndent() et:
diff --git a/use-libtirpc-headers.patch b/use-libtirpc-headers.patch
index 705b82e8df9a..7244f593f8c8 100644
--- a/use-libtirpc-headers.patch
+++ b/use-libtirpc-headers.patch
@@ -1,11 +1,11 @@
-diff -aur --no-dereference radium-5.8.9.pristine/bin/packages/build.sh radium-5.8.9.new/bin/packages/build.sh
---- radium-5.8.9.pristine/bin/packages/build.sh 2018-09-12 17:40:04.000000000 +0100
-+++ radium-5.8.9.new/bin/packages/build.sh 2018-09-15 08:11:31.031841089 +0100
-@@ -97,6 +97,7 @@
+diff -aur --no-dereference radium-5.9.60.pristine/bin/packages/build.sh radium-5.9.60.new/bin/packages/build.sh
+--- radium-5.9.60.pristine/bin/packages/build.sh 2019-05-11 22:54:53.259293886 +0100
++++ radium-5.9.60.new/bin/packages/build.sh 2019-05-11 22:55:12.335959902 +0100
+@@ -110,6 +110,7 @@
+ rm -fr libpd-master
tar xvzf libpd-master.tar.gz
cd libpd-master/
- make clean
+sed -i '/define CFLAGS/ s|")| -I/usr/include/tirpc ")|' make.scm
- make -j `nproc`
+ make clean
+ make -j`nproc`
cd ..
-
diff --git a/use-static-llvm40.patch b/use-static-llvm40.patch
deleted file mode 100644
index e0be59fa3d08..000000000000
--- a/use-static-llvm40.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-diff -aur --no-dereference radium-5.9.34.pristine/bin/packages/faust2/compiler/Makefile.unix radium-5.9.34.new/bin/packages/faust2/compiler/Makefile.unix
---- radium-5.9.34.pristine/bin/packages/faust2/compiler/Makefile.unix 2019-02-07 17:21:55.000000000 +0000
-+++ radium-5.9.34.new/bin/packages/faust2/compiler/Makefile.unix 2019-02-08 00:38:30.883774254 +0000
-@@ -26,7 +26,7 @@
- # link a suitable llvm-config to a location somewhere on your PATH, or just
- # set LLVM_CONFIG manually.
-
--LLVM_CONFIG = $(lastword $(wildcard /usr/bin/llvm-config* /opt/local/bin/llvm-config* /usr/local/bin/llvm-config*) $(shell which llvm-config 2> /dev/null))
-+LLVM_CONFIG = /usr/bin/llvm-config-4.0
-
- ## On Darwin build both 32 and 64-bits intel versions
- ifeq ($(system), Darwin)
-@@ -47,7 +47,7 @@
- endif
- endif
-
--LLVM_STATIC_LIBS = $(shell $(LLVM_CONFIG) --libfiles)
-+LLVM_STATIC_LIBS = $(shell $(LLVM_CONFIG) --link-static --libfiles)
- LLVM_VERSION = $(shell $(LLVM_CONFIG) --version)
-
- ## On Windows (mingw32) we must link against the socket library.
-@@ -225,7 +225,7 @@
- ifneq ($(findstring MINGW32, $(system)),)
- $(CXX) $(CXXFLAGS) $(LDFLAGS) $(objects) main.o libcode.o global.o `$(LLVM_CONFIG) --ldflags` $(LLVMLIBS) $(CLANGLIBS) $(LIBS) -lpthread -o faust
- else
-- $(CXX) $(CXXFLAGS) $(LDFLAGS) $(objects) main.o libcode.o global.o `$(LLVM_CONFIG) --ldflags` $(LLVMLIBS) $(CLANGLIBS) -ldl -lcrypto -lz -lncurses -lpthread -o faust
-+ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(objects) main.o libcode.o global.o $(LLVM_STATIC_LIBS) $(CLANGLIBS) -ldl -lcrypto -lz -lncurses -lpthread -o faust
- endif
-
- ifeq ($(system), Darwin)
-diff -aur --no-dereference radium-5.9.34.pristine/build_linux_common.sh radium-5.9.34.new/build_linux_common.sh
---- radium-5.9.34.pristine/build_linux_common.sh 2019-02-07 17:21:55.000000000 +0000
-+++ radium-5.9.34.new/build_linux_common.sh 2019-02-08 00:42:18.613767374 +0000
-@@ -107,19 +107,13 @@
- PYTHONLIBPATH=`$PYTHONEXE -c "import sys;print '-L'+sys.prefix+'/lib'"`
- PYTHONLIBNAME=`$PYTHONEXE -c "import sys;print '-lpython'+sys.version[:3]"`
-
--LLVM_OPTS=`llvm-config --cppflags`
--
--MAYBELLVM=`llvm-config --libdir`/libLLVM-`llvm-config --version`.so
--if [ -f $MAYBELLVM ]; then
-- LLVMLIBS=-lLLVM-`llvm-config --version`
--else
-- LLVMLIBS=`llvm-config --libs`
--fi
-+LLVM_OPTS=`llvm-config-4.0 --cppflags`
-+LLVMLIBS=`llvm-config-4.0 --link-static --libfiles`
-
- export QSCINTILLA_PATH=`pwd`/bin/packages/QScintilla_gpl-2.10.8
-
- if env |grep INCLUDE_FAUSTDEV ; then
-- FAUSTLDFLAGS="$QSCINTILLA_PATH/Qt4Qt5/libqscintilla2_qt5.a bin/packages/faust2/compiler/libfaust.a `$PKG --libs uuid` `llvm-config --ldflags` $LLVMLIBS -lcrypto -lncurses"
-+ FAUSTLDFLAGS="$QSCINTILLA_PATH/Qt4Qt5/libqscintilla2_qt5.a bin/packages/faust2/compiler/libfaust.a `$PKG --libs uuid` $LLVMLIBS -lcrypto -lncurses"
- else
- FAUSTLDFLAGS=""
- fi
diff --git a/use-system-libxcb.patch b/use-system-libxcb.patch
index ebf98b8f0c9a..fc3b530af1ed 100644
--- a/use-system-libxcb.patch
+++ b/use-system-libxcb.patch
@@ -1,7 +1,7 @@
-diff -aur --no-dereference radium-5.9.0.pristine/bin/packages/build.sh radium-5.9.0.new/bin/packages/build.sh
---- radium-5.9.0.pristine/bin/packages/build.sh 2018-09-16 16:43:47.000000000 +0100
-+++ radium-5.9.0.new/bin/packages/build.sh 2018-09-16 16:57:25.576723176 +0100
-@@ -171,28 +171,6 @@
+diff -aur --no-dereference radium-5.9.60.pristine/bin/packages/build.sh radium-5.9.60.new/bin/packages/build.sh
+--- radium-5.9.60.pristine/bin/packages/build.sh 2019-05-11 22:54:53.259293886 +0100
++++ radium-5.9.60.new/bin/packages/build.sh 2019-05-11 22:57:03.595956087 +0100
+@@ -185,28 +185,28 @@
cd ../
fi
@@ -13,7 +13,7 @@ diff -aur --no-dereference radium-5.9.0.pristine/bin/packages/build.sh radium-5.
- cd xcb-proto-1.13/
- mkdir install
- ./configure --prefix=`pwd`/install PYTHON=`which python2`
-- make
+- make -j`proc`
- make install
- cd ..
-
@@ -23,16 +23,38 @@ diff -aur --no-dereference radium-5.9.0.pristine/bin/packages/build.sh radium-5.
- #patch -p1 <../libxcb-1.12.patch
- export PKG_CONFIG_PATH=`pwd`/../xcb-proto-1.13/install/lib/pkgconfig:$PKG_CONFIG_PATH
- CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" CPPFLAGS="$CXXFLAGS" ./configure PYTHON=`which python2`
-- CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" CPPFLAGS="$CXXFLAGS" make
+- CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" CPPFLAGS="$CXXFLAGS" make -j`nproc`
- cd ..
-
-fi
++#if [[ $RADIUM_QT_VERSION == 5 ]]
++#then
++#
++# rm -fr xcb-proto-1.13/
++# tar xvjf xcb-proto-1.13.tar.bz2
++# cd xcb-proto-1.13/
++# mkdir install
++# ./configure --prefix=`pwd`/install PYTHON=`which python2`
++# make -j`proc`
++# make install
++# cd ..
++#
++# rm -fr libxcb-1.13
++# tar xvjf libxcb-1.13.tar.bz2
++# cd libxcb-1.13
++# #patch -p1 <../libxcb-1.12.patch
++# export PKG_CONFIG_PATH=`pwd`/../xcb-proto-1.13/install/lib/pkgconfig:$PKG_CONFIG_PATH
++# CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" CPPFLAGS="$CXXFLAGS" ./configure PYTHON=`which python2`
++# CFLAGS="$CFLAGS" CPPFLAGS="$CPPFLAGS" CPPFLAGS="$CXXFLAGS" make -j`nproc`
++# cd ..
++#
++#fi
- # Build faust last since we reset the build flags.
-diff -aur --no-dereference radium-5.9.0.pristine/bin/run_radium_linux.sh radium-5.9.0.new/bin/run_radium_linux.sh
---- radium-5.9.0.pristine/bin/run_radium_linux.sh 2018-09-16 16:43:47.000000000 +0100
-+++ radium-5.9.0.new/bin/run_radium_linux.sh 2018-09-16 16:57:25.576723176 +0100
+ touch deletemetorebuild
+diff -aur --no-dereference radium-5.9.60.pristine/bin/run_radium_linux.sh radium-5.9.60.new/bin/run_radium_linux.sh
+--- radium-5.9.60.pristine/bin/run_radium_linux.sh 2019-05-11 22:54:53.262627219 +0100
++++ radium-5.9.60.new/bin/run_radium_linux.sh 2019-05-11 22:57:03.595956087 +0100
@@ -4,14 +4,14 @@
@@ -52,12 +74,12 @@ diff -aur --no-dereference radium-5.9.0.pristine/bin/run_radium_linux.sh radium-
-export LD_LIBRARY_PATH="$XCB_LIB_DIR"${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
+#export LD_LIBRARY_PATH="$XCB_LIB_DIR"${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}
- # To avoid buggy qt plugins from crashing radium (very common).
+ # To avoid buggy qt plugins crashing radium (very common).
unset QT_QPA_PLATFORMTHEME
-diff -aur --no-dereference radium-5.9.0.pristine/install.sh radium-5.9.0.new/install.sh
---- radium-5.9.0.pristine/install.sh 2018-09-16 16:43:47.000000000 +0100
-+++ radium-5.9.0.new/install.sh 2018-09-16 16:58:34.036723259 +0100
-@@ -79,7 +79,7 @@
+diff -aur --no-dereference radium-5.9.60.pristine/install.sh radium-5.9.60.new/install.sh
+--- radium-5.9.60.pristine/install.sh 2019-05-11 22:54:53.275960552 +0100
++++ radium-5.9.60.new/install.sh 2019-05-11 22:57:03.595956087 +0100
+@@ -99,7 +99,7 @@
cd "$THIS_DIR/bin"
# libxcb
@@ -69,19 +91,22 @@ diff -aur --no-dereference radium-5.9.0.pristine/install.sh radium-5.9.0.new/ins
+#cd "$TARGET/packages/libxcb-1.13/src"
+#rm -f *.o
+#cd "$THIS_DIR/bin"
-diff -aur --no-dereference radium-5.9.0.pristine/Qt/Qt_Main.cpp radium-5.9.0.new/Qt/Qt_Main.cpp
---- radium-5.9.0.pristine/Qt/Qt_Main.cpp 2018-09-16 16:43:47.000000000 +0100
-+++ radium-5.9.0.new/Qt/Qt_Main.cpp 2018-09-16 16:57:25.586723176 +0100
-@@ -3449,12 +3449,6 @@
+diff -aur --no-dereference radium-5.9.60.pristine/Qt/Qt_Main.cpp radium-5.9.60.new/Qt/Qt_Main.cpp
+--- radium-5.9.60.pristine/Qt/Qt_Main.cpp 2019-05-11 22:54:53.245960553 +0100
++++ radium-5.9.60.new/Qt/Qt_Main.cpp 2019-05-11 22:57:03.595956087 +0100
+@@ -3536,6 +3536,7 @@
+
+ #endif // !defined(RELEASE)
+
++/*
#if defined(FOR_LINUX)
{
QString name(dlpi_name);
-- if (name.contains("libxcb.so")){
-- if (!name.contains("bin/packages/libxcb-1.13/src/.libs/")){
-- fprintf(stderr,"\n\n%c[31mError. A version of libxcb not included with Radium has been dynamically linked into the program. Something is wrong the installation of Radium.\nOlder versions of libxcb (probably before 1.11.1) are unstable with Radium.%c[0m\n\n", 0x1b, 0x1b);
-- abort();
-- }
-- }
+@@ -3547,6 +3548,7 @@
+ }
}
#endif
++*/
+
+ if (is_main_root)
diff --git a/use-system-vstsdk.patch b/use-system-vstsdk.patch
index dfcdad4aa989..a9cd2373252b 100644
--- a/use-system-vstsdk.patch
+++ b/use-system-vstsdk.patch
@@ -1,7 +1,7 @@
-diff -aur --no-dereference radium-5.9.51.pristine/check_dependencies.sh radium-5.9.51.new/check_dependencies.sh
---- radium-5.9.51.pristine/check_dependencies.sh 2019-04-02 21:02:25.000000000 +0100
-+++ radium-5.9.51.new/check_dependencies.sh 2019-04-03 16:47:17.163749245 +0100
-@@ -211,11 +211,6 @@
+diff -aur --no-dereference radium-5.9.60.pristine/check_dependencies.sh radium-5.9.60.new/check_dependencies.sh
+--- radium-5.9.60.pristine/check_dependencies.sh 2019-05-11 22:54:53.265960552 +0100
++++ radium-5.9.60.new/check_dependencies.sh 2019-05-11 22:58:13.635953702 +0100
+@@ -211,11 +211,11 @@
exit 5
fi
@@ -10,13 +10,18 @@ diff -aur --no-dereference radium-5.9.51.pristine/check_dependencies.sh radium-5
- echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html . Unless Steinberg have changed the directory structure again, it should enough to unzip the file into your ~/SDKs directory.'
- exit 5
-fi
++#if [[ ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/"VST3 SDK"/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h ]] ; then
++# echo 'Steinberg VST headers not found. (Missing "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h or "~/SDKs/VST3 SDK/pluginterfaces/vst2.x/aeffect.h" or "~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h")'
++# echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html . Unless Steinberg have changed the directory structure again, it should enough to unzip the file into your ~/SDKs directory.'
++# exit 5
++#fi
if [[ $4 == "test_build" ]] ; then
-diff -aur --no-dereference radium-5.9.51.pristine/Makefile.Qt radium-5.9.51.new/Makefile.Qt
---- radium-5.9.51.pristine/Makefile.Qt 2019-04-02 21:02:25.000000000 +0100
-+++ radium-5.9.51.new/Makefile.Qt 2019-04-03 16:48:33.380415989 +0100
-@@ -242,7 +242,7 @@
+diff -aur --no-dereference radium-5.9.60.pristine/Makefile.Qt radium-5.9.60.new/Makefile.Qt
+--- radium-5.9.60.pristine/Makefile.Qt 2019-05-11 22:54:53.245960553 +0100
++++ radium-5.9.60.new/Makefile.Qt 2019-05-11 22:58:13.639287034 +0100
+@@ -252,7 +252,7 @@
FLAGOPTS = $(DEFINES) -DGUIISQT -DUSE_GFX_OP_QUEUE -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
@@ -25,15 +30,15 @@ diff -aur --no-dereference radium-5.9.51.pristine/Makefile.Qt radium-5.9.51.new/
#-fdelete-null-pointer-checks
# -Werror
-diff -aur --no-dereference radium-5.9.51.pristine/pluginhost/Builds/Linux/Makefile radium-5.9.51.new/pluginhost/Builds/Linux/Makefile
---- radium-5.9.51.pristine/pluginhost/Builds/Linux/Makefile 2019-04-02 21:02:25.000000000 +0100
-+++ radium-5.9.51.new/pluginhost/Builds/Linux/Makefile 2019-04-03 16:47:17.167082577 +0100
+diff -aur --no-dereference radium-5.9.60.pristine/pluginhost/Builds/Linux/Makefile radium-5.9.60.new/pluginhost/Builds/Linux/Makefile
+--- radium-5.9.60.pristine/pluginhost/Builds/Linux/Makefile 2019-05-11 22:54:53.279293885 +0100
++++ radium-5.9.60.new/pluginhost/Builds/Linux/Makefile 2019-05-11 22:58:13.639287034 +0100
@@ -8,7 +8,7 @@
CONFIG=Debug
endif
--COMMONCPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I~/SDKs/VST_SDK/VST3_SDK -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I ~/SDKs/vstsdk2.4 -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\"" -Wno-class-memaccess -mfpmath=sse -msse2
-+COMMONCPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I /usr/include/vst36 -I~/SDKs/VST_SDK/VST3_SDK -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I ~/SDKs/vstsdk2.4 -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\"" -Wno-class-memaccess -mfpmath=sse -msse2
+-COMMONCPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I~/SDKs/VST_SDK/VST3_SDK -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I ~/SDKs/vstsdk2.4 -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\"" -mfpmath=sse -msse2
++COMMONCPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I /usr/include/vst36 -I~/SDKs/VST_SDK/VST3_SDK -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I ~/SDKs/vstsdk2.4 -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\"" -mfpmath=sse -msse2
- ifeq ($(CONFIG),Debug)
- BINDIR := build
+ ifeq (,$(findstring clang,$(CXX)))
+ COMMONCPPFLAGS += -Wno-class-memaccess