summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--0001-Internal-Various-compilation-fixes-plus-assert-that-.patch280
-rw-r--r--0002-Sequencer-Fix-program-sometimes-crashing-in-debug-mo.patch39
-rw-r--r--0003-Linux-Macosx-Fix-compiling-with-newer-bdf.h.patch69
-rw-r--r--PKGBUILD22
-rw-r--r--use-libtirpc-headers.patch11
-rw-r--r--use-system-vstsdk.patch28
7 files changed, 428 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e6e149014c0..84a5e12f0691 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 5.9.96
+ pkgver = 5.9.98
pkgrel = 1
url = https://users.notam02.no/~kjetism/radium
arch = i686
arch = x86_64
license = GPL2
makedepends = boost
- makedepends = clang
makedepends = cmake
makedepends = ladspa
makedepends = libxcursor
@@ -33,14 +32,20 @@ pkgbase = radium
depends = ttf-bitstream-vera
depends = ttf-lato
optdepends = calf-ladspa: Default chorus plugin
- optdepends = ladspa-plugins: Package group for default radium plugins incl in binary releases
+ optdepends = ladspa-plugins: Package group for default radium plugins included in binary releases
options = !strip
- source = https://github.com/kmatheussen/radium/archive/5.9.96.tar.gz
+ source = https://github.com/kmatheussen/radium/archive/5.9.98.tar.gz
+ source = 0001-Internal-Various-compilation-fixes-plus-assert-that-.patch
+ source = 0002-Sequencer-Fix-program-sometimes-crashing-in-debug-mo.patch
+ source = 0003-Linux-Macosx-Fix-compiling-with-newer-bdf.h.patch
source = use-system-libxcb.patch
source = use-system-vstsdk.patch
- sha256sums = 932c4091cd8d77a18dc042675447bfc6ccac1c04f945846b5ec6d45107663169
+ sha256sums = 3b1b5b9f72536d79561f602f278611979fbc9a8720cd3064c001998a22de9e90
+ sha256sums = c658253e13eb5e5dbe44d5e968634da4ea474885bd4ea33b4d7c586b8aa58cc2
+ sha256sums = eb6641f77506799eab7f3fadccd5e129fc3a5f1a4cefd099d97dd1918aaa26d8
+ sha256sums = b0841d5979936a87b179a5ac8a61f326493b50ddcdb79b10da27870af1b204ab
sha256sums = 6c29e825e06d1c3aec4afd915718b8c46da705d1411a94f7c0f777b888a9b50d
- sha256sums = 045e4b4c444d1a37dffdcecb87e5245188fadf68444f9a4b14207a5b98671344
+ sha256sums = a1ee3635dd9338e2ea2fc76cddf670fcb046afeba553a12b73158cf0b51a52f6
pkgname = radium
diff --git a/0001-Internal-Various-compilation-fixes-plus-assert-that-.patch b/0001-Internal-Various-compilation-fixes-plus-assert-that-.patch
new file mode 100644
index 000000000000..28b68eef2c2e
--- /dev/null
+++ b/0001-Internal-Various-compilation-fixes-plus-assert-that-.patch
@@ -0,0 +1,280 @@
+From 94af14231e09e9b4dbe462622b7d5eb97896de59 Mon Sep 17 00:00:00 2001
+From: Kjetil Matheussen <k.s.matheussen@notam02.no>
+Date: Thu, 5 Mar 2020 12:52:37 +0100
+Subject: [PATCH 1/3] Internal: Various compilation fixes, plus assert that we
+ are not trying to free a memory object with finalization
+
+---
+ OpenGL/Widget.cpp | 4 ++--
+ Qt/Qt_Main.cpp | 4 +++-
+ Qt/Qt_MainWindow.cpp | 4 ++++
+ Qt/Qt_settings.cpp | 2 +-
+ api/s7_types_generator.scm | 3 +++
+ audio/SoundProducer.cpp | 14 ++++++++++++-
+ common/memory.c | 20 +++++++++++++++++--
+ common/nsmtracker.h | 9 +++++++++
+ common/sequencer.cpp | 40 ++++++++++++++++++++++++++++++++++----
+ 9 files changed, 89 insertions(+), 11 deletions(-)
+
+diff --git a/OpenGL/Widget.cpp b/OpenGL/Widget.cpp
+index 90f97b751..5a8dc15ef 100644
+--- a/OpenGL/Widget.cpp
++++ b/OpenGL/Widget.cpp
+@@ -2541,7 +2541,7 @@ bool GL_check_compatibility(void){
+ SETTINGS_write_bool("show_vsync_warning_during_startup", false);
+ }
+ }
+-
++
+ if (is_opengl_certainly_too_old_questionmark()){
+ GFX_Message(NULL,
+ "Your version of OpenGL is too old. Radium can not run.\n"
+@@ -2551,7 +2551,7 @@ bool GL_check_compatibility(void){
+ //exit(-1);
+ return false;
+ }
+-
++
+ if (!is_opengl_version_recent_enough_questionmark()){
+ vector_t v = {};
+ VECTOR_push_back(&v,"Try to run anywyay"); // (but please don't send a bug report if Radium crashes)");
+diff --git a/Qt/Qt_Main.cpp b/Qt/Qt_Main.cpp
+index 65798d9c3..afa6f5a01 100755
+--- a/Qt/Qt_Main.cpp
++++ b/Qt/Qt_Main.cpp
+@@ -3723,7 +3723,9 @@ int main(int argc, char **argv){
+ #endif
+
+ #if defined(FOR_WINDOWS)
++#if defined(RELEASE)
+ DWORD progress_pid = atoi(argv[2]);
++#endif
+ GC_set_no_dls(1);
+ #endif
+
+@@ -3874,7 +3876,7 @@ int main(int argc, char **argv){
+ //QPixmap pixmap(QPixmap(OS_get_full_program_file_path("/home/kjetil/radium/pictures/logo_big.png")).scaled(QSize(256,256), Qt::KeepAspectRatioByExpanding));
+ GFX_OpenProgress("Please wait, starting program");
+
+-#if defined(FOR_WINDOWS)
++#if defined(RELEASE) && defined(FOR_WINDOWS)
+ {
+ auto handle = OpenProcess(PROCESS_ALL_ACCESS, TRUE, progress_pid);
+ if (handle != NULL)
+diff --git a/Qt/Qt_MainWindow.cpp b/Qt/Qt_MainWindow.cpp
+index 8884892d9..1387ccc6e 100644
+--- a/Qt/Qt_MainWindow.cpp
++++ b/Qt/Qt_MainWindow.cpp
+@@ -26,7 +26,11 @@ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. */
+
+ #include <QApplication>
+ //#include <QSplitter>
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wnull-dereference"
+ #include <QCloseEvent>
++#pragma GCC diagnostic pop
++
+ #include <QStatusBar>
+ #include <QMenuBar>
+ #include <QUrl>
+diff --git a/Qt/Qt_settings.cpp b/Qt/Qt_settings.cpp
+index 7a7c80a81..b7df29d52 100644
+--- a/Qt/Qt_settings.cpp
++++ b/Qt/Qt_settings.cpp
+@@ -104,7 +104,7 @@ wchar_t *STRING_create(const QString s, bool use_gc_alloc){
+
+ bool is_main_thread = THREADING_is_main_thread();
+ if (is_main_thread==false)
+- R_ASSERT(use_gc_alloc==false);
++ R_ASSERT_NON_RELEASE(use_gc_alloc==false);
+
+ if (is_main_thread==false || use_gc_alloc==false){
+ array = (wchar_t*)malloc(size);
+diff --git a/api/s7_types_generator.scm b/api/s7_types_generator.scm
+index 29b706eb9..77bff8fb5 100755
+--- a/api/s7_types_generator.scm
++++ b/api/s7_types_generator.scm
+@@ -68,8 +68,11 @@ exec guile -e main -s $0 $*
+ (<->
+ " const wchar_t* o = val.id==NULL ? NULL : wcsdup(val.id);\n")
+ (<->
++ "#pragma GCC diagnostic push\n"
++ "#pragma GCC diagnostic ignored \"-Wint-to-pointer-cast\"\n"
+ " if (sizeof(" c-type ") <= sizeof(void*))\n"
+ " return s7_make_c_object(s7, g_" type "_type_tag, (void*)(val.id));\n"
++ "#pragma GCC diagnostic pop\n"
+ "\n"
+ " " c-type " *o = (" c-type "*)malloc(sizeof(" c-type "));\n"
+ " *o = val.id;\n"))
+diff --git a/audio/SoundProducer.cpp b/audio/SoundProducer.cpp
+index b30ccb693..3b021d921 100644
+--- a/audio/SoundProducer.cpp
++++ b/audio/SoundProducer.cpp
+@@ -309,6 +309,12 @@ public:
+ if (source_ch==0 && target_ch==0){
+
+ SoundPlugin *plugin = SP_get_plugin(source);
++#if !defined(RELEASE)
++ if(plugin==NULL){ // silence "null-dereference" warning.
++ abort();
++ return false;
++ }
++#endif
+ const SoundPluginType *type = plugin->type;
+ int effect_num = type->num_effects + EFFNUM_BUS1 + _bus_num;
+
+@@ -340,7 +346,13 @@ public:
+ if (_is_bus_link){
+
+ SoundPlugin *plugin = SP_get_plugin(source);
+- const SoundPluginType *type = plugin->type;
++#if !defined(RELEASE)
++ if(plugin==NULL){ // silence "null-dereference" warning.
++ abort();
++ return 0;
++ }
++#endif
++ const SoundPluginType *type = plugin->type;
+ int effect_num = type->num_effects + EFFNUM_BUS1 + _bus_num;
+
+ //printf("Setting bus volume for %d to %f\n", bus_num, volume);
+diff --git a/common/memory.c b/common/memory.c
+index ebbf38109..08d54900c 100755
+--- a/common/memory.c
++++ b/common/memory.c
+@@ -66,10 +66,26 @@ void init_memory(void){
+ return;
+ }
+
++#if !defined(RELEASE)
++#ifndef DISABLE_BDWGC
++static void dummy_finalizer(void *actual_mem_start, void *user_data){
++}
++#endif
++#endif
+
+ void tfree(void *element){
+- ASSERT_IS_NONRT_MAIN_THREAD_NON_RELEASE()
+-
++ ASSERT_IS_NONRT_MAIN_THREAD_NON_RELEASE();
++
++#if !defined(RELEASE)
++#ifndef DISABLE_BDWGC
++ // Check that element has no finalizer.
++ GC_finalization_proc old = NULL;
++ GC_register_finalizer(element, dummy_finalizer, NULL, &old, NULL);
++ if (old!=NULL)
++ abort();
++#endif
++#endif
++
+ #ifdef DISABLE_BDWGC
+
+ if(element==NULL){
+diff --git a/common/nsmtracker.h b/common/nsmtracker.h
+index eff912ad4..eb92f9c22 100755
+--- a/common/nsmtracker.h
++++ b/common/nsmtracker.h
+@@ -145,9 +145,14 @@ static_assert (sizeof(long long int) >= 8, "sizof(long long int) must be 8 or hi
+ #pragma clang diagnostic push
+ #pragma clang diagnostic ignored "-Wshorten-64-to-32"
+
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wnull-dereference"
++
+ #include <QList>
+ #include <QMap>
+
++#pragma GCC diagnostic pop
++
+ #pragma clang diagnostic pop
+
+ #if !defined(__clang__)
+@@ -3285,6 +3290,10 @@ struct SeqBlock{
+
+ float envelope_db; // db version of envelope_volume
+
++#if !defined(RELEASE)
++ int64_t gcfinalizerdebuggingvariable;
++#endif
++
+ struct SeqblockAutomation *automations[NUM_SATS];
+
+ struct StretchspeedTimeConversionTable conversion_table;
+diff --git a/common/sequencer.cpp b/common/sequencer.cpp
+index 66989672c..ff2616678 100644
+--- a/common/sequencer.cpp
++++ b/common/sequencer.cpp
+@@ -386,12 +386,35 @@ void SONG_call_me_before_starting_to_play_song(int64_t seqtime){
+ gotit.wait_for_all_future_signals();
+ }
+
+-
++#if !defined(RELEASE)
++static int g_finalizer_num = 0;
++namespace{
++struct WithNum{
++ int num = g_finalizer_num++;
++ bool has_been_finalized = false;
++};
++}
++#define MAGIC_FINALIZER_NUM 19340834513
++#endif
++
++#if 1
++
+ static void seqblockgcfinalizer(void *actual_mem_start, void *user_data){
+ struct SeqBlock *seqblock = (struct SeqBlock*)actual_mem_start;
+ //printf("=============================FINALIZING seqblock\n");
+ //abort();
+ //getchar();
++
++#if !defined(RELEASE)
++ WithNum *withnum = (WithNum*)user_data;
++ if (withnum->num<0 || withnum->has_been_finalized==true)
++ abort();
++ withnum->has_been_finalized=true;
++ printf(" Seqblock finalizing %d\n", withnum->num);
++
++ if (seqblock->gcfinalizerdebuggingvariable != MAGIC_FINALIZER_NUM)
++ abort();
++#endif
+
+ for(int i = 0 ; i < NUM_SATS; i++)
+ SEQBLOCK_AUTOMATION_free(seqblock->automations[i]);
+@@ -401,7 +424,7 @@ static void seqblockgcfinalizer(void *actual_mem_start, void *user_data){
+
+ SEQBLOCK_STRETCHSPEED_call_me_when_seqblock_is_released(seqblock);
+ }
+-
++#endif
+ static int64_t get_default_duration_from_num_samples(const struct SeqTrack *seqtrack, struct SeqBlock *seqblock, int64_t num_samples){
+ R_ASSERT_RETURN_IF_FALSE2(seqblock->block==NULL, pc->pfreq);
+ R_ASSERT_RETURN_IF_FALSE2(seqtrack->patch!=NULL, pc->pfreq);
+@@ -512,12 +535,21 @@ void SEQBLOCK_init(const struct SeqTrack *seqtrack, struct SeqBlock *seqblock, s
+ }
+ }
+
+-
++ /*
++ static vector_t temp = {};
++ VECTOR_push_back(&temp, seqblock);
++ */
++
+ seqblock->fade_in_envelope = new radium::Envelope(FADE_LINEAR, 1.0, true);
+ seqblock->fade_out_envelope = new radium::Envelope(FADE_LINEAR, 1.0, false);
+
++#if defined(RELEASE)
+ GC_register_finalizer(seqblock, seqblockgcfinalizer, NULL, NULL, NULL);
+-
++#else
++ seqblock->gcfinalizerdebuggingvariable = MAGIC_FINALIZER_NUM;
++ GC_register_finalizer(seqblock, seqblockgcfinalizer, (void*)new WithNum, NULL, NULL);
++#endif
++
+ }else{
+
+ // Happens when starting to play block.
+--
+2.25.1
+
diff --git a/0002-Sequencer-Fix-program-sometimes-crashing-in-debug-mo.patch b/0002-Sequencer-Fix-program-sometimes-crashing-in-debug-mo.patch
new file mode 100644
index 000000000000..3c559d3a1e4e
--- /dev/null
+++ b/0002-Sequencer-Fix-program-sometimes-crashing-in-debug-mo.patch
@@ -0,0 +1,39 @@
+From a49a43e3cc88e958f53d04f3a7ac41b3e81304d5 Mon Sep 17 00:00:00 2001
+From: Kjetil Matheussen <k.s.matheussen@notam02.no>
+Date: Thu, 5 Mar 2020 12:56:36 +0100
+Subject: [PATCH 2/3] Sequencer: Fix program sometimes crashing in debug mode
+ when finalizing a seqblock or seqtrack. Only seen it happen on windows32 for
+ some reason.
+
+---
+ common/sequencer.cpp | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/common/sequencer.cpp b/common/sequencer.cpp
+index ff2616678..2149fa5bb 100644
+--- a/common/sequencer.cpp
++++ b/common/sequencer.cpp
+@@ -2236,8 +2236,10 @@ void SEQTRACK_delete_seqblock(struct SeqTrack *seqtrack, const struct SeqBlock *
+
+ #if !defined(RELEASE)
+ //memset((void*)seqblock, 0, sizeof(struct SeqBlock));
++ /*
+ if(seqblock->block != NULL) // Can't release sample seqblock memory here since it may still be used in Seqtrack_plugin.cpp.
+- tfree((void*)seqblock); // Only for debugging.
++ tfree((void*)seqblock); // Only for debugging. // Commented out, can't tfree memory that has a finalizer.
++ */
+ #endif
+ }
+
+@@ -3206,7 +3208,7 @@ void SEQUENCER_delete_seqtrack(int pos){
+
+ #if !defined(RELEASE)
+ //memset(old_seqtrack, 0, sizeof(struct SeqTrack));
+- tfree((void*)old_seqtrack);
++ // tfree((void*)old_seqtrack); // Commented out, can't tfree memory that has a finalizer.
+ #endif
+ }
+
+--
+2.25.1
+
diff --git a/0003-Linux-Macosx-Fix-compiling-with-newer-bdf.h.patch b/0003-Linux-Macosx-Fix-compiling-with-newer-bdf.h.patch
new file mode 100644
index 000000000000..acba206a87f5
--- /dev/null
+++ b/0003-Linux-Macosx-Fix-compiling-with-newer-bdf.h.patch
@@ -0,0 +1,69 @@
+From 37df0d0a2c5263c4be22c56ba6ddcbd65ef16371 Mon Sep 17 00:00:00 2001
+From: Kjetil Matheussen <k.s.matheussen@notam02.no>
+Date: Fri, 6 Mar 2020 14:19:16 +0100
+Subject: [PATCH 3/3] Linux/Macosx: Fix compiling with newer bdf.h
+
+---
+ crashreporter/backtrace-symbols.c | 30 ++++++++++++++++++++++++++++--
+ 1 file changed, 28 insertions(+), 2 deletions(-)
+
+diff --git a/crashreporter/backtrace-symbols.c b/crashreporter/backtrace-symbols.c
+index 0ee3a43fc..393703584 100644
+--- a/crashreporter/backtrace-symbols.c
++++ b/crashreporter/backtrace-symbols.c
+@@ -57,6 +57,16 @@ Downloaded from http://opensource.apple.com/source/X11libs/X11libs-40.2/cairo/ca
+ //#if defined(FOR_LINUX)
+ //# include <libiberty.h> // mac ports doesn't install this file.
+ //#endif
++
++#if defined(bfd_get_section_flags)
++#define OLD_BFD_VERSION 1
++#define NEW_BFD_VERSION 0
++#else
++#define OLD_BFD_VERSION 0
++#define NEW_BFD_VERSION 1
++#endif
++
++
+ #include <dlfcn.h>
+ #include <link.h>
+ #if 0
+@@ -133,17 +143,33 @@ static void find_address_in_section(bfd *abfd, asection *section, void *data __a
+ if (found)
+ return;
+
+- if ((bfd_get_section_flags(abfd, section) & SEC_ALLOC) == 0)
++#if NEW_BFD_VERSION
++
++ if ((bfd_section_flags(section) & SEC_ALLOC) == 0)
++ return;
++
++ vma = bfd_section_vma(section);
++ if (pc2 < vma)
++ return;
++
++ size = bfd_section_size(section);
++ if (pc2 >= vma + size)
+ return;
+
++#else
++ if ((bfd_get_section_flags(abfd, section) & SEC_ALLOC) == 0)
++ return;
++
+ vma = bfd_get_section_vma(abfd, section);
+ if (pc2 < vma)
+ return;
+-
++
+ size = bfd_section_size(abfd, section);
+ if (pc2 >= vma + size)
+ return;
+
++#endif
++
+ found = bfd_find_nearest_line(abfd, section, syms, pc2 - vma,
+ &filename, &functionname, &line);
+ }
+--
+2.25.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 9c7b0909cd78..9a85368882c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Teteros <teteros at teknik dot io>
pkgname=radium
-pkgver=5.9.96
+pkgver=5.9.98
pkgrel=1
pkgdesc='A graphical music editor. A next generation tracker.'
arch=(i686 x86_64)
@@ -28,7 +28,6 @@ depends=(
)
makedepends=(
boost
- clang
cmake
ladspa
libxcursor
@@ -41,15 +40,21 @@ makedepends=(
)
optdepends=(
'calf-ladspa: Default chorus plugin'
- 'ladspa-plugins: Package group for default radium plugins incl in binary releases'
+ 'ladspa-plugins: Package group for default radium plugins included in binary releases'
)
options=(!strip)
source=(https://github.com/kmatheussen/radium/archive/$pkgver.tar.gz
+ 0001-Internal-Various-compilation-fixes-plus-assert-that-.patch
+ 0002-Sequencer-Fix-program-sometimes-crashing-in-debug-mo.patch
+ 0003-Linux-Macosx-Fix-compiling-with-newer-bdf.h.patch
use-system-libxcb.patch
use-system-vstsdk.patch)
-sha256sums=('932c4091cd8d77a18dc042675447bfc6ccac1c04f945846b5ec6d45107663169'
+sha256sums=('3b1b5b9f72536d79561f602f278611979fbc9a8720cd3064c001998a22de9e90'
+ 'c658253e13eb5e5dbe44d5e968634da4ea474885bd4ea33b4d7c586b8aa58cc2'
+ 'eb6641f77506799eab7f3fadccd5e129fc3a5f1a4cefd099d97dd1918aaa26d8'
+ 'b0841d5979936a87b179a5ac8a61f326493b50ddcdb79b10da27870af1b204ab'
'6c29e825e06d1c3aec4afd915718b8c46da705d1411a94f7c0f777b888a9b50d'
- '045e4b4c444d1a37dffdcecb87e5245188fadf68444f9a4b14207a5b98671344')
+ 'a1ee3635dd9338e2ea2fc76cddf670fcb046afeba553a12b73158cf0b51a52f6')
prepare() {
cd radium-$pkgver
@@ -60,6 +65,9 @@ prepare() {
# Set VST SDK location to steinberg-vst36 rather than look for it in user's home folder
patch -p1 < "$srcdir/use-system-vstsdk.patch"
+ # Compile fix for gdb9 https://github.com/kmatheussen/radium/issues/1246
+ for commit in "$srcdir"/000?-*.patch; do patch -p1 < "$commit"; done
+
# Edit new file template and demo songs to be compatible with chorus plugin from calf-ladspa
for file in bin/sounds/*.rad; do sed -i -e 's/Calf MultiChorus LADSPA/Calf Multi Chorus LADSPA/g' "$file"; done
}
@@ -67,8 +75,8 @@ prepare() {
build() {
cd radium-$pkgver
- RADIUM_USE_CLANG=1 RADIUM_QT_VERSION=5 make packages
- RADIUM_USE_CLANG=1 RADIUM_QT_VERSION=5 BUILDTYPE=RELEASE ./build_linux.sh
+ RADIUM_QT_VERSION=5 make packages
+ RADIUM_QT_VERSION=5 BUILDTYPE=RELEASE ./build_linux.sh
}
package() {
diff --git a/use-libtirpc-headers.patch b/use-libtirpc-headers.patch
deleted file mode 100644
index 7244f593f8c8..000000000000
--- a/use-libtirpc-headers.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -aur --no-dereference radium-5.9.60.pristine/bin/packages/build.sh radium-5.9.60.new/bin/packages/build.sh
---- radium-5.9.60.pristine/bin/packages/build.sh 2019-05-11 22:54:53.259293886 +0100
-+++ radium-5.9.60.new/bin/packages/build.sh 2019-05-11 22:55:12.335959902 +0100
-@@ -110,6 +110,7 @@
- rm -fr libpd-master
- tar xvzf libpd-master.tar.gz
- cd libpd-master/
-+sed -i '/define CFLAGS/ s|")| -I/usr/include/tirpc ")|' make.scm
- make clean
- make -j`nproc`
- cd ..
diff --git a/use-system-vstsdk.patch b/use-system-vstsdk.patch
index 471e217b57fa..c790aa679204 100644
--- a/use-system-vstsdk.patch
+++ b/use-system-vstsdk.patch
@@ -1,7 +1,7 @@
-diff -aur --no-dereference radium-5.9.61.pristine/check_dependencies.sh radium-5.9.61.new/check_dependencies.sh
---- radium-5.9.61.pristine/check_dependencies.sh 2019-05-15 14:04:11.000000000 +0100
-+++ radium-5.9.61.new/check_dependencies.sh 2019-05-16 10:03:43.252329929 +0100
-@@ -211,11 +211,11 @@
+diff -aur --no-dereference radium-5.9.98.pristine/check_dependencies.sh radium-5.9.98.new/check_dependencies.sh
+--- radium-5.9.98.pristine/check_dependencies.sh 2020-03-04 11:54:26.000000000 +0000
++++ radium-5.9.98.new/check_dependencies.sh 2020-03-05 19:39:44.645529813 +0000
+@@ -226,11 +226,11 @@
exit 5
fi
@@ -18,21 +18,21 @@ diff -aur --no-dereference radium-5.9.61.pristine/check_dependencies.sh radium-5
if [[ $4 == "test_build" ]] ; then
-diff -aur --no-dereference radium-5.9.61.pristine/Makefile.Qt radium-5.9.61.new/Makefile.Qt
---- radium-5.9.61.pristine/Makefile.Qt 2019-05-15 14:04:11.000000000 +0100
-+++ radium-5.9.61.new/Makefile.Qt 2019-05-16 10:05:39.962325937 +0100
-@@ -269,7 +269,7 @@
+diff -aur --no-dereference radium-5.9.98.pristine/Makefile.Qt radium-5.9.98.new/Makefile.Qt
+--- radium-5.9.98.pristine/Makefile.Qt 2020-03-04 11:54:26.000000000 +0000
++++ radium-5.9.98.new/Makefile.Qt 2020-03-05 19:48:52.498540565 +0000
+@@ -296,7 +296,7 @@
- FLAGOPTS = $(DEFINES) -DGUIISQT -DUSE_GFX_OP_QUEUE -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
+ FLAGOPTS = $(DEFINES) -DGUIISQT -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
--COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_70_0 -I${HOME}/boost_1_67_0 -I${HOME}/boost_1_63_0 -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ~/SDKs/vstsdk2.4/ -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers -Wnull-dereference
-+COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_70_0 -I${HOME}/boost_1_67_0 -I${HOME}/boost_1_63_0 -I /usr/include/vst36 -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK -I ~/SDKs/vstsdk2.4/ -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers -Wnull-dereference
+-COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_70_0 -I${HOME}/boost_1_67_0 -I${HOME}/boost_1_63_0 -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/vstsdk2.4/ -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers -Wnull-dereference
++COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_70_0 -I${HOME}/boost_1_67_0 -I${HOME}/boost_1_63_0 -I /usr/include/vst36 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers -Wnull-dereference
#-fdelete-null-pointer-checks
# -Werror
-diff -aur --no-dereference radium-5.9.61.pristine/pluginhost/Builds/Linux/Makefile radium-5.9.61.new/pluginhost/Builds/Linux/Makefile
---- radium-5.9.61.pristine/pluginhost/Builds/Linux/Makefile 2019-05-15 14:04:11.000000000 +0100
-+++ radium-5.9.61.new/pluginhost/Builds/Linux/Makefile 2019-05-16 10:03:43.272329928 +0100
+diff -aur --no-dereference radium-5.9.98.pristine/pluginhost/Builds/Linux/Makefile radium-5.9.98.new/pluginhost/Builds/Linux/Makefile
+--- radium-5.9.98.pristine/pluginhost/Builds/Linux/Makefile 2020-03-04 11:54:26.000000000 +0000
++++ radium-5.9.98.new/pluginhost/Builds/Linux/Makefile 2020-03-05 19:39:44.648863139 +0000
@@ -8,7 +8,7 @@
CONFIG=Debug
endif