summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--rem-sndlib-include.patch11
3 files changed, 28 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61b4c08df27a..216d2b96a4c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 5.9.12
+ pkgver = 5.9.15
pkgrel = 1
url = https://users.notam02.no/~kjetism/radium
arch = i686
@@ -30,16 +30,18 @@ pkgbase = radium
optdepends = calf-ladspa: Default chorus plugin
optdepends = ladspa-plugins: Package group for default radium plugins incl in binary releases
options = !strip
- source = https://github.com/kmatheussen/radium/archive/5.9.12.tar.gz
+ source = https://github.com/kmatheussen/radium/archive/5.9.15.tar.gz
source = use-libtirpc-headers.patch
source = use-system-libxcb.patch
source = use-system-vstsdk.patch
source = use-static-llvm40.patch
- sha256sums = 273302cbe0b8bc24d07cc7b13a40f7a5361b0a6ef3386ee2169a8e3df3f6fd77
+ source = rem-sndlib-include.patch
+ sha256sums = ba6459d1810ada9210b0904188f2ee47ba7965d5fe6e2da57e5d3cbdc5f641f8
sha256sums = f2596261f9ebd859f9850cbfc97edb7fd5d45cf8768ce47d0721cbf4b2d80c7e
sha256sums = 94de9befbe6530c721917445ee3a0c0202371e1b2229784b2ea6e0c0efaf7808
sha256sums = 75c606ed2c0f1f42449b2b2a7f6936c37be7a78e658ef4306f21edcd16eb2304
sha256sums = f4f35f6d0abb59f7db685f7e4e4d5e4c875fef83ed43672b4abad4da7f8989df
+ sha256sums = f1bcf6efd96af99c99f5f043a5e3400b0603a5c5facd609bd4dac300cd61f01a
pkgname = radium
diff --git a/PKGBUILD b/PKGBUILD
index 4ab72651343a..b64de9d8aad2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Teteros <teteros at teknik dot io>
pkgname=radium
-pkgver=5.9.12
+pkgver=5.9.15
pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
@@ -43,12 +43,14 @@ source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
"use-libtirpc-headers.patch"
"use-system-libxcb.patch"
"use-system-vstsdk.patch"
- "use-static-llvm40.patch")
-sha256sums=('273302cbe0b8bc24d07cc7b13a40f7a5361b0a6ef3386ee2169a8e3df3f6fd77'
+ "use-static-llvm40.patch"
+ "rem-sndlib-include.patch")
+sha256sums=('ba6459d1810ada9210b0904188f2ee47ba7965d5fe6e2da57e5d3cbdc5f641f8'
'f2596261f9ebd859f9850cbfc97edb7fd5d45cf8768ce47d0721cbf4b2d80c7e'
'94de9befbe6530c721917445ee3a0c0202371e1b2229784b2ea6e0c0efaf7808'
'75c606ed2c0f1f42449b2b2a7f6936c37be7a78e658ef4306f21edcd16eb2304'
- 'f4f35f6d0abb59f7db685f7e4e4d5e4c875fef83ed43672b4abad4da7f8989df')
+ 'f4f35f6d0abb59f7db685f7e4e4d5e4c875fef83ed43672b4abad4da7f8989df'
+ 'f1bcf6efd96af99c99f5f043a5e3400b0603a5c5facd609bd4dac300cd61f01a')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -67,6 +69,9 @@ prepare() {
# https://github.com/kmatheussen/radium/issues/1068
# https://users.notam02.no/~kjetism/radium/forum/viewtopic.php?f=7&t=39
patch -p1 < "${srcdir}/use-static-llvm40.patch"
+
+ # https://github.com/kmatheussen/radium/issues/1161
+ patch -p1 < "${srcdir}/rem-sndlib-include.patch"
}
build() {
@@ -84,8 +89,9 @@ package() {
# Create startup script according to bin/packages/README
mkdir -p "${pkgdir}/usr/bin"
- echo '#!/bin/sh' > "${pkgdir}/usr/bin/radium"
- echo QT_QPA_PLATFORM_PLUGIN_PATH="$($(RADIUM_QT_VERSION=5 ./find_moc_and_uic_paths.sh qmake) -query QT_INSTALL_PLUGINS)" \
+ echo '#!/bin/bash' > "${pkgdir}/usr/bin/radium"
+ echo LADSPA_PATH=/usr/lib/ladspa \
+ QT_QPA_PLATFORM_PLUGIN_PATH="$($(RADIUM_QT_VERSION=5 ./find_moc_and_uic_paths.sh qmake) -query QT_INSTALL_PLUGINS)" \
/opt/radium/radium >> "${pkgdir}/usr/bin/radium"
chmod +x "${pkgdir}/usr/bin/radium"
diff --git a/rem-sndlib-include.patch b/rem-sndlib-include.patch
new file mode 100644
index 000000000000..61aa31482832
--- /dev/null
+++ b/rem-sndlib-include.patch
@@ -0,0 +1,11 @@
+diff -aur --no-dereference radium-5.9.15.pristine/audio/GranResampler.hpp radium-5.9.15.new/audio/GranResampler.hpp
+--- radium-5.9.15.pristine/audio/GranResampler.hpp 2018-11-22 01:00:49.000000000 +0000
++++ radium-5.9.15.new/audio/GranResampler.hpp 2018-11-22 04:53:13.179089408 +0000
+@@ -18,7 +18,6 @@
+ #define _RADIUM_AUDIO_GRANRESAMPLER_HPP
+
+
+-#include "../bin/packages/sndlib/clm.h"
+ #include "Resampler_proc.h"
+
+