summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
-rw-r--r--reenable-libbfd-workaround.patch14
-rw-r--r--use-gcc5-for-pluginhost.patch36
4 files changed, 80 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8b91c589699..28b81abb924b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Sat May 7 16:53:53 UTC 2016
+# Mon Jun 6 15:34:49 UTC 2016
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 3.8.3
+ pkgver = 3.9.1
pkgrel = 1
url = http://users.notam02.no/~kjetism/radium/
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
+ makedepends = gcc5
makedepends = boost
depends = python2
depends = libxaw
@@ -24,8 +25,12 @@ pkgbase = radium
depends = libxinerama
depends = libxcursor
options = !strip
- source = https://github.com/kmatheussen/radium/archive/3.8.3.tar.gz
- md5sums = b5863a9d6150791a452aba932f7bf57b
+ source = https://github.com/kmatheussen/radium/archive/3.9.1.tar.gz
+ source = reenable-libbfd-workaround.patch
+ source = use-gcc5-for-pluginhost.patch
+ md5sums = f14e8266682a35c1b8f22f226bd490ea
+ md5sums = 74ea7a54f0e358035a7f0cc7baf54b6e
+ md5sums = 9c19006defeef7e317ec23ed8eae1b72
pkgname = radium
diff --git a/PKGBUILD b/PKGBUILD
index 0c04e43001fe..c7c384bb84a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
+# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
# NOTICE: This needs Steinberg VST Audio Plug-Ins SDK in ~/SDKs to work.
# It can obtained like this:
@@ -8,7 +9,7 @@
# 4. cp -va "VST3 SDK/." ~/SDKs/vstsdk2.4
pkgname=radium
-pkgver=3.8.3
+pkgver=3.9.1
pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
@@ -31,11 +32,27 @@ depends=(
)
makedepends=(
'cmake'
+ 'gcc5'
'boost'
)
options=(!strip)
-source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz")
-md5sums=('b5863a9d6150791a452aba932f7bf57b')
+source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
+ "reenable-libbfd-workaround.patch"
+ "use-gcc5-for-pluginhost.patch")
+md5sums=('f14e8266682a35c1b8f22f226bd490ea'
+ '74ea7a54f0e358035a7f0cc7baf54b6e'
+ '9c19006defeef7e317ec23ed8eae1b72')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ # See https://github.com/kmatheussen/radium/commit/22be69fd24235cafb5878692d574d500f843c911#commitcomment-17394610
+ patch -Np1 < "${srcdir}/reenable-libbfd-workaround.patch"
+ # Some parts of JUCE that Radium uses depend on unstandardized behaviour
+ # specific to GCC5, so they don't compile with Arch's regular GCC6 and we
+ # have to switch back manually
+ patch -Np1 < "${srcdir}/use-gcc5-for-pluginhost.patch"
+}
build() {
cd "${pkgname}-${pkgver}"
@@ -57,7 +74,7 @@ package() {
# Restore s7 sources - needed to make the Scheme parts of Radium work
mkdir -p "${pkgdir}/opt/radium/packages"
tar -xvf "bin/packages/s7.tar.gz" -C "${pkgdir}/opt/radium/packages" \
- --no-same-owner --no-same-permissions
+ --no-same-owner --no-same-permissions --wildcards '*.scm'
}
# vim:set ts=4 sw=4 et:
diff --git a/reenable-libbfd-workaround.patch b/reenable-libbfd-workaround.patch
new file mode 100644
index 000000000000..d45eeaeeb555
--- /dev/null
+++ b/reenable-libbfd-workaround.patch
@@ -0,0 +1,14 @@
+diff -aur package.pristine/crashreporter/crashreporter_posix.c package.new/crashreporter/crashreporter_posix.c
+--- package.pristine/crashreporter/crashreporter_posix.c 2016-06-05 23:57:15.720344670 +0200
++++ package.new/crashreporter/crashreporter_posix.c 2016-06-05 23:57:33.723548061 +0200
+@@ -28,8 +28,8 @@
+ #include <stdio.h>
+
+
+-//#define PACKAGE 1 // workaround for bug in libbfd
+-//#define PACKAGE_VERSION 1 // workaround for bug in libbfd
++#define PACKAGE 1 // workaround for bug in libbfd
++#define PACKAGE_VERSION 1 // workaround for bug in libbfd
+ #include "backtrace-symbols.c"
+
+ #elif defined(FOR_MACOSX)
diff --git a/use-gcc5-for-pluginhost.patch b/use-gcc5-for-pluginhost.patch
new file mode 100644
index 000000000000..3a46aea46e59
--- /dev/null
+++ b/use-gcc5-for-pluginhost.patch
@@ -0,0 +1,36 @@
+diff -aur package.pristine/Makefile.Qt package.new/Makefile.Qt
+--- package.pristine/Makefile.Qt 2016-06-06 16:51:53.304728252 +0200
++++ package.new/Makefile.Qt 2016-06-06 16:56:08.792762710 +0200
+@@ -65,6 +65,7 @@
+ PKG ?= pkg-config
+
+ CCC ?= g++
++PLUGINHOST_CCC ?= g++-5
+ CC ?= gcc
+ GCC ?= $(CC)
+ GPLUSPLUS ?= $(CCC)
+@@ -407,7 +408,7 @@
+ # -lasound
+
+ # Adding "TARGET_ARCH=-g" to prevent juce from compiling with -march=native
+-PLUGINHOSTOPTS = CXX="$(CCC) -DDEBUG_ALLOWED -DJUCE_ALSA_MIDI_INPUT_NAME=\\\"Radium\\\" -DJUCE_ALSA_MIDI_OUTPUT_NAME=\\\"Radium\\\"" TARGET_ARCH=-g
++PLUGINHOSTOPTS = CXX="$(PLUGINHOST_CCC) -DDEBUG_ALLOWED -DJUCE_ALSA_MIDI_INPUT_NAME=\\\"Radium\\\" -DJUCE_ALSA_MIDI_OUTPUT_NAME=\\\"Radium\\\"" TARGET_ARCH=-g
+
+ pluginhost/Builds/Linux/build/libMyPluginHost.a: audio/Juce_plugins.cpp midi/midi_juce.cpp flagopts.opt pluginhost/MyPluginHost.jucer $(API)/radium_proc.h
+ # dryrun
+diff -aur package.pristine/build_linux_common.sh package.new/build_linux_common.sh
+--- package.pristine/build_linux_common.sh 2016-06-06 16:51:53.384727636 +0200
++++ package.new/build_linux_common.sh 2016-06-06 16:55:09.099888420 +0200
+@@ -29,6 +29,7 @@
+
+ #export CCC="clang++ -mfpmath=sse -msse2"
+ export CCC="g++ -mfpmath=sse -msse2"
++export PLUGINHOST_CCC="g++-5 -mfpmath=sse -msse2"
+ export CC="gcc -mfpmath=sse -msse2"
+ #export CC="clang -Wno-gnu-designator -mfpmath=sse -msse2 -Wenum-conversion "
+ export GCC="gcc -mfpmath=sse -msse2"
+@@ -98,3 +99,4 @@
+ cp -p *.o linux_objs/ 2>/dev/null | true
+
+
++