summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD55
-rw-r--r--dont-empty-qt-library-paths.patch42
-rw-r--r--faust-accept-current-clang.patch12
-rw-r--r--fix-X11_keyboard-compilation.patch14
-rw-r--r--fix-misleading-indentation.patch12
-rw-r--r--use-system-libxcb.patch73
-rw-r--r--use-system-vstsdk.patch33
8 files changed, 131 insertions, 137 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b52ef86276f..a1f4e1308478 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Sat Feb 18 22:14:56 UTC 2017
+# Tue Apr 11 18:40:17 UTC 2017
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 4.5.0
+ pkgver = 4.6.6
pkgrel = 1
- url = http://users.notam02.no/~kjetism/radium/
+ url = https://users.notam02.no/~kjetism/radium/
arch = i686
arch = x86_64
license = GPL
@@ -16,8 +16,6 @@ pkgbase = radium
makedepends = steinberg-vst36
depends = python2
depends = libxaw
- depends = libsndfile
- depends = libsamplerate
depends = liblrdf
depends = qt5-webkit
depends = qt5-x11extras
@@ -28,21 +26,18 @@ pkgbase = radium
depends = jack
depends = libxinerama
depends = libxcursor
+ depends = hicolor-icon-theme
+ optdepends = calf-ladspa
+ optdepends = ladspa-plugins
options = !strip
- source = https://github.com/kmatheussen/radium/archive/4.5.0.tar.gz
- source = faust-accept-current-clang.patch
+ source = https://github.com/kmatheussen/radium/archive/4.6.6.tar.gz
source = dont-empty-qt-library-paths.patch
- source = fix-misleading-indentation.patch
- source = fix-X11_keyboard-compilation.patch
source = use-system-libxcb.patch
source = use-system-vstsdk.patch
- md5sums = e2bddd56d0e9dc3a9cdf89249a3915ef
- md5sums = df250d13d5826b35c9139e6d436ebac9
- md5sums = 77c202bc0a36562eb7b805ad6b7a85b3
- md5sums = 1ca36c75ce4b3fed28c22753b8dc045a
- md5sums = 24e927620d8aeb09c83b903a92dacf9f
- md5sums = 60e99f9362d08726877d14ea2cdfd5c6
- md5sums = 5c78211475528b588cabced5f024eb54
+ md5sums = 4a2e4050ce8350d1d0287524b4916cd2
+ md5sums = d63cea387564fa21dee775e764206a45
+ md5sums = d798d5655e2899dc1b54f797d9b2bda3
+ md5sums = d068d4bc99360cd4ec933c57ab9f5159
pkgname = radium
diff --git a/PKGBUILD b/PKGBUILD
index c21139075fed..a5cad71547dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
# Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
+# Contributor: Teteros <teteros -at- opmbx -dot- org>
pkgname=radium
-pkgver=4.5.0
+pkgver=4.6.6
pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
-url="http://users.notam02.no/~kjetism/radium/"
+url="https://users.notam02.no/~kjetism/radium/"
license=('GPL')
depends=(
'python2'
'libxaw'
- 'libsndfile'
- 'libsamplerate'
'liblrdf'
'qt5-webkit'
'qt5-x11extras'
@@ -23,7 +22,9 @@ depends=(
'jack'
'libxinerama'
'libxcursor'
+ 'hicolor-icon-theme'
)
+optdepends=('calf-ladspa' 'ladspa-plugins')
makedepends=(
'cmake'
'boost'
@@ -34,35 +35,20 @@ makedepends=(
)
options=(!strip)
source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
- "faust-accept-current-clang.patch"
"dont-empty-qt-library-paths.patch"
- "fix-misleading-indentation.patch"
- "fix-X11_keyboard-compilation.patch"
"use-system-libxcb.patch"
"use-system-vstsdk.patch")
-md5sums=('e2bddd56d0e9dc3a9cdf89249a3915ef'
- 'df250d13d5826b35c9139e6d436ebac9'
- '77c202bc0a36562eb7b805ad6b7a85b3'
- '1ca36c75ce4b3fed28c22753b8dc045a'
- '24e927620d8aeb09c83b903a92dacf9f'
- '60e99f9362d08726877d14ea2cdfd5c6'
- '5c78211475528b588cabced5f024eb54')
+md5sums=('4a2e4050ce8350d1d0287524b4916cd2'
+ 'd63cea387564fa21dee775e764206a45'
+ 'd798d5655e2899dc1b54f797d9b2bda3'
+ 'd068d4bc99360cd4ec933c57ab9f5159')
prepare() {
cd "${pkgname}-${pkgver}"
- msg2 "Fixing faust2 compilation on llvm 3.9.1"
- patch -Nsp1 < "${srcdir}/faust-accept-current-clang.patch"
-
msg2 "Fixing QT_QPA_PLATFORM_PLUGIN_PATH problem"
patch -Nsp1 < "${srcdir}/dont-empty-qt-library-paths.patch"
- msg2 "Fixing misleading indentation"
- patch -Nsp1 < "${srcdir}/fix-misleading-indentation.patch"
-
- msg2 "Fixing X11_keyboard compilation"
- patch -Nsp1 < "${srcdir}/fix-X11_keyboard-compilation.patch"
-
msg2 "Switching to systemd-wide libxcb"
patch -Nsp1 < "${srcdir}/use-system-libxcb.patch"
@@ -97,12 +83,31 @@ package() {
msg2 "Installing s7 sources"
install -dm755 "${pkgdir}/opt/radium/packages"
tar -xf "bin/packages/s7.tar.gz" -C "${pkgdir}/opt/radium/packages" \
- --no-same-owner --no-same-permissions --wildcards '*.scm'
+ --no-same-owner --no-same-permissions --wildcards '*.scm'
# Radium will complain if these are missing
msg2 "Installing Faust GUI styles"
install -Dm644 -t "${pkgdir}/opt/radium/packages/faust2/architecture/faust/gui/Styles" \
- "bin/packages/faust2/architecture/faust/gui/Styles/"*".qss"
+ "bin/packages/faust2/architecture/faust/gui/Styles/"*".qss"
+
+ msg2 "Installing .desktop, icon and mimetype files"
+ install -dm755 "${pkgdir}/usr/share/applications"
+ ln -s "/opt/radium/radium.desktop" \
+ "${pkgdir}/usr/share/applications/radium.desktop"
+
+ install -dm755 "${pkgdir}/usr/share/icons/hicolor/"{256x256,128x128,32x32,16x16}"/apps"
+ ln -s "/opt/radium/radium_256x256x32.png" \
+ "${pkgdir}/usr/share/icons/hicolor/256x256/apps/radium.png"
+ ln -s "/opt/radium/radium_128x128x32.png" \
+ "${pkgdir}/usr/share/icons/hicolor/128x128/apps/radium.png"
+ ln -s "/opt/radium/radium_32x32x24.png" \
+ "${pkgdir}/usr/share/icons/hicolor/32x32/apps/radium.png"
+ ln -s "/opt/radium/radium_16x16x8.png" \
+ "${pkgdir}/usr/share/icons/hicolor/16x16/apps/radium.png"
+
+ install -dm755 "${pkgdir}/usr/share/mime/packages"
+ ln -s "/opt/radium/radium-mimetype.xml" \
+ "${pkgdir}/usr/share/mime/packages/radium.xml"
}
# vim:set ts=4 sw=4 et:
diff --git a/dont-empty-qt-library-paths.patch b/dont-empty-qt-library-paths.patch
index 5a8e4ca9fb83..f776e64fb500 100644
--- a/dont-empty-qt-library-paths.patch
+++ b/dont-empty-qt-library-paths.patch
@@ -1,19 +1,22 @@
diff -aur --no-dereference package.pristine/Qt/Qt_Error.cpp package.new/Qt/Qt_Error.cpp
---- package.pristine/Qt/Qt_Error.cpp 2016-10-29 19:20:29.405129735 +0200
-+++ package.new/Qt/Qt_Error.cpp 2016-10-29 19:21:28.281368400 +0200
-@@ -63,7 +63,7 @@
- QSplashScreen *g_splashscreen = NULL; // referenced by helpers.h
-
- int main(int argc, char **argv){
+--- package.pristine/Qt/Qt_Error.cpp 2017-04-08 14:45:26.000000000 +0200
++++ package.new/Qt/Qt_Error.cpp 2017-04-11 19:26:40.613065282 +0200
+@@ -77,9 +77,9 @@
+ if(getenv("QT_QPA_PLATFORM_PLUGIN_PATH")==NULL){
+ faulty_installation = true;
+ }else
+- QCoreApplication::setLibraryPaths(QStringList());
++ //QCoreApplication::setLibraryPaths(QStringList());
+ #else
- QCoreApplication::setLibraryPaths(QStringList());
+ //QCoreApplication::setLibraryPaths(QStringList());
-
+ #endif
+
QApplication app(argc,argv);
- int ret = show_message(argv[1]);
diff -aur --no-dereference package.pristine/Qt/Qt_Main.cpp package.new/Qt/Qt_Main.cpp
---- package.pristine/Qt/Qt_Main.cpp 2016-10-29 19:20:29.405129735 +0200
-+++ package.new/Qt/Qt_Main.cpp 2016-10-29 19:21:07.024856269 +0200
-@@ -2274,7 +2274,7 @@
+--- package.pristine/Qt/Qt_Main.cpp 2017-04-08 14:45:26.000000000 +0200
++++ package.new/Qt/Qt_Main.cpp 2017-04-11 19:25:31.886938780 +0200
+@@ -2623,7 +2623,7 @@
qInstallMsgHandler(myMessageOutput);
#endif
@@ -23,14 +26,17 @@ diff -aur --no-dereference package.pristine/Qt/Qt_Main.cpp package.new/Qt/Qt_Mai
QCoreApplication::setAttribute(Qt::AA_X11InitThreads);
diff -aur --no-dereference package.pristine/crashreporter/crashreporter.cpp package.new/crashreporter/crashreporter.cpp
---- package.pristine/crashreporter/crashreporter.cpp 2016-10-29 19:20:29.541795408 +0200
-+++ package.new/crashreporter/crashreporter.cpp 2016-10-29 19:20:46.425006019 +0200
-@@ -395,7 +395,7 @@
-
- int main(int argc, char **argv){
-
+--- package.pristine/crashreporter/crashreporter.cpp 2017-04-08 14:45:26.000000000 +0200
++++ package.new/crashreporter/crashreporter.cpp 2017-04-11 19:27:08.169515448 +0200
+@@ -407,9 +407,9 @@
+ if(getenv("QT_QPA_PLATFORM_PLUGIN_PATH")==NULL){
+ faulty_installation = true;
+ }else
+- QCoreApplication::setLibraryPaths(QStringList());
++ //QCoreApplication::setLibraryPaths(QStringList());
+ #else
- QCoreApplication::setLibraryPaths(QStringList());
+ //QCoreApplication::setLibraryPaths(QStringList());
+ #endif
QApplication app(argc,argv);
-
diff --git a/faust-accept-current-clang.patch b/faust-accept-current-clang.patch
deleted file mode 100644
index d21a1c9e06aa..000000000000
--- a/faust-accept-current-clang.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aur --no-dereference package.pristine/bin/packages/faust2/compiler/Makefile.unix package.new/bin/packages/faust2/compiler/Makefile.unix
---- package.pristine/bin/packages/faust2/compiler/Makefile.unix 2016-10-29 17:56:44.082520406 +0200
-+++ package.new/bin/packages/faust2/compiler/Makefile.unix 2016-10-29 17:56:54.242445169 +0200
-@@ -102,7 +102,7 @@
- CLANGLIBS=$(CLANGLIBSLIST)
- CXXFLAGS += -std=gnu++11
-
--else ifeq ($(LLVM_VERSION),$(filter $(LLVM_VERSION), 3.8.0 3.8.1))
-+else ifeq ($(LLVM_VERSION),$(filter $(LLVM_VERSION), 3.8.0 3.8.1 3.9.1))
- LLVM_VERSION = LLVM_38
- CLANGLIBS=$(CLANGLIBSLIST)
- CXXFLAGS += -std=gnu++11
diff --git a/fix-X11_keyboard-compilation.patch b/fix-X11_keyboard-compilation.patch
deleted file mode 100644
index 219dc6b94695..000000000000
--- a/fix-X11_keyboard-compilation.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Only in package.new: .Makefile.Qt.swp
-diff -aur --no-dereference package.pristine/Makefile.Qt package.new/Makefile.Qt
---- package.pristine/Makefile.Qt 2017-02-02 01:15:50.335803833 +0100
-+++ package.new/Makefile.Qt 2017-02-02 02:18:48.679033631 +0100
-@@ -1087,7 +1087,7 @@
- $(CC) X11/X11_instrument.c $(OPT)
-
- X11_keyboard.o: $(BUILD_DEPENDENCIES) X11/X11_keyboard.cpp
-- $(CCC) X11/X11_keyboard.cpp $(QTOPT) -DUSE_QT$(RADIUM_QT_VERSION)
-+ $(CCC) X11/X11_keyboard.cpp $(CPPOPT) $(QT_CFLAGS) -DUSE_QT$(RADIUM_QT_VERSION)
-
- #X11_MidiProperties.o: $(BUILD_DEPENDENCIES) X11/X11_MidiProperties.c
- # $(CC) X11/X11_MidiProperties.c $(OPT)
-Only in package.new: Makefile.Qt~
diff --git a/fix-misleading-indentation.patch b/fix-misleading-indentation.patch
deleted file mode 100644
index 32ba07e5606e..000000000000
--- a/fix-misleading-indentation.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aur --no-dereference package.pristine/pluginhost/JuceLibraryCode/modules/juce_core/maths/juce_NormalisableRange.h package.new/pluginhost/JuceLibraryCode/modules/juce_core/maths/juce_NormalisableRange.h
---- package.pristine/pluginhost/JuceLibraryCode/modules/juce_core/maths/juce_NormalisableRange.h 2016-11-22 17:36:12.490115783 +0100
-+++ package.new/pluginhost/JuceLibraryCode/modules/juce_core/maths/juce_NormalisableRange.h 2016-11-22 17:38:02.635866089 +0100
-@@ -130,7 +130,7 @@
- if (skew != static_cast<ValueType> (1) && proportion > ValueType())
- proportion = std::exp (std::log (proportion) / skew);
-
-- return start + (end - start) * proportion;
-+ return start + (end - start) * proportion;
- }
-
- ValueType distanceFromMiddle = static_cast<ValueType> (2) * proportion - static_cast<ValueType> (1);
diff --git a/use-system-libxcb.patch b/use-system-libxcb.patch
index 5c5e3872aa88..422f823a0e13 100644
--- a/use-system-libxcb.patch
+++ b/use-system-libxcb.patch
@@ -1,30 +1,7 @@
-diff -aur --no-dereference package.pristine/Qt/Qt_Main.cpp package.new/Qt/Qt_Main.cpp
---- package.pristine/Qt/Qt_Main.cpp 2017-01-26 17:00:32.000000000 +0100
-+++ package.new/Qt/Qt_Main.cpp 2017-02-02 02:36:04.552338576 +0100
-@@ -2426,18 +2426,6 @@
- //abort();
-
- #endif // !defined(RELEASE)
--
--#if defined(FOR_LINUX)
-- {
-- QString name(dlpi_name);
-- if (name.contains("libxcb.so")){
-- if (!name.contains("bin/packages/libxcb-1.12/src/.libs/")){
-- fprintf(stderr,"\n\n%c[31mError. A version of libxcb not included with Radium has been dynamically linked into the program. Something is wrong the installation of Radium.\nOlder versions of libxcb (probably before 1.11.1) are unstable with Radium.%c[0m\n\n", 0x1b, 0x1b);
-- abort();
-- }
-- }
-- }
--#endif
-
-
-
-Only in package.new/Qt: Qt_Main.cpp~
diff -aur --no-dereference package.pristine/bin/packages/build.sh package.new/bin/packages/build.sh
---- package.pristine/bin/packages/build.sh 2017-01-26 17:00:32.000000000 +0100
-+++ package.new/bin/packages/build.sh 2017-02-02 02:36:22.135671428 +0100
-@@ -189,27 +189,5 @@
+--- package.pristine/bin/packages/build.sh 2017-03-26 19:27:43.000000000 +0000
++++ package.new/bin/packages/build.sh 2017-03-30 05:14:35.867793829 +0000
+@@ -189,27 +189,27 @@
cd ../
fi
@@ -49,7 +26,47 @@ diff -aur --no-dereference package.pristine/bin/packages/build.sh package.new/bi
- cd ..
-
-fi
--
++#if [[ $RADIUM_QT_VERSION == 5 ]]
++#then
++#
++# rm -fr xcb-proto-1.12/
++# tar xvjf xcb-proto-1.12.tar.bz2
++# cd xcb-proto-1.12/
++# mkdir install
++# ./configure --prefix=`pwd`/install
++# make
++# make install
++# cd ..
++#
++# rm -fr libxcb-1.12
++# tar xvjf libxcb-1.12.tar.bz2
++# cd libxcb-1.12
++# export PKG_CONFIG_PATH=`pwd`/../xcb-proto-1.12/install/lib/pkgconfig:$PKG_CONFIG_PATH
++# ./configure
++# make
++# cd ..
++#
++#fi
+
touch deletemetorebuild
-Only in package.new/bin/packages: build.sh~
+diff -aur --no-dereference package.pristine/Qt/Qt_Main.cpp package.new/Qt/Qt_Main.cpp
+--- package.pristine/Qt/Qt_Main.cpp 2017-03-26 19:27:43.000000000 +0000
++++ package.new/Qt/Qt_Main.cpp 2017-03-30 05:12:36.587795134 +0000
+@@ -2523,6 +2523,7 @@
+
+ #endif // !defined(RELEASE)
+
++/*
+ #if defined(FOR_LINUX)
+ {
+ QString name(dlpi_name);
+@@ -2534,7 +2535,7 @@
+ }
+ }
+ #endif
+-
++*/
+
+
+ if (is_main_root)
diff --git a/use-system-vstsdk.patch b/use-system-vstsdk.patch
index 5345569c1362..35bbb094c339 100644
--- a/use-system-vstsdk.patch
+++ b/use-system-vstsdk.patch
@@ -1,38 +1,47 @@
diff -aur --no-dereference package.pristine/Makefile.Qt package.new/Makefile.Qt
---- package.pristine/Makefile.Qt 2016-10-30 16:03:25.260604684 +0100
-+++ package.new/Makefile.Qt 2016-10-30 16:05:44.299544309 +0100
-@@ -192,7 +192,7 @@
+--- package.pristine/Makefile.Qt 2017-04-08 14:45:26.000000000 +0200
++++ package.new/Makefile.Qt 2017-04-11 19:54:05.803545494 +0200
+@@ -210,7 +210,7 @@
FLAGOPTS = $(DEFINES) -DGUIISQT -DUSE_GFX_OP_QUEUE -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
-COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_63_0 -I ~/SDKs/VST3\ SDK -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer -Wno-unknown-pragmas
-+COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_63_0 -I/usr/include/vst36 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer -Wno-unknown-pragmas
++COMMONOPT = -c $(RADIUM_BFD_CFLAGS) `cat buildtype.opt` -I$(GCDIR)/include -I$(P) -I$(PYPATH) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I${HOME}/boost_1_63_0 -I /usr/include/vst36 -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -fno-omit-frame-pointer -Wno-unknown-pragmas
ifeq ($(RADIUM_QT_VERSION),5)
COMMONOPT += -DUSE_QT5
diff -aur --no-dereference package.pristine/check_dependencies.sh package.new/check_dependencies.sh
---- package.pristine/check_dependencies.sh 2016-10-30 16:03:25.373937152 +0100
-+++ package.new/check_dependencies.sh 2016-10-30 16:06:12.332664001 +0100
-@@ -127,8 +127,8 @@
+--- package.pristine/check_dependencies.sh 2017-04-08 14:45:26.000000000 +0200
++++ package.new/check_dependencies.sh 2017-04-11 19:53:20.887228014 +0200
+@@ -137,8 +137,8 @@
exit 5
fi
-if [[ ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/"VST3 SDK"/pluginterfaces/vst2.x/aeffect.h ]] ; then
- echo 'Steinberg VST headers not found. (Missing "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h or "~/SDKs/VST3 SDK/pluginterfaces/vst2.x/aeffect.h")'
-+if [ ! -f /usr/include/vst36/pluginterfaces/vst2.x/aeffect.h ] ; then
-+ echo 'Steinberg VST headers not found. (Missing "/usr/include/vst36/pluginterfaces/vst2.x/aeffect.h")'
++if [[ ! -f /usr/include/vst36/pluginterfaces/vst2.x/aeffect.h && ! -f /usr/include/vst36/pluginterfaces/vst2.x/aeffect.h ]] ; then
++ echo 'Steinberg VST headers not found. (Missing "/usr/include/vst36/pluginterfaces/vst2.x/aeffect.h or "/usr/include/vst36/pluginterfaces/vst2.x/aeffect.h")'
echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html'
exit 5
fi
diff -aur --no-dereference package.pristine/pluginhost/Builds/Linux/Makefile package.new/pluginhost/Builds/Linux/Makefile
---- package.pristine/pluginhost/Builds/Linux/Makefile 2016-10-30 16:03:25.383937076 +0100
-+++ package.new/pluginhost/Builds/Linux/Makefile 2016-10-30 16:05:19.869730485 +0100
+--- package.pristine/pluginhost/Builds/Linux/Makefile 2017-04-08 14:45:26.000000000 +0200
++++ package.new/pluginhost/Builds/Linux/Makefile 2017-04-11 19:52:24.024336863 +0200
+@@ -18,7 +18,7 @@
+ TARGET_ARCH := -march=native
+ endif
+
+- CPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "DEBUG=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I ~/SDKs/vstsdk2.4 -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\""
++ CPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "DEBUG=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I /usr/include/vst36 -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\""
+ CFLAGS += $(CPPFLAGS) $(TARGET_ARCH) -g -ggdb -O0 -I../../../Qt `cat ../../../flagopts.opt`
+ CXXFLAGS += $(CFLAGS) -std=c++11
+ LDFLAGS += $(TARGET_ARCH) -L$(BINDIR) -L$(LIBDIR) -L/usr/X11R6/lib/ -lX11 -lXext -lXinerama -lasound -ldl -lfreetype -lpthread -lrt
@@ -38,7 +38,7 @@
TARGET_ARCH := -march=native
endif
- CPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "DEBUG=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I ~/SDKs/vstsdk2.4 -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\""
-+ CPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "DEBUG=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I ~/SDKs/VST3\ SDK -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -I /usr/include/vst36 -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\""
++ CPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "DEBUG=1" -D "_DEBUG=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" -I /usr/include -I /usr/include/freetype2 -I /usr/include/vst36 -I ../../JuceLibraryCode -I ../../JuceLibraryCode/modules -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\""
CFLAGS += $(CPPFLAGS) $(TARGET_ARCH) -g -ggdb -O3 -I../../../Qt `cat ../../../flagopts.opt`
CXXFLAGS += $(CFLAGS) -std=c++11
LDFLAGS += $(TARGET_ARCH) -L$(BINDIR) -L$(LIBDIR) -L/usr/X11R6/lib/ -lX11 -lXext -lXinerama -lasound -ldl -lfreetype -lpthread -lrt