summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
-rw-r--r--fix-qt5.11-comp.patch15
3 files changed, 29 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8686925d8cc..83d9205d5911 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 5.9.0
+ pkgver = 5.9.4
pkgrel = 1
url = https://users.notam02.no/~kjetism/radium
arch = i686
@@ -30,16 +30,18 @@ pkgbase = radium
optdepends = calf-ladspa: Default chorus plugin
optdepends = ladspa-plugins: Package group for default radium plugins incl in binary releases
options = !strip
- source = https://github.com/kmatheussen/radium/archive/5.9.0.tar.gz
+ source = https://github.com/kmatheussen/radium/archive/5.9.4.tar.gz
source = use-libtirpc-headers.patch
source = use-system-libxcb.patch
source = use-system-vstsdk.patch
source = use-static-llvm40.patch
- sha256sums = 44f67ea67a05f66090920ed4e68fe30b5ed7ab9dd3249b556ed07611a58e65ba
+ source = fix-qt5.11-comp.patch
+ sha256sums = e1534c60bfd6d830410e356363d03f688c47dce5d30890017e3751b17c704b7d
sha256sums = f2596261f9ebd859f9850cbfc97edb7fd5d45cf8768ce47d0721cbf4b2d80c7e
sha256sums = 94de9befbe6530c721917445ee3a0c0202371e1b2229784b2ea6e0c0efaf7808
sha256sums = 75c606ed2c0f1f42449b2b2a7f6936c37be7a78e658ef4306f21edcd16eb2304
sha256sums = 413523f60ae7dea7aa2e223fc035f57b05693eea17ba3889eafaca9173fe5f3d
+ sha256sums = 31cff1d5fb813462803a85c0d418291fc4f2fb4f4b727853cb60ad6c8a37429c
pkgname = radium
diff --git a/PKGBUILD b/PKGBUILD
index d6d09c560bc6..db12e9af14cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: Teteros <teteros at teknik dot io>
pkgname=radium
-pkgver=5.9.0
+pkgver=5.9.4
pkgrel=1
pkgdesc="A graphical music editor. A next generation tracker."
arch=('i686' 'x86_64')
@@ -43,12 +43,14 @@ source=("https://github.com/kmatheussen/${pkgname}/archive/${pkgver}.tar.gz"
"use-libtirpc-headers.patch"
"use-system-libxcb.patch"
"use-system-vstsdk.patch"
- "use-static-llvm40.patch")
-sha256sums=('44f67ea67a05f66090920ed4e68fe30b5ed7ab9dd3249b556ed07611a58e65ba'
+ "use-static-llvm40.patch"
+ "fix-qt5.11-comp.patch")
+sha256sums=('e1534c60bfd6d830410e356363d03f688c47dce5d30890017e3751b17c704b7d'
'f2596261f9ebd859f9850cbfc97edb7fd5d45cf8768ce47d0721cbf4b2d80c7e'
'94de9befbe6530c721917445ee3a0c0202371e1b2229784b2ea6e0c0efaf7808'
'75c606ed2c0f1f42449b2b2a7f6936c37be7a78e658ef4306f21edcd16eb2304'
- '413523f60ae7dea7aa2e223fc035f57b05693eea17ba3889eafaca9173fe5f3d')
+ '413523f60ae7dea7aa2e223fc035f57b05693eea17ba3889eafaca9173fe5f3d'
+ '31cff1d5fb813462803a85c0d418291fc4f2fb4f4b727853cb60ad6c8a37429c')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -67,6 +69,9 @@ prepare() {
# https://github.com/kmatheussen/radium/issues/1068
# https://users.notam02.no/~kjetism/radium/forum/viewtopic.php?f=7&t=39
patch -p1 < "${srcdir}/use-static-llvm40.patch"
+
+ # https://github.com/kmatheussen/radium/issues/1157
+ patch -p1 < "${srcdir}/fix-qt5.11-comp.patch"
}
build() {
diff --git a/fix-qt5.11-comp.patch b/fix-qt5.11-comp.patch
new file mode 100644
index 000000000000..2a5d0a88ec77
--- /dev/null
+++ b/fix-qt5.11-comp.patch
@@ -0,0 +1,15 @@
+diff --git a/api/api_gui_proc.h b/api/api_gui_proc.h
+index e7d0d85..7d1600e 100644
+--- a/api/api_gui_proc.h
++++ b/api/api_gui_proc.h
+@@ -35,9 +35,9 @@ int64_t API_get_gui_from_existing_widget(QWidget *widget);
+
+ #if defined(QREGION_H)
+ void API_run_paint_event_for_custom_widget(QWidget *widget, QPaintEvent *ev, const QRegion &already_painted_areas);
++bool API_run_custom_gui_paint_function(QWidget *widget, QPainter *p, const QRegion *region, std::function<void(void)> func);
+ #endif
+
+-bool API_run_custom_gui_paint_function(QWidget *widget, QPainter *p, const QRegion *region, std::function<void(void)> func);
+
+ bool API_run_mouse_press_event_for_custom_widget(QWidget *widget, QMouseEvent *ev);
+ bool API_run_mouse_move_event_for_custom_widget(QWidget *widget, QMouseEvent *ev);