summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO58
-rw-r--r--PKGBUILD148
-rw-r--r--radium.install4
3 files changed, 109 insertions, 101 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47fc325ceb6d..a773847243e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,77 +1,73 @@
pkgbase = radium-git
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 7.1.92.r7.ge115ad6
+ pkgver = 7.4.76.r7.g0c86614
pkgrel = 1
- url = https://users.notam02.no/~kjetism/radium/
+ url = https://users.notam02.no/~kjetism/radium
install = radium.install
arch = x86_64
- groups = ladspa-host
groups = pro-audio
- groups = vst-host
- groups = vst3-host
license = GPL2
+ makedepends = git
makedepends = boost
makedepends = cmake
makedepends = libxcursor
makedepends = libxinerama
- makedepends = libxkbfile
makedepends = libxrandr
- makedepends = llvm
makedepends = qt5-tools
makedepends = vst2sdk
- depends = alsa-lib
- depends = binutils
+ makedepends = gcc13
depends = desktop-file-utils
depends = fftw
- depends = glib2
depends = glu
- depends = gmp
depends = gsfonts
- depends = guile
depends = hicolor-icon-theme
depends = jack
- depends = ladspa
- depends = libatomic_ops
depends = liblo
depends = liblrdf
- depends = libmicrohttpd
depends = libmpc
- depends = libmpc
- depends = libogg
- depends = libsamplerate
depends = libsndfile
- depends = libvorbis
- depends = libxkbfile
- depends = mpfr
- depends = ncurses
- depends = openssl
- depends = openssl
depends = python2
- depends = qt5-base
depends = qt5-svg
depends = qt5-webkit
depends = qt5-x11extras
depends = speex
- depends = swh-plugins
- depends = tk
depends = ttf-bitstream-vera
depends = ttf-croscore
depends = ttf-lato
+ depends = libatomic_ops
+ depends = libsamplerate
+ depends = tk
+ depends = guile
+ depends = libxkbfile
+ depends = openssl
+ depends = ncurses
+ depends = gmp
depends = xcb-util-keysyms
+ depends = mpfr
+ depends = libmpc
+ depends = libogg
+ depends = libvorbis
+ depends = openssl
+ depends = alsa-lib
+ depends = glib2
+ depends = binutils
depends = xorg-util-macros
+ depends = qt5-base
+ depends = libmicrohttpd
+ depends = ladspa
optdepends = new-session-manager: for session management
optdepends = calf-ladspa: default chorus plugin used in new file templates
+ optdepends = lmms-git: provides veal.so (instead of calf-ladspa)
optdepends = ladspa-plugins: package group for plugins normally included in binary releases
optdepends = vst-plugins: more plugins
- provides = radium-git
- provides = ladspa-host
- provides = vst-host
- provides = vst3-host
+ provides = radium
conflicts = radium
options = !strip
source = git+https://github.com/kmatheussen/radium
+ source = radium.install
source = build_linux_common.patch
sha256sums = SKIP
+ sha256sums = f627730ff7a819e8cc5ac5c2b5f1fb2f2237327db6ea5442c55a23c1ce82ef14
sha256sums = 0decfc3adcba836004ac34d970a83d4d0b69743334a586f42be53b3de7bdd5a4
pkgname = radium-git
diff --git a/PKGBUILD b/PKGBUILD
index a49a9f6527d6..880174aa1a85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,4 @@
-# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
-# Contributor: nyx eles
+# Maintainer: nyxkn <dev@nyxkn.net>
# Contributor: yustin <#archlinux-proaudio@libera.chat>
# Contributor: Teteros <teteros at teknik dot io>
# Contributor: Karol "Kenji Takahashi" Woźniak <kenji.sx>
@@ -7,137 +6,150 @@
_pkgname=radium
pkgname=$_pkgname-git
-pkgver=7.1.92.r7.ge115ad6
+pkgver=7.4.76.r7.g0c86614
pkgrel=1
pkgdesc='A graphical music editor. A next generation tracker.'
arch=(x86_64)
-url='https://users.notam02.no/~kjetism/radium/'
+url=https://users.notam02.no/~kjetism/radium
license=(GPL2)
-groups=(ladspa-host pro-audio vst-host vst3-host)
-provides=($pkgname ladspa-host vst-host vst3-host)
-conflicts=($_pkgname)
+groups=(pro-audio)
+provides=(radium)
+conflicts=(radium)
depends=(
- alsa-lib
- binutils
desktop-file-utils
fftw
- glib2
glu
- gmp
gsfonts
- guile
hicolor-icon-theme
jack
- ladspa
- libatomic_ops
liblo
liblrdf
- libmicrohttpd
- libmpc
libmpc
- libogg
- libsamplerate
libsndfile
- libvorbis
- libxkbfile
- mpfr
- ncurses
- openssl
- openssl
python2
- qt5-base
qt5-svg
qt5-webkit
qt5-x11extras
speex
- swh-plugins
- tk
ttf-bitstream-vera
ttf-croscore
ttf-lato
+ libatomic_ops
+ libsamplerate
+ tk
+ guile
+ libxkbfile
+ openssl
+ ncurses
+ gmp
xcb-util-keysyms
+ mpfr
+ libmpc
+ libogg
+ libvorbis
+ openssl
+ alsa-lib
+ glib2
+ binutils
xorg-util-macros
-)
+ qt5-base
+ libmicrohttpd
+ ladspa
+ )
makedepends=(
+ git
boost
cmake
libxcursor
libxinerama
- libxkbfile
libxrandr
- llvm
qt5-tools
vst2sdk
+ gcc13
)
optdepends=(
'new-session-manager: for session management'
'calf-ladspa: default chorus plugin used in new file templates'
+ 'lmms-git: provides veal.so (instead of calf-ladspa)'
'ladspa-plugins: package group for plugins normally included in binary releases'
'vst-plugins: more plugins'
)
-options=(!strip)
-source=(
- "git+https://github.com/kmatheussen/radium"
- build_linux_common.patch
+options=( !strip )
+source=("git+https://github.com/kmatheussen/radium"
+ radium.install
+ build_linux_common.patch
)
sha256sums=('SKIP'
+ 'f627730ff7a819e8cc5ac5c2b5f1fb2f2237327db6ea5442c55a23c1ce82ef14'
'0decfc3adcba836004ac34d970a83d4d0b69743334a586f42be53b3de7bdd5a4')
install=radium.install
-pkgver() {
- cd radium
+prepare() {
+ cd "$_pkgname"
- git describe --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
+ export PATH=$(pwd):$PATH
-prepare() {
- cd radium
+ # use gcc13 ...
+ ln -sf /usr/bin/cc-13 cc
+ ln -sf /usr/bin/gcc-13 gcc
+ ln -sf /usr/bin/c++-13 c++
+ ln -sf /usr/bin/g++-13 g++
- git revert --no-commit f8c725e46791ce76fe71556b8dc1fac2d3bd35ff
+ export CC=gcc-13 CXX=g++-13
# fix for binutils 2.40
- patch -p0 -N -r - -i "$srcdir"/build_linux_common.patch
+ patch -p0 < "$srcdir/build_linux_common.patch"
+
+ # This tweak edits new file template and demo songs to be compatible with chorus plugin from calf-ladspa package or with veal.so from lmms>=1.3
+ # New Demosong also needs fixes for LADSPA-Plugins
+ for file in bin/sounds/*.rad; do sed -i -e 's/Calf MultiChorus LADSPA/Calf Multi Chorus LADSPA/g' "$file"; done
+ for file in bin/sounds/*.RAD; do sed -i -e 's/Calf MultiChorus LADSPA/Calf Multi Chorus LADSPA/g' "$file"; done
+ sed -ie "s/C\* Eq - 10-band equalizer/C\* Eq10 - 10-band equaliser/g" bin/sounds/ROMANCE2.RAD
+
+ sed -i "/cd libpd-master/s|$|\nsed -i '/LINUXCFLAGS/s/=/= --Wno-error=implicit-function-declaration/' pure-data/extra/makefile |" bin/packages/build.sh
+ sed -i "/cd libpd-master/s|$|\nsed -i '/define CFLAGS/s/-Wall/-Wall -Wno-error=implicit-function-declaration/' make.scm |" bin/packages/build.sh
+}
- # This tweak edits the new file template and demo songs to be compatible with
- # the multi chorus plugin from the 'calf-ladspa' package
- for file in \
- bin/{,sounds}/*.[Rr][Aa][Dd] \
- audio/SoundPluginRegistry.cpp \
- bin/scheme/instruments.scm \
- ladspa_info/calf.7.cached_type_info; do
- sed -i -e 's/Calf MultiChorus LADSPA/Calf Multi Chorus LADSPA/g' "$file";
- done
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd radium
+ cd "$_pkgname"
+
+ export PATH=$(pwd):$PATH
+ export INCLUDE_FAUSTDEV_BUT_NOT_LLVM=1
- RADIUM_QT_VERSION=5 RADIUM_VST2SDK_PATH=/usr/include/vst36 RADIUM_BUILD_LIBXCB=0 make packages
- RADIUM_QT_VERSION=5 RADIUM_VST2SDK_PATH=/usr/include/vst36 BUILDTYPE=RELEASE ./build_linux.sh
+ RADIUM_QT_VERSION=5 RADIUM_VST2SDK_PATH=/usr/src/vst2sdk RADIUM_BUILD_LIBXCB=0 make packages
+ RADIUM_QT_VERSION=5 RADIUM_VST2SDK_PATH=/usr/src/vst2sdk BUILDTYPE=RELEASE ./build_linux.sh
}
package() {
- cd radium
+ cd "$_pkgname"
# Install radium and its packages to /opt
- RADIUM_INSTALL_LIBXCB=0 ./install.sh "$pkgdir"/opt
+ RADIUM_INSTALL_LIBXCB=0 ./install.sh "$pkgdir/opt"
+ # radium.install will link ladspa-path here so remove it
+ rm -rf $pkgdir/opt/radium/ladspa
# Create startup script according to bin/packages/README
- echo '#!/usr/bin/env bash' > radium.sh
+ mkdir -p "$pkgdir/usr/bin"
+ echo '#!/usr/bin/env bash' > "$pkgdir/usr/bin/radium"
echo QT_QPA_PLATFORM_PLUGIN_PATH="$($(RADIUM_QT_VERSION=5 ./find_moc_and_uic_paths.sh qmake) -query QT_INSTALL_PLUGINS)" \
- /opt/radium/radium '"$@"' >> radium.sh
- install -vDm 755 radium.sh "$pkgdir"/usr/bin/radium
+ /opt/radium/radium '"$@"' >> "$pkgdir/usr/bin/radium"
+ chmod +x "$pkgdir/usr/bin/radium"
# Icons, .desktop and mimetype files
- mkdir -p "$pkgdir"/usr/share/icons/hicolor/{16x16,32x32,128x128,256x256}/apps \
- "$pkgdir"/usr/share/applications \
- "$pkgdir"/usr/share/mime/packages
- ln -s /opt/radium/radium_16x16x8.png "$pkgdir"/usr/share/icons/hicolor/16x16/apps/radium.png
- ln -s /opt/radium/radium_32x32x24.png "$pkgdir"/usr/share/icons/hicolor/32x32/apps/radium.png
- ln -s /opt/radium/radium_128x128x32.png "$pkgdir"/usr/share/icons/hicolor/128x128/apps/radium.png
- ln -s /opt/radium/radium_256x256x32.png "$pkgdir"/usr/share/icons/hicolor/256x256/apps/radium.png
- ln -s /opt/radium/radium.desktop "$pkgdir"/usr/share/applications/radium.desktop
- ln -s /opt/radium/radium-mimetype.xml "$pkgdir"/usr/share/mime/packages/radium.xml
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/"{16x16,32x32,128x128,256x256}"/apps" \
+ "$pkgdir/usr/share/applications" \
+ "$pkgdir/usr/share/mime/packages"
+ ln -s "/opt/radium/radium_16x16x8.png" "$pkgdir/usr/share/icons/hicolor/16x16/apps/radium.png"
+ ln -s "/opt/radium/radium_32x32x24.png" "$pkgdir/usr/share/icons/hicolor/32x32/apps/radium.png"
+ ln -s "/opt/radium/radium_128x128x32.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/radium.png"
+ ln -s "/opt/radium/radium_256x256x32.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/radium.png"
+ ln -s "/opt/radium/radium.desktop" "$pkgdir/usr/share/applications/radium.desktop"
+ ln -s "/opt/radium/radium-mimetype.xml" "$pkgdir/usr/share/mime/packages/radium.xml"
}
warn_build_references() {
diff --git a/radium.install b/radium.install
index f39d031dd2e9..9cf4f6312ab6 100644
--- a/radium.install
+++ b/radium.install
@@ -2,10 +2,10 @@
### to get rid off the errormessage
post_install() {
- ln -sf /usr/lib/ladspa /opt/radium/ladspa
+ ln -sf /usr/lib/ladspa /opt/radium/ladspa
}
pre_remove() {
- rm /opt/radium/ladspa
+ rm /opt/radium/ladspa
}