summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8c300fa4aee..5067d9967858 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = raiseorlaunch
pkgdesc = Run-or-raise-application-launcher for i3 window manager.
pkgver = 0.1.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/open-dynaMIX/raiseorlaunch
arch = any
license = MIT
makedepends = python-setuptools
+ makedepends = python-pip
+ makedepends = python-wheel
depends = python
depends = python-i3-py
source = https://github.com/open-dynaMIX/raiseorlaunch/archive/v0.1.1.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index f008590f5d19..251e546b65cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,19 @@
pkgname=raiseorlaunch
pkgver=0.1.1
-pkgrel=3
+pkgrel=4
pkgdesc="Run-or-raise-application-launcher for i3 window manager."
arch=(any)
url="https://github.com/open-dynaMIX/raiseorlaunch"
license=('MIT')
depends=('python' 'python-i3-py')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-pip' 'python-wheel')
source=("https://github.com/open-dynaMIX/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('c2984485721479404f397d4496792a2f6b5894a291cac6768049232aedf9de26')
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ # Need to create the wheel first, otherwise the generated entry script will be too slow
+ python setup.py bdist_wheel
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps dist/${pkgname}-${pkgver}-py2.py3-none-any.whl
}