summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD18
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a9c0e081aa5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = raj-browser-bin
+ pkgdesc = A UI and privacy focussed browser for the web from the web.
+ pkgver = 2.0.5
+ pkgrel = 1
+ url = https://github.com/Rajaniraiyn/raj-browser
+ arch = x86_64
+ license = custom
+ depends = nspr
+ depends = libcups
+ depends = libxkbcommon
+ depends = libxrandr
+ depends = libxcb
+ depends = libxcomposite
+ depends = dbus
+ depends = gcc-libs
+ depends = libx11
+ depends = cairo
+ depends = at-spi2-core
+ depends = nss
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libxdamage
+ depends = pango
+ depends = alsa-lib
+ depends = glibc
+ depends = wayland
+ depends = libdrm
+ depends = libxfixes
+ depends = glib2
+ depends = libxext
+ depends = expat
+ depends = mesa
+ conflicts = raj-browser
+ source = raj-browser-2.0.5.deb::https://github.com/Rajaniraiyn/raj-browser/releases/download/v2.0.5/raj-browser_2.0.5_amd64.deb
+ sha256sums = b0ff6a0abff0fe3f8510aa5f12bae954eab07cb0441ee5971685d3335fa91b79
+
+pkgname = raj-browser-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f207d2f2846
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname="raj-browser-bin"
+pkgver=2.0.5
+pkgrel=1
+pkgdesc="A UI and privacy focussed browser for the web from the web."
+arch=('x86_64')
+license=('custom')
+conflicts=("${pkgname%-bin}")
+url="https://github.com/Rajaniraiyn/raj-browser"
+depends=('nspr' 'libcups' 'libxkbcommon' 'libxrandr' 'libxcb' 'libxcomposite' 'dbus' 'gcc-libs' 'libx11' 'cairo' 'at-spi2-core' 'nss' \
+ 'gtk3' 'hicolor-icon-theme' 'libxdamage' 'pango' 'alsa-lib' 'glibc' 'wayland' 'libdrm' 'libxfixes' 'glib2' 'libxext' 'expat' 'mesa')
+source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb")
+sha256sums=('b0ff6a0abff0fe3f8510aa5f12bae954eab07cb0441ee5971685d3335fa91b79')
+package(){
+ bsdtar -xf data.tar.xz -C "${pkgdir}"
+ sed "s|Utility|Network;Utility|g" -i "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/LICENSE"* -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file