summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD57
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4f8f176b67f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = raleway-font-git
+ pkgdesc = An elegant sans-serif font family, originally in a single thin weight, now 9 weights
+ pkgver = 4.100.r2.g9af4c69
+ pkgrel = 1
+ url = https://www.theleagueofmoveabletype.com/raleway
+ arch = any
+ groups = lmt-fonts
+ license = OFL
+ makedepends = fontship
+ makedepends = git
+ source = raleway-font-git::git+https://github.com/theleagueof/raleway.git
+ sha256sums = SKIP
+
+pkgname = otf-raleway-git
+ provides = otf-raleway
+ provides = raleway-font
+ conflicts = otf-raleway
+
+pkgname = ttf-raleway-git
+ provides = ttf-raleway
+ provides = raleway-font
+ conflicts = ttf-raleway
+
+pkgname = ttf-raleway-variable-git
+ provides = ttf-raleway-variable
+ provides = raleway-font-variable
+ conflicts = ttf-raleway-variable
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c16ad5f4eea3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Maintainer: LightDot <lightdot -a-t- g m a i l>
+
+_name=raleway
+_fname=Raleway
+pkgbase=$_name-font-git
+pkgname=(otf-$_name-git ttf-$_name-git ttf-$_name-variable-git)
+pkgver=4.100.r2.g9af4c69
+pkgrel=1
+pkgdesc='An elegant sans-serif font family, originally in a single thin weight, now 9 weights'
+arch=('any')
+url="https://www.theleagueofmoveabletype.com/$_name"
+license=('OFL')
+groups=('lmt-fonts')
+makedepends=('fontship' 'git')
+source=("$pkgbase::git+https://github.com/theleagueof/$_name.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgbase"
+ git describe --long --tags --abbrev=7 HEAD |
+ sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgbase"
+ fontship -q make
+}
+
+package_otf-raleway-git() {
+ provides=("${pkgname%-git}" "${pkgbase%-git}")
+ conflicts=("${pkgname%-git}")
+ cd "$pkgbase"
+ export GLOBIGNORE='*-VF.otf'
+ install -Dm644 -t "$pkgdir/usr/share/fonts/OTF/" $_fname-*.otf
+ # install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" ofl{,-faq}.markdown
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" README.md
+}
+
+package_ttf-raleway-git() {
+ provides=("${pkgname%-git}" "${pkgbase%-git}")
+ conflicts=("${pkgname%-git}")
+ cd "$pkgbase"
+ export GLOBIGNORE='*-VF.ttf'
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" $_fname-*.ttf
+ # install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" ofl{,-faq}.markdown
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" README.md
+}
+
+package_ttf-raleway-variable-git() {
+ provides=("${pkgname%-git}" "${pkgbase%-git}-variable")
+ conflicts=("${pkgname%-git}")
+ cd "$pkgbase"
+ install -Dm644 -t "$pkgdir/usr/share/fonts/TTF/" $_fname-VF.ttf
+ # install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" ofl{,-faq}.markdown
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname/" README.md
+}