summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--Makefile18
-rw-r--r--PKGBUILD27
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0ef8b95137d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jan 25 14:06:51 UTC 2016
+pkgbase = ramspeed
+ pkgdesc = Open source utility to measure cache and memory performance
+ pkgver = 2.6.0
+ pkgrel = 1
+ url = http://alasir.com/software/ramspeed/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = glibc
+ source = http://www.alasir.com/software/ramspeed/ramspeed-2.6.0.tar.gz
+ source = Makefile
+ md5sums = 546394131a1467a8651e0b8a218970c0
+ md5sums = 03ff681717c551b53a736e9e3c6ea786
+
+pkgname = ramspeed
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..d418b19fa696
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,18 @@
+SOURCES := ramspeed.c
+
+ifeq ($(CARCH),i686)
+SOURCES += $(wildcard i386/*.s) $(wildcard i386/cpuinfo/*.s)
+CPPFLAGS += -DI386_ASM
+else ifeq ($(CARCH),x86_64)
+SOURCES += $(wildcard amd64/*.s)
+CPPFLAGS += -DAMD64_ASM
+else
+SOURCES += fltmem.c intmem.c fltmark.c intmark.c
+endif
+
+ramspeed: $(SOURCES)
+ echo $(CARCH)
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $^ -o $@
+
+clean:
+ rm -f *.o ramspeed
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c92a6381143
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Anton Leontyev <scileont /at/ gmail.com>
+pkgname=ramspeed
+pkgver=2.6.0
+pkgrel=1
+pkgdesc='Open source utility to measure cache and memory performance'
+arch=('i686' 'x86_64')
+depends=('glibc')
+license=('custom')
+url='http://alasir.com/software/ramspeed/'
+source=(http://www.alasir.com/software/ramspeed/$pkgname-$pkgver.tar.gz Makefile)
+md5sums=('546394131a1467a8651e0b8a218970c0'
+ '03ff681717c551b53a736e9e3c6ea786')
+
+prepare() {
+ cp Makefile $pkgname-$pkgver/
+}
+
+build() {
+ cd $pkgname-$pkgver
+ export CARCH
+ make
+}
+
+package() {
+ install -Dm755 $pkgname-$pkgver/ramspeed "$pkgdir"/usr/bin/ramspeed
+ install -Dm644 $pkgname-$pkgver/LICENCE "$pkgdir"/usr/share/licenses/ramspeed/LICENSE
+}