summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--completion1
3 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03c53f0f99fc..05d54289b138 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = randrctl-git
pkgdesc = Lightweight profile based screen manager for X
- pkgver = 1.7.1.r6.895dee6
- pkgrel = 2
+ pkgver = 1.7.1.r12.feb97f3
+ pkgrel = 1
url = http://github.com/edio/randrctl
install = randrctl.install
arch = any
@@ -10,8 +10,8 @@ pkgbase = randrctl-git
makedepends = python-pip
depends = python
depends = python-argcomplete
- depends = python-pyyaml
depends = python-setuptools
+ depends = python-yaml
depends = xorg-xrandr
optdepends = bash-completion
provides = randrctl
@@ -19,7 +19,7 @@ pkgbase = randrctl-git
source = git+https://github.com/edio/randrctl.git
source = completion
md5sums = SKIP
- md5sums = 0557733f74c7724ac0680e6166807b83
+ md5sums = 3d815420a33e62aa25b011f19d812a07
pkgname = randrctl-git
diff --git a/PKGBUILD b/PKGBUILD
index f1281a215f20..f09cefbaa297 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,22 @@
_gitname=randrctl
pkgname=$_gitname-git
pkgdesc="Lightweight profile based screen manager for X"
-pkgver=1.7.1.r6.895dee6
-pkgrel=2
+pkgver=1.7.1.r12.feb97f3
+pkgrel=1
arch=('any')
url="http://github.com/edio/randrctl"
license=('GPL3')
makedepends=('git' 'python-pip')
-depends=('python' 'python-argcomplete' 'python-pyyaml' 'python-setuptools' 'xorg-xrandr')
+depends=('python' 'python-argcomplete' 'python-setuptools' 'python-yaml' 'xorg-xrandr')
optdepends=('bash-completion')
source=(
'git+https://github.com/edio/randrctl.git'
'completion'
)
-md5sums=(
- 'SKIP'
- '0557733f74c7724ac0680e6166807b83'
-)
+
+md5sums=('SKIP'
+ '3d815420a33e62aa25b011f19d812a07')
+
provides=("$_gitname")
conflicts=("$_gitname")
install="randrctl.install"
@@ -35,7 +35,7 @@ package() {
python setup.py install --root="$pkgdir/" --optimize=1
install -Dm644 "$srcdir/completion" "$pkgdir/usr/share/bash-completion/completions/randrctl"
- install -Dm644 "randrctl/misc/99-randrctl.rules" "$pkgdir/usr/lib/rules.d/99-randrctl.rules"
+ install -Dm644 "randrctl/setup/99-randrctl.rules" "$pkgdir/usr/lib/rules.d/99-randrctl.rules"
}
# vim:set ts=2 sw=2 et:
diff --git a/completion b/completion
index 716ad3d9270d..18c4c1b0ab67 100644
--- a/completion
+++ b/completion
@@ -1,4 +1,3 @@
-completion
# Run something, muting output or redirecting it to the debug stream
# depending on the value of _ARC_DEBUG.