summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-file-paths.patch76
-rw-r--r--PKGBUILD6
3 files changed, 45 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 177464678170..08b7b5652ae4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = raze
pkgdesc = Build engine port backed by GZDoom tech
- pkgver = 0.6.0
- pkgrel = 3
+ pkgver = 0.7.3_alpha
+ pkgrel = 1
url = https://github.com/coelckers/Raze
arch = x86_64
license = custom:BUILD
@@ -20,11 +20,11 @@ pkgbase = raze
optdepends = gxmessage: crash dialog (GNOME)
optdepends = kdialog: crash dialog (KDE)
optdepends = xorg-xmessage: crash dialog (other)
- source = Raze::git+https://github.com/coelckers/Raze#tag=0.6.0
+ source = Raze::git+https://github.com/coelckers/Raze#tag=0.7.3_alpha
source = 0001-Fix-file-paths.patch
source = raze.desktop
sha256sums = SKIP
- sha256sums = 09502741573bba7f8f8f91b74ecf88dd82d030ed0b185e72dee1cff51a17ec92
+ sha256sums = 97891d1e02d9d159762af51011d57127960adac6d5b4cd16bba8e3863455d5f2
sha256sums = ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8
pkgname = raze
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
index 9eb97341adcf..cb00e3c5c96b 100644
--- a/0001-Fix-file-paths.patch
+++ b/0001-Fix-file-paths.patch
@@ -1,18 +1,43 @@
-From 31a32f5be1739d5c9bd1c25ebe2b582ce9aa2fe6 Mon Sep 17 00:00:00 2001
+From ab0451141d00d316c98134ab07948942e6357ce8 Mon Sep 17 00:00:00 2001
From: Jan Cholasta <jan@cholasta.net>
Date: Thu, 6 Feb 2020 07:59:18 +0100
Subject: [PATCH] Fix file paths
---
- source/common/gameconfigfile.cpp | 13 +------------
- source/common/gamecontrol.cpp | 2 +-
- source/platform/posix/sdl/i_main.cpp | 14 +-------------
+ source/common/platform/posix/sdl/i_main.cpp | 14 +-------------
+ source/core/gameconfigfile.cpp | 13 +------------
+ source/core/gamecontrol.cpp | 2 +-
3 files changed, 3 insertions(+), 26 deletions(-)
-diff --git a/source/common/gameconfigfile.cpp b/source/common/gameconfigfile.cpp
-index dd4c0889e..ae7d282d4 100644
---- a/source/common/gameconfigfile.cpp
-+++ b/source/common/gameconfigfile.cpp
+diff --git a/source/common/platform/posix/sdl/i_main.cpp b/source/common/platform/posix/sdl/i_main.cpp
+index a984721fc..ddc209e34 100644
+--- a/source/common/platform/posix/sdl/i_main.cpp
++++ b/source/common/platform/posix/sdl/i_main.cpp
+@@ -129,19 +129,7 @@ int main (int argc, char **argv)
+ Args = new FArgs(argc, argv);
+
+ // Should we even be doing anything with progdir on Unix systems?
+- char program[PATH_MAX];
+- if (realpath (argv[0], program) == NULL)
+- strcpy (program, argv[0]);
+- char *slash = strrchr (program, '/');
+- if (slash != NULL)
+- {
+- *(slash + 1) = '\0';
+- progdir = program;
+- }
+- else
+- {
+- progdir = "./";
+- }
++ progdir = "/usr/lib/raze/";
+
+ I_StartupJoysticks();
+
+diff --git a/source/core/gameconfigfile.cpp b/source/core/gameconfigfile.cpp
+index 115c737be..6e8d2f352 100644
+--- a/source/core/gameconfigfile.cpp
++++ b/source/core/gameconfigfile.cpp
@@ -100,15 +100,10 @@ FGameConfigFile::FGameConfigFile ()
// Debian likes them in /usr/share/games/doom
// I assume other distributions don't do anything radically different
@@ -53,11 +78,11 @@ index dd4c0889e..ae7d282d4 100644
#endif
}
-diff --git a/source/common/gamecontrol.cpp b/source/common/gamecontrol.cpp
-index 99bc5ae6d..92e07fd6e 100644
---- a/source/common/gamecontrol.cpp
-+++ b/source/common/gamecontrol.cpp
-@@ -613,7 +613,7 @@ int RunGame()
+diff --git a/source/core/gamecontrol.cpp b/source/core/gamecontrol.cpp
+index ef7d7a427..ae170eb19 100644
+--- a/source/core/gamecontrol.cpp
++++ b/source/core/gamecontrol.cpp
+@@ -776,7 +776,7 @@ int RunGame()
FString logfile = Args->TakeValue("+logfile");
// As long as this engine is still in prerelease mode let's always write a log file.
@@ -66,31 +91,6 @@ index 99bc5ae6d..92e07fd6e 100644
if (logfile.IsNotEmpty())
{
-diff --git a/source/platform/posix/sdl/i_main.cpp b/source/platform/posix/sdl/i_main.cpp
-index b0e2ce978..0c2a2a96e 100644
---- a/source/platform/posix/sdl/i_main.cpp
-+++ b/source/platform/posix/sdl/i_main.cpp
-@@ -121,19 +121,7 @@ int main (int argc, char **argv)
- Args = new FArgs(argc, argv);
-
- // Should we even be doing anything with progdir on Unix systems?
-- char program[PATH_MAX];
-- if (realpath (argv[0], program) == NULL)
-- strcpy (program, argv[0]);
-- char *slash = strrchr (program, '/');
-- if (slash != NULL)
-- {
-- *(slash + 1) = '\0';
-- progdir = program;
-- }
-- else
-- {
-- progdir = "./";
-- }
-+ progdir = "/usr/lib/raze/";
-
- I_StartupJoysticks();
-
--
2.28.0
diff --git a/PKGBUILD b/PKGBUILD
index 6c2036ec233e..61c82fce88cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
pkgname=raze
-pkgver=0.6.0
-pkgrel=3
+pkgver=0.7.3_alpha
+pkgrel=1
pkgdesc='Build engine port backed by GZDoom tech'
arch=('x86_64')
url='https://github.com/coelckers/Raze'
@@ -25,7 +25,7 @@ source=("Raze::git+https://github.com/coelckers/Raze#tag=${pkgver}"
'0001-Fix-file-paths.patch'
'raze.desktop')
sha256sums=('SKIP'
- '09502741573bba7f8f8f91b74ecf88dd82d030ed0b185e72dee1cff51a17ec92'
+ '97891d1e02d9d159762af51011d57127960adac6d5b4cd16bba8e3863455d5f2'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
prepare() {