summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Fix-file-paths.patch14
-rw-r--r--PKGBUILD6
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0edfbfe4421e..826ce34311f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = raze
pkgdesc = Build engine port backed by GZDoom tech
- pkgver = 1.3.1
+ pkgver = 1.4.0
pkgrel = 1
url = https://github.com/coelckers/Raze
arch = x86_64
@@ -20,11 +20,11 @@ pkgbase = raze
optdepends = gxmessage: crash dialog (GNOME)
optdepends = kdialog: crash dialog (KDE)
optdepends = xorg-xmessage: crash dialog (other)
- source = Raze::git+https://github.com/coelckers/Raze#tag=1.3.1
+ source = Raze::git+https://github.com/coelckers/Raze#tag=1,4,0
source = 0001-Fix-file-paths.patch
source = raze.desktop
sha256sums = SKIP
- sha256sums = 5655c8685ebebf8ac7491dda3b4c8efd3b06f979111315df3fd87674dacfa963
+ sha256sums = 889b23ebf89f9d931e870dca99a3f1c665a6e73e09fdf6d427a78a3c7b7e506d
sha256sums = ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8
pkgname = raze
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
index d862910407a1..422303bd297f 100644
--- a/0001-Fix-file-paths.patch
+++ b/0001-Fix-file-paths.patch
@@ -10,13 +10,13 @@ Subject: [PATCH] Fix file paths
3 files changed, 4 insertions(+), 27 deletions(-)
diff --git a/source/common/platform/posix/sdl/i_main.cpp b/source/common/platform/posix/sdl/i_main.cpp
-index a984721fc..ddc209e34 100644
+index a28b90f01..3bd907336 100644
--- a/source/common/platform/posix/sdl/i_main.cpp
+++ b/source/common/platform/posix/sdl/i_main.cpp
-@@ -129,19 +129,7 @@ int main (int argc, char **argv)
- Args = new FArgs(argc, argv);
-
- // Should we even be doing anything with progdir on Unix systems?
+@@ -175,19 +175,7 @@ int main (int argc, char **argv)
+ Args = new FArgs(argc, argv);
+
+ // Should we even be doing anything with progdir on Unix systems?
- char program[PATH_MAX];
- if (realpath (argv[0], program) == NULL)
- strcpy (program, argv[0]);
@@ -31,8 +31,8 @@ index a984721fc..ddc209e34 100644
- progdir = "./";
- }
+ progdir = "/usr/lib/raze/";
-
- I_StartupJoysticks();
+
+ I_StartupJoysticks();
diff --git a/source/core/gameconfigfile.cpp b/source/core/gameconfigfile.cpp
index 115c737be..c83ce70ed 100644
diff --git a/PKGBUILD b/PKGBUILD
index 645228d2147a..d1a584b31a93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jan Cholasta <grubber at grubber cz>
pkgname=raze
-pkgver=1.3.1
+pkgver=1.4.0
pkgrel=1
pkgdesc='Build engine port backed by GZDoom tech'
arch=('x86_64')
@@ -22,11 +22,11 @@ makedepends=('cmake'
optdepends=('gxmessage: crash dialog (GNOME)'
'kdialog: crash dialog (KDE)'
'xorg-xmessage: crash dialog (other)')
-source=("Raze::git+https://github.com/coelckers/Raze#tag=${pkgver}"
+source=("Raze::git+https://github.com/coelckers/Raze#tag=1,4,0"
'0001-Fix-file-paths.patch'
'raze.desktop')
sha256sums=('SKIP'
- '5655c8685ebebf8ac7491dda3b4c8efd3b06f979111315df3fd87674dacfa963'
+ '889b23ebf89f9d931e870dca99a3f1c665a6e73e09fdf6d427a78a3c7b7e506d'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
prepare() {