summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Fix-file-paths.patch77
-rw-r--r--PKGBUILD4
3 files changed, 12 insertions, 75 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d145643d5a2..9ab156ca3560 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = raze
pkgdesc = Build engine port backed by GZDoom tech
- pkgver = 1.5.0
+ pkgver = 1.6.0
pkgrel = 1
url = https://github.com/coelckers/Raze
arch = x86_64
@@ -20,11 +20,11 @@ pkgbase = raze
optdepends = gxmessage: crash dialog (GNOME)
optdepends = kdialog: crash dialog (KDE)
optdepends = xorg-xmessage: crash dialog (other)
- source = Raze::git+https://github.com/coelckers/Raze#tag=1.5.0
+ source = Raze::git+https://github.com/coelckers/Raze#tag=1.6.0
source = 0001-Fix-file-paths.patch
source = raze.desktop
sha256sums = SKIP
- sha256sums = 889b23ebf89f9d931e870dca99a3f1c665a6e73e09fdf6d427a78a3c7b7e506d
+ sha256sums = 6a0584daafa365af02dfc7b823a371e37c28a3740a47a554869888e900edb314
sha256sums = ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8
pkgname = raze
diff --git a/0001-Fix-file-paths.patch b/0001-Fix-file-paths.patch
index 422303bd297f..81667af90a8f 100644
--- a/0001-Fix-file-paths.patch
+++ b/0001-Fix-file-paths.patch
@@ -1,22 +1,9 @@
-From 59d406377474990b43356132a7157eb23ccdcef4 Mon Sep 17 00:00:00 2001
-From: Jan Cholasta <jan@cholasta.net>
-Date: Thu, 6 Feb 2020 07:59:18 +0100
-Subject: [PATCH] Fix file paths
-
----
- source/common/platform/posix/sdl/i_main.cpp | 14 +-------------
- source/core/gameconfigfile.cpp | 15 ++-------------
- source/core/gamecontrol.cpp | 2 +-
- 3 files changed, 4 insertions(+), 27 deletions(-)
-
-diff --git a/source/common/platform/posix/sdl/i_main.cpp b/source/common/platform/posix/sdl/i_main.cpp
-index a28b90f01..3bd907336 100644
--- a/source/common/platform/posix/sdl/i_main.cpp
+++ b/source/common/platform/posix/sdl/i_main.cpp
-@@ -175,19 +175,7 @@ int main (int argc, char **argv)
- Args = new FArgs(argc, argv);
-
- // Should we even be doing anything with progdir on Unix systems?
+@@ -177,19 +177,7 @@
+ #ifdef PROGDIR
+ progdir = PROGDIR;
+ #else
- char program[PATH_MAX];
- if (realpath (argv[0], program) == NULL)
- strcpy (program, argv[0]);
@@ -31,61 +18,13 @@ index a28b90f01..3bd907336 100644
- progdir = "./";
- }
+ progdir = "/usr/lib/raze/";
-
- I_StartupJoysticks();
-
-diff --git a/source/core/gameconfigfile.cpp b/source/core/gameconfigfile.cpp
-index 115c737be..c83ce70ed 100644
---- a/source/core/gameconfigfile.cpp
-+++ b/source/core/gameconfigfile.cpp
-@@ -100,15 +100,10 @@ FGameConfigFile::FGameConfigFile ()
- // Debian likes them in /usr/share/games/doom
- // I assume other distributions don't do anything radically different
- SetValueForKey ("Path", "/usr/share/games/jfduke3d", true);
-- SetValueForKey ("Path", "/usr/local/share/games/jfduke3d", true);
- SetValueForKey ("Path", "/usr/share/games/eduke32", true);
-- SetValueForKey ("Path", "/usr/local/share/games/eduke32", true);
- SetValueForKey ("Path", "/usr/share/games/nblood", true);
-- SetValueForKey ("Path", "/usr/local/share/games/nblood", true);
- SetValueForKey("Path", "/usr/share/games/jfsw", true);
-- SetValueForKey("Path", "/usr/local/share/games/jfsw", true);
- SetValueForKey("Path", "/usr/share/games/voidsw", true);
-- SetValueForKey("Path", "/usr/local/share/games/voidsw", true);
-
#endif
- SetValueForKey ("Path", "$STEAM", true); // also covers GOG.
-@@ -128,13 +123,10 @@ FGameConfigFile::FGameConfigFile ()
- SetValueForKey ("Path", "$GAMEDIR", true);
- #else
- SetValueForKey ("Path", "$HOME/" GAME_DIR, true);
-- SetValueForKey ("Path", SHARE_DIR, true);
-+ SetValueForKey ("Path", "/usr/share/raze", true);
- SetValueForKey ("Path", "/usr/share/games/jfduke3d", true);
-- SetValueForKey ("Path", "/usr/local/share/games/jfduke3d", true);
- SetValueForKey ("Path", "/usr/share/games/eduke32", true);
-- SetValueForKey ("Path", "/usr/local/share/games/eduke32", true);
- SetValueForKey ("Path", "/usr/share/games/nblood", true);
-- SetValueForKey ("Path", "/usr/local/share/games/nblood", true);
- #endif
- }
-
-@@ -151,10 +143,7 @@ FGameConfigFile::FGameConfigFile ()
- SetValueForKey("Path", "$PROGDIR/soundfonts", true);
- #else
- SetValueForKey("Path", "$HOME/" GAME_DIR "/soundfonts", true);
-- SetValueForKey("Path", "/usr/local/share/" GAME_DIR "/soundfonts", true);
-- SetValueForKey("Path", "/usr/local/share/games/" GAME_DIR "/soundfonts", true);
-- SetValueForKey("Path", "/usr/share/" GAME_DIR "/soundfonts", true);
-- SetValueForKey("Path", "/usr/share/games/" GAME_DIR "/soundfonts", true);
-+ SetValueForKey("Path", "/usr/share/" GAMENAMELOWERCASE "/soundfonts", true);
- #endif
- }
+
+ I_StartupJoysticks();
-diff --git a/source/core/gamecontrol.cpp b/source/core/gamecontrol.cpp
-index c034ff152..1ba99a14b 100644
--- a/source/core/gamecontrol.cpp
+++ b/source/core/gamecontrol.cpp
-@@ -823,7 +823,7 @@ int RunGame()
+@@ -1006,7 +1006,7 @@ int RunGame()
FString logfile = Args->TakeValue("+logfile");
// As long as this engine is still in prerelease mode let's always write a log file.
@@ -94,6 +33,4 @@ index c034ff152..1ba99a14b 100644
if (logfile.IsNotEmpty())
{
---
-2.30.0
diff --git a/PKGBUILD b/PKGBUILD
index a0d8bd6257bc..efbaedd5d2b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jan Cholasta <grubber at grubber cz>
pkgname=raze
-pkgver=1.5.0
+pkgver=1.6.0
pkgrel=1
pkgdesc='Build engine port backed by GZDoom tech'
arch=('x86_64')
@@ -26,7 +26,7 @@ source=("Raze::git+https://github.com/coelckers/Raze#tag=${pkgver}"
'0001-Fix-file-paths.patch'
'raze.desktop')
sha256sums=('SKIP'
- '889b23ebf89f9d931e870dca99a3f1c665a6e73e09fdf6d427a78a3c7b7e506d'
+ '6a0584daafa365af02dfc7b823a371e37c28a3740a47a554869888e900edb314'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
prepare() {