summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Fix-build-on-recent-gcc-libstdc.patch44
-rw-r--r--PKGBUILD8
3 files changed, 54 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1616628527de..b5f0b4da5921 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = raze
pkgdesc = Build engine port backed by GZDoom tech
pkgver = 1.7.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/coelckers/Raze
arch = x86_64
license = custom:BUILD
@@ -21,8 +21,10 @@ pkgbase = raze
optdepends = kdialog: crash dialog (KDE)
optdepends = xorg-xmessage: crash dialog (other)
source = Raze::git+https://github.com/coelckers/Raze#tag=1.7.1
+ source = 0001-Fix-build-on-recent-gcc-libstdc.patch
source = raze.desktop
sha256sums = SKIP
+ sha256sums = 9a531bb168ae375b15fb3a6efff9da8a9e6ed5a2834d405dd7b41e8b52e21504
sha256sums = ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8
pkgname = raze
diff --git a/0001-Fix-build-on-recent-gcc-libstdc.patch b/0001-Fix-build-on-recent-gcc-libstdc.patch
new file mode 100644
index 000000000000..3603af5bfedb
--- /dev/null
+++ b/0001-Fix-build-on-recent-gcc-libstdc.patch
@@ -0,0 +1,44 @@
+From 2081cb1d34847b34d0b11020d375619c60529cc7 Mon Sep 17 00:00:00 2001
+From: Brian Koropoff <bkoropoff@gmail.com>
+Date: Sat, 6 May 2023 18:28:55 -0700
+Subject: [PATCH] Fix build on recent gcc/libstdc++
+
+---
+ libraries/ZVulkan/include/zvulkan/vk_mem_alloc/vk_mem_alloc.h | 1 +
+ libraries/ZVulkan/src/vulkanbuilders.cpp | 1 +
+ libraries/ZVulkan/src/vulkanswapchain.cpp | 1 +
+ 3 files changed, 3 insertions(+)
+
+diff --git a/libraries/ZVulkan/include/zvulkan/vk_mem_alloc/vk_mem_alloc.h b/libraries/ZVulkan/include/zvulkan/vk_mem_alloc/vk_mem_alloc.h
+index fd4472286..6091f1b2b 100644
+--- a/libraries/ZVulkan/include/zvulkan/vk_mem_alloc/vk_mem_alloc.h
++++ b/libraries/ZVulkan/include/zvulkan/vk_mem_alloc/vk_mem_alloc.h
+@@ -2162,6 +2162,7 @@ VMA_CALL_PRE void VMA_CALL_POST vmaDestroyImage(
+ #undef VMA_IMPLEMENTATION
+
+ #include <cstdint>
++#include <cstdio>
+ #include <cstdlib>
+ #include <cstring>
+ #include <utility>
+diff --git a/libraries/ZVulkan/src/vulkanbuilders.cpp b/libraries/ZVulkan/src/vulkanbuilders.cpp
+index bfa138080..486ba0caf 100644
+--- a/libraries/ZVulkan/src/vulkanbuilders.cpp
++++ b/libraries/ZVulkan/src/vulkanbuilders.cpp
+@@ -1,3 +1,4 @@
++#include <stdexcept>
+
+ #include "vulkanbuilders.h"
+ #include "vulkansurface.h"
+diff --git a/libraries/ZVulkan/src/vulkanswapchain.cpp b/libraries/ZVulkan/src/vulkanswapchain.cpp
+index 9162109c4..7a5a5378f 100644
+--- a/libraries/ZVulkan/src/vulkanswapchain.cpp
++++ b/libraries/ZVulkan/src/vulkanswapchain.cpp
+@@ -1,3 +1,4 @@
++#include <stdexcept>
+
+ #include "vulkanswapchain.h"
+ #include "vulkanobjects.h"
+--
+2.41.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 88d8d43b4b50..dc105ab13430 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=raze
pkgver=1.7.1
-pkgrel=1
+pkgrel=2
pkgdesc='Build engine port backed by GZDoom tech'
arch=('x86_64')
url='https://github.com/coelckers/Raze'
@@ -23,9 +23,15 @@ optdepends=('gxmessage: crash dialog (GNOME)'
'kdialog: crash dialog (KDE)'
'xorg-xmessage: crash dialog (other)')
source=("Raze::git+https://github.com/coelckers/Raze#tag=${pkgver}"
+ '0001-Fix-build-on-recent-gcc-libstdc.patch'
'raze.desktop')
sha256sums=('SKIP'
+ '9a531bb168ae375b15fb3a6efff9da8a9e6ed5a2834d405dd7b41e8b52e21504'
'ffc02d8f6f0d4464a74e025d41063f2441d9423d4ed605a0290eb266ae9531c8')
+prepare() {
+ cd Raze
+ patch -i "$srcdir"/0001-Fix-build-on-recent-gcc-libstdc.patch -p 1
+}
build() {
cd Raze