summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Patch-from-Debian-803857-to-support-ffmpeg-2.9.patch42
-rw-r--r--PKGBUILD20
3 files changed, 64 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1f1feb370ac..87f3c2e64d5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Feb 18 17:48:13 UTC 2016
pkgbase = rbdoom-3-bfg
pkgdesc = Doom 3 BFG source code (Robert Beckebans repo).
pkgver = 1.0.3
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/RobertBeckebans/RBDOOM-3-BFG
arch = i686
arch = x86_64
@@ -25,8 +27,10 @@ pkgbase = rbdoom-3-bfg
conflicts = rbdoom3-bfg-git
source = https://github.com/RobertBeckebans/RBDOOM-3-BFG/archive/1.0.3.tar.gz
source = rbdoom-3-bfg.desktop
+ source = 0001-Patch-from-Debian-803857-to-support-ffmpeg-2.9.patch
sha256sums = 961182e741529c0a3634f1892d067b724ddd800cca936522c1d70415789e6bfb
sha256sums = b05a261bd2fd4c1a32788d68397c98e17008d0636bc948edad51d2ebe29f5a8a
+ sha256sums = 1815f68da09bb67abc560fc1ef8e57a572d5b33b919102dc95d80e3369162929
pkgname = rbdoom-3-bfg
diff --git a/0001-Patch-from-Debian-803857-to-support-ffmpeg-2.9.patch b/0001-Patch-from-Debian-803857-to-support-ffmpeg-2.9.patch
new file mode 100644
index 000000000000..11041a66ee3f
--- /dev/null
+++ b/0001-Patch-from-Debian-803857-to-support-ffmpeg-2.9.patch
@@ -0,0 +1,42 @@
+From 42d4d7c7c00389532bf57e91d9c2df15457d0269 Mon Sep 17 00:00:00 2001
+From: y2keeth <y2keeth@yahoo.com>
+Date: Sat, 7 Nov 2015 12:02:59 -0500
+Subject: [PATCH] Patch from Debian #803857 to support ffmpeg 2.9
+
+---
+ neo/renderer/Cinematic.cpp | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/neo/renderer/Cinematic.cpp b/neo/renderer/Cinematic.cpp
+index a9a35a6..3865d0d 100644
+--- a/neo/renderer/Cinematic.cpp
++++ b/neo/renderer/Cinematic.cpp
+@@ -439,8 +439,8 @@ idCinematicLocal::~idCinematicLocal()
+
+ // RB: TODO double check this. It seems we have different versions of ffmpeg on Kubuntu 13.10 and the win32 development files
+ #if defined(_WIN32) || defined(_WIN64)
+- avcodec_free_frame( &frame );
+- avcodec_free_frame( &frame2 );
++ av_frame_free( &frame );
++ av_frame_free( &frame2 );
+ #else
+ av_freep( &frame );
+ av_freep( &frame2 );
+@@ -557,12 +557,12 @@ bool idCinematicLocal::InitFromFFMPEGFile( const char* qpath, bool amilooping )
+ framePos = -1;
+ common->Printf( "Loaded FFMPEG file: '%s', looping=%d%dx%d, %f FPS, %f sec\n", qpath, looping, CIN_WIDTH, CIN_HEIGHT, frameRate, durationSec );
+ image = ( byte* )Mem_Alloc( CIN_WIDTH * CIN_HEIGHT * 4 * 2, TAG_CINEMATIC );
+- avpicture_fill( ( AVPicture* )frame2, image, PIX_FMT_BGR32, CIN_WIDTH, CIN_HEIGHT );
++ avpicture_fill( ( AVPicture* )frame2, image, AV_PIX_FMT_BGR32, CIN_WIDTH, CIN_HEIGHT );
+ if( img_convert_ctx )
+ {
+ sws_freeContext( img_convert_ctx );
+ }
+- img_convert_ctx = sws_getContext( dec_ctx->width, dec_ctx->height, dec_ctx->pix_fmt, CIN_WIDTH, CIN_HEIGHT, PIX_FMT_BGR32, SWS_BICUBIC, NULL, NULL, NULL );
++ img_convert_ctx = sws_getContext( dec_ctx->width, dec_ctx->height, dec_ctx->pix_fmt, CIN_WIDTH, CIN_HEIGHT, AV_PIX_FMT_BGR32, SWS_BICUBIC, NULL, NULL, NULL );
+ status = FMV_PLAY;
+
+ startTime = 0;
+--
+2.7.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 7c1ba1d9f8e2..5f91923d155d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=rbdoom-3-bfg
pkgver=1.0.3
-pkgrel=3
+pkgrel=4
pkgdesc="Doom 3 BFG source code (Robert Beckebans repo)."
arch=('i686' 'x86_64')
url="https://github.com/RobertBeckebans/RBDOOM-3-BFG"
@@ -16,9 +16,23 @@ conflicts=('rbdoom3-bfg-git')
optdepends=('alsa-plugins: pulseaudio-support'
'libpulse: pulseaudio support')
source=("https://github.com/RobertBeckebans/RBDOOM-3-BFG/archive/${pkgver}.tar.gz"
- 'rbdoom-3-bfg.desktop')
+ 'rbdoom-3-bfg.desktop'
+ '0001-Patch-from-Debian-803857-to-support-ffmpeg-2.9.patch')
sha256sums=('961182e741529c0a3634f1892d067b724ddd800cca936522c1d70415789e6bfb'
- 'b05a261bd2fd4c1a32788d68397c98e17008d0636bc948edad51d2ebe29f5a8a')
+ 'b05a261bd2fd4c1a32788d68397c98e17008d0636bc948edad51d2ebe29f5a8a'
+ '1815f68da09bb67abc560fc1ef8e57a572d5b33b919102dc95d80e3369162929')
+
+prepare() {
+ cd "$srcdir/RBDOOM-3-BFG-$pkgver"
+
+ for patch in ../*.patch; do
+ if [ ! -f "$patch" ]; then
+ break;
+ else
+ patch -p1 -i "$patch"
+ fi
+ done
+}
build() {
mkdir "$srcdir/RBDOOM-3-BFG-$pkgver/build"