summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--imgui.patch13
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbd257d0836f..50564454d127 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rbdoom3-bfg-git
pkgdesc = Doom 3 BFG Edition with soft shadows, cleaned up source, Linux and 64 bit Support
- pkgver = r971.42d5436d
+ pkgver = r1354.ee014e80
pkgrel = 1
url = https://github.com/RobertBeckebans/RBDOOM-3-BFG
install = rbdoom3-bfg-git.install
@@ -22,10 +22,11 @@ pkgbase = rbdoom3-bfg-git
source = rbdoom3-bfg-git.desktop
source = doom3bfg.png
source = sdl2-cmake.patch
+ source = imgui.patch
sha256sums = SKIP
sha256sums = a651aa2e71a8a525e66173a8f76b907712b73c950c88f5468ccab79f7533361f
sha256sums = 0fb6a3bb9b47cad65d5012ba20dc9de3b1487f4ac1908ee847e6087511b7f09e
sha256sums = 438993ae976453143d1055fd851e3fd0d48c5309818d485b276e1cfcd6701ce9
+ sha256sums = 632e07d086637cf46b69cadfdae2eb402f4bac954c38133ca7cf2ca9afe94ecf
pkgname = rbdoom3-bfg-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 73b2862f5132..b9171c030387 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zan <zan@420blaze.it>
pkgname=rbdoom3-bfg-git
-pkgver=r971.42d5436d
+pkgver=r1354.ee014e80
pkgrel=1
pkgdesc="Doom 3 BFG Edition with soft shadows, cleaned up source, Linux and 64 bit Support"
arch=(i686 x86_64)
@@ -16,11 +16,13 @@ install=rbdoom3-bfg-git.install
source=("$pkgname::git+https://github.com/RobertBeckebans/RBDOOM-3-BFG.git"
'rbdoom3-bfg-git.desktop'
'doom3bfg.png'
- 'sdl2-cmake.patch')
+ 'sdl2-cmake.patch'
+ 'imgui.patch')
sha256sums=('SKIP'
'a651aa2e71a8a525e66173a8f76b907712b73c950c88f5468ccab79f7533361f'
'0fb6a3bb9b47cad65d5012ba20dc9de3b1487f4ac1908ee847e6087511b7f09e'
- '438993ae976453143d1055fd851e3fd0d48c5309818d485b276e1cfcd6701ce9')
+ '438993ae976453143d1055fd851e3fd0d48c5309818d485b276e1cfcd6701ce9'
+ '632e07d086637cf46b69cadfdae2eb402f4bac954c38133ca7cf2ca9afe94ecf')
pkgver() {
cd "$pkgname"
@@ -30,6 +32,7 @@ pkgver() {
prepare() {
cd "$pkgname"
patch -p1 -i "$srcdir/sdl2-cmake.patch"
+ patch -p1 -i "$srcdir/imgui.patch"
}
build() {
diff --git a/imgui.patch b/imgui.patch
new file mode 100644
index 000000000000..2c32a3b00166
--- /dev/null
+++ b/imgui.patch
@@ -0,0 +1,13 @@
+diff --git a/neo/renderer/OpenGL/RenderBackend_GL.cpp b/neo/renderer/OpenGL/RenderBackend_GL.cpp
+index 259cae86..6b251191 100644
+--- a/neo/renderer/OpenGL/RenderBackend_GL.cpp
++++ b/neo/renderer/OpenGL/RenderBackend_GL.cpp
+@@ -48,7 +48,7 @@ If you have questions concerning this license or the applicable additional terms
+ #include "../RenderBackend.h"
+ #include "../../framework/Common_local.h"
+
+-#include "../../imgui/imgui.h"
++#include "../../imgui/BFGimgui.h"
+
+ idCVar r_drawFlickerBox( "r_drawFlickerBox", "0", CVAR_RENDERER | CVAR_BOOL, "visual test for dropping frames" );
+ idCVar stereoRender_warp( "stereoRender_warp", "0", CVAR_RENDERER | CVAR_ARCHIVE | CVAR_BOOL, "use the optical warping renderprog instead of stereoDeGhost" );