summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ebb400e44b4a..a62fbc9ba0a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = react-native-cli
pkgdesc = The React Native CLI tools
pkgver = 2.0.1
- pkgrel = 1
+ pkgrel = 2
url = http://facebook.github.io/react-native/
arch = any
license = BSD-3-Clause
makedepends = npm
depends = nodejs
+ options = !emptydirs
pkgname = react-native-cli
diff --git a/PKGBUILD b/PKGBUILD
index a02aaf986260..a655ed0ef9f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: farwayer <farwayer@gmail.com>
pkgname=react-native-cli
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="The React Native CLI tools"
arch=(any)
url="http://facebook.github.io/react-native/"
license=('BSD-3-Clause')
depends=('nodejs')
makedepends=('npm')
+options=('!emptydirs')
package() {
- npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
+ npm install -g --prefix "$pkgdir/usr" --cache "$srcdir/npm-cache" $pkgname@$pkgver
+ find "$pkgdir/usr" -type d -exec chmod 755 {} +
}