summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD9
-rwxr-xr-xupdate_helper.sh2
4 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30f9b7bce042..7b35ee5e891f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = red-nightly-bin
pkgdesc = Red is a next-generation programming language strongly inspired by Rebol
- pkgver = r4444.08may23.652d66a4f
+ pkgver = r4777.05apr24.9516a4b66
pkgrel = 1
url = https://www.red-lang.org
arch = x86_64
@@ -15,10 +15,10 @@ pkgbase = red-nightly-bin
conflicts = red
conflicts = ed
options = !strip
- source = https://static.red-lang.org/dl/auto/linux/red-08may23-652d66a4f
+ source = https://static.red-lang.org/dl/auto/linux/red-05apr24-9516a4b66
source = https://raw.githubusercontent.com/red/red/master/BSL-License.txt
source = https://raw.githubusercontent.com/red/red/master/BSD-3-License.txt
- sha256sums = 2db3039df8cd8f398292ab690046705f00fcc5230fc80c89d6f0c96c54c0959d
+ sha256sums = 5382969815fd43faf3a19cd85f2750571c4885235535e87bb2762a92d2528d8a
sha256sums = c9bff75738922193e67fa726fa225535870d2aa1059f91452c411736284ad566
sha256sums = e64d257131093ad15b757d19181e02e3a48a2cccabe14aebf153e91a5a3735a8
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3b317cb3796a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+red-nightly-bin-*
diff --git a/PKGBUILD b/PKGBUILD
index 734c315e0062..911abe28a1be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Maciej Łoziński <maciej@robotix-lozinski.pl>
pkgname="red-nightly-bin"
-pkgver=r4444.08may23.652d66a4f
+pkgver=r4777.05apr24.9516a4b66
pkgrel=1
pkgdesc="Red is a next-generation programming language strongly inspired by Rebol"
arch=(x86_64)
@@ -15,12 +15,13 @@ optdepends=(
provides=(red)
conflicts=(red ed)
options=(!strip)
+_filename="red-05apr24-9516a4b66"
source=(
- "https://static.red-lang.org/dl/auto/linux/red-08may23-652d66a4f"
+ "https://static.red-lang.org/dl/auto/linux/$_filename"
"https://raw.githubusercontent.com/red/red/master/BSL-License.txt"
"https://raw.githubusercontent.com/red/red/master/BSD-3-License.txt")
sha256sums=(
- '2db3039df8cd8f398292ab690046705f00fcc5230fc80c89d6f0c96c54c0959d'
+ '5382969815fd43faf3a19cd85f2750571c4885235535e87bb2762a92d2528d8a'
'c9bff75738922193e67fa726fa225535870d2aa1059f91452c411736284ad566'
'e64d257131093ad15b757d19181e02e3a48a2cccabe14aebf153e91a5a3735a8')
@@ -28,7 +29,7 @@ sha256sums=(
package() {
cd "$srcdir"
- install -Dm755 red-08may23-652d66a4f "$pkgdir/usr/bin/red"
+ install -Dm755 "$_filename" "$pkgdir/usr/bin/red"
install -dm755 "${pkgdir}/usr/share/licenses/$pkgname"
install -Dm644 BSL-License.txt "$pkgdir/usr/share/licenses/$pkgname/BSL-License.txt"
diff --git a/update_helper.sh b/update_helper.sh
index 664d76bc7f3f..eb54ac6c157e 100755
--- a/update_helper.sh
+++ b/update_helper.sh
@@ -12,7 +12,7 @@ wget -q https://static.red-lang.org/download.html
_date=$( grep -P '/dl/auto/linux/red-\K([0-9]{2}[a-z]{3}[0-9]{2})' -o download.html )
_commit=$( grep -P '/dl/auto/linux/red-[0-9]{2}[a-z]{3}[0-9]{2}-\K([0-9a-f]*)' -o download.html )
_filename="red-$_date-$_commit"
-echo -e "____ filename:\t $_filename"
+echo -e "____ _filename:\t $_filename"
echo "downloading $_filename ..."
wget -q "https://static.red-lang.org/dl/auto/linux/$_filename"